Steam won't stop (shut down) or use GPU on games

Hello everyone

I have at least two problem with steam at the moment.

  1. Games have not always launched as in this post (but today Deus-EX launched, so maybe the steam update this morning has fixed that, will provide more info about that when I have tried more games).
  2. Steam will not use GPU (I have nvidia-driver-450xx-prime installed, more info in inxi below). I run steam from Lutris, where I have enabled NVIDIA prime render offload, and Use discrete graphics. I can not enable Feral gamemode.
    3. Steam will not shut down at all. I started Steam with terminal to see what might be the cause. I copied termial output from approx when I selected Exit Steam (closing terminal solves this, but if I don't run it from termianl, steam won't shut down).
    No 3 does no longer apply, Steam has started to shut down on first try.

I have finally remembered gdm-prime and have installed that, so maybe I will be able to use GPU.

In the process of getting read/write privilege on the just formatted external HDD so I can install some games and check it out.

No cached sticky mapping in ActivateActionSet.[0930/] Crash reporting enabled for process: renderer
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
[0930/] Invalid resolutions constraints: 0x0 must not be greater than 0x0; and also within media::limits.
/data/src/common/pipes.cpp (843) : Assertion Failed: stalled cross-thread pipe
Installing breakpad exception handler for appid(gameoverlayui)/version(1.0)
assert_20200930090501_6.dmp[3216]: Uploading dump (out-of-process)
/data/src/clientdll/steamclient.cpp (821) : Assertion Failed: bufRet.TellPut() == sizeof(uint8)
assert_20200930090501_6.dmp[3216]: Finished uploading minidump (out-of-process): success = yes
assert_20200930090501_6.dmp[3216]: response: Discarded=1
assert_20200930090501_6.dmp[3216]: file ''/tmp/dumps/assert_20200930090501_6.dmp'', upload yes: ''Discarded=1''
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down
Thread "CJobMgr::m_WorkThreadPool:2" (ID 2167) failed to shut down

Haven’t had any luck finding this on the internet yet.

inxi -Fazy
[olividir@HP ~]$ inxi -Fazy
  Kernel: 5.8.6-1-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=f90c1ec5-7cd7-47fb-bf4b-d2eb2320d764 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.19.5 tk: Qt 5.15.0 wm: kwin_x11 dm: SDDM 
  Distro: Manjaro Linux 
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 15-cx0xxx 
  v: Type1ProductConfigId serial: <filter> Chassis: type: 10 serial: <filter> 
  Mobo: HP model: 8478 v: 70.57 serial: <filter> UEFI: Insyde v: F.22 
  date: 04/21/2020 
  ID-1: BAT1 charge: 35.7 Wh condition: 37.6/52.8 Wh (71%) volts: 12.8/11.6 
  model: Hewlett-Packard PABAS0241231 type: Li-ion serial: <filter> 
  status: Unknown 
  Topology: Quad Core model: Intel Core i5-8300H bits: 64 type: MT MCP 
  arch: Kaby Lake family: 6 model-id: 9E (158) stepping: A (10) microcode: D6 
  L2 cache: 8192 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 36812 
  Speed: 884 MHz min/max: 800/4000 MHz Core speeds (MHz): 1: 884 2: 844 3: 821 
  4: 820 5: 867 6: 870 7: 863 8: 878 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: conditional, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel UHD Graphics 630 vendor: Hewlett-Packard driver: i915 
  v: kernel bus ID: 00:02.0 chip ID: 8086:3e9b 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: Hewlett-Packard 
  driver: nvidia v: 450.66 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1c8d 
  Device-3: Cheng Uei Precision Industry (Foxlink) HP Wide Vision HD 
  Integrated Webcam 
  type: USB driver: uvcvideo bus ID: 1-5:5 chip ID: 05c8:03bc 
  Display: x11 server: X.Org 1.20.8 compositor: kwin_x11 
  driver: modesetting,nvidia unloaded: intel,nouveau alternate: fbdev,nv,vesa 
  display ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP-1 res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") 
  diag: 394mm (15.5") 
  OpenGL: renderer: Mesa Intel UHD Graphics 630 (CFL GT2) v: 4.6 Mesa 20.1.7 
  direct render: Yes 
  Device-1: Intel Cannon Lake PCH cAVS vendor: Hewlett-Packard 
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci 
  bus ID: 00:1f.3 chip ID: 8086:a348 
  Sound Server: ALSA v: k5.8.6-1-MANJARO 
  Device-1: Realtek RTL8822BE 802.11a/b/g/n/ac WiFi adapter 
  vendor: Hewlett-Packard driver: rtw_8822be v: N/A modules: rtw88_8822be 
  port: 4000 bus ID: 02:00.0 chip ID: 10ec:b822 
  IF: wlo1 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus ID: 05:00.0 
  chip ID: 10ec:8168 
  IF: eno1 state: down mac: <filter> 
  Local Storage: total: 1.60 TiB used: 334.95 GiB (20.5%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 vendor: Samsung model: MZVLW256HEHP-000H1 
  size: 238.47 GiB block size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 serial: <filter> rev: CXB73H1Q scheme: GPT 
  ID-2: /dev/sda type: USB vendor: Toshiba model: External USB 3.0 
  size: 931.51 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 5438 scheme: MBR 
  ID-3: /dev/sdb type: USB vendor: Western Digital model: WD My Passport 0740 
  size: 465.73 GiB block size: physical: 512 B logical: 512 B serial: <filter> 
  rev: 1007 
  ID-1: / raw size: 238.17 GiB size: 233.43 GiB (98.01%) 
  used: 64.44 GiB (27.6%) fs: ext4 dev: /dev/nvme0n1p2 
  Alert: No Swap data was found. 
  System Temperatures: cpu: 52.0 C mobo: 29.8 C 
  Fan Speeds (RPM): N/A 
  Processes: 265 Uptime: 20m Memory: 15.53 GiB used: 2.03 GiB (13.1%) 
  Init: systemd v: 246 Compilers: gcc: 10.2.0 alt: 9 clang: 10.0.1 
  Packages: 1340 pacman: 1317 lib: 368 flatpak: 13 snap: 10 Shell: Bash 
  v: 5.0.18 running in: konsole inxi: 3.1.05 

If anyone can help, I would really appreciate it. And will provide all info needed to solve this case

I think i had the same problem
just click again on stop

thats what i do

Yeah, I tried that, didn’t work.

Steam seems to have started to shut down on first attempt. Have no idea what changed, haven’t changed any settings. So that is ok now.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.