Steam symbol lookup error libxcb-dri3

inxi output

When trying to run steam from my whisker menu (on xfce4) nothing happens, so I tried running steam from terminal and received the following error message. I have a very recent install of Manjaro and have not done any changes to my system aside from regular updates so it’s very odd to me that this is happening.

$ steam
Repairing installation, linking /home/vigenere/.steam/steam to /home/vigenere/.local/share/Steam
Running Steam on manjarolinux 17.0.2 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(0)
/home/vigenere/.local/share/Steam/ubuntu12_32/steam: symbol lookup error: /usr/lib32/libxcb-dri3.so.0: undefined symbol: xcb_send_request_with_fds
/home/vigenere/.local/share/Steam/steam.sh: line 444: no match: ssfn*

From this arch wiki page it suggests that I “disable dri3 in xorg config file or as a workaround run steam with LIBGL_DRI3_DISABLE=1”. How would I do this in the xorg config file?

As of now, steam only opens when I run it in terminal with the following command:

$ LIBGL_DRI3_DISABLE=1 steam

Probably good idea to edit the steam icon to run LIBGL_DRI3_DISABLE=1 steam command instead disabling dri3 in xorg config file…

try

steam --reset
steam_install_workaround
#-- wait for installation, login, close steam
steam
1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark