Steam not starting after updating to newer nvidia driver

Hello

After fiddling with it for a while i figured i seek help from fellow Manjaro users. I’ve been fighting my NVIDIA driver not wanting to update. I however finally managed to update it using the mhwd in through console to version 450xx. After updating the driver i of course installed the utils etc.

But now I’m having problems with Steam not starting at all & Lutris not being able to boot any games.

I tried force removing steam and reinstalling steam using.

pacman -Rns steam-native steam-manjaro
pacman -Syu steam-manjaro

Still no luck, so i tried starting steam through the console and posting the logs to a log file, using
steam &> ~/steam.log

And here’s what i get, while steam does not start at all…

Running Steam on manjarolinux 20.1.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins potentially out-of-date, rebuilding...
Can't find 'steam-runtime-check-requirements', continuing anyway
/home/mikkel/.local/share/Steam/ubuntu12_32/steam

Any suggestions?

Change to 455 drivers or wait for the 32bits libraries to be brought to the proper version (issue in the 450 drivers currently).

2 Likes

I’ll give it a go with 455xx then and get back to you :slight_smile:

Jesus, after all that fighting i cannot believe how easy that was.
Due to a stupid bug in the driver…

Thank you alot, steam booted right up after that update :sweat_smile:

The issue is actually not the drivers, it is on Manjaro side, there was an issue with 450 drivers where all packages were not at same version so people couldn’t even install it, and now they can install it but there is still two package on previous version 450.66 instead of 450.80 so it creates issues. I tried to have it look at yesterday but the packager probably still didn’t have time yet.

2 Likes

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.