Steam not running

Hiya! Today when trying to start Steam, I noticed that it did not want to run. Running it in the terminal, I got the following output:

steam.sh[3247]: Running Steam on manjarolinux 24.0.2 64-bit
steam.sh[3247]: STEAM_RUNTIME is enabled automatically
setup.sh[3320]: Steam runtime environment up-to-date!
steam.sh[3247]: Steam client's requirements are satisfied

After which it immediately terminates without error. Running steam --reset gave the same output (up to the numbers after .sh changing). Trying to reinstall steam also did not change anything.

The last time I know for sure that steam worked was the 18th, with the lack of any other information, I suspect it was broken by some updated package. The updates I have run within the time-frame are as follows:

This, however, is where I get stuck; I can’t know for sure that any of these updates were the cause, neither do I don’t know how to roll back these updates to check, nor if that’s even what I want to do here.

Other information:

KDE plasma 6.0.5
KDE frameworks: 6.2.0
Qt: 6.7.1
Kernel: 6.9.3-3-MANJARO (64-bit)
Graphics platform: X11

CPU: AMD Ryzen 7 7840HS
iGPU: Radeon 780M
dGPU: Nvidia 4060 laptop
RAM: 1 x 16 GB DDR5 5600, 1 x 8 GB DDR5 5600
Display: 2560 x 1600 at 165 Hz.

Thanks in advance for helping!

What do you mean?

All packages should be updated at once.

But I do notice this thread is marked AUR and some of those listed packages are also AUR…

So are we talking about a foreign package? Or is it steam from the repositories?

My apologies for not being clear.

All packages should be updated at once.

Perhaps it’s bad practice then, but when I see that there’s packages with an update, I generally just update them. I saw that archlinux-keyring and minecraft-launcher had an update on the 18th, so I updated them then. Same with inxi on the 19th, etc. The list shown contains all package changes that have happened from the 18th till now.

Or is it steam from the repositories?

The steam install is from the official repositories.

[…] some of those listed packages are also AUR…

Some of the packages I have installed are from the AUR. What I suspected might have happened is that one of those AUR packages had a dependency that steam also had somewhere down the chain, and that there is some incompatibility there.

Maybe I am wrong about that, however, and mis-tagged the post because of that. Like I said though, I would have no idea what else might have caused this otherwise.

From what command? I have never seen such little output from Steam. It produces much more than that no matter if it has an error or not.

1 Like

Literally inputting steam into the terminal:

The output is the same if I use e.g. steam --reset or things like steam steam://run/[game ID].


Moderator edit: Quoted existing output and removed screenshot

Please copy and paste terminal output instead of posting screenshots. I’ve edited your reply accordingly.

Having said that, I believe you. That’s just very odd.

Is the output the same running steam-runtime? Just double-checking as both steam and steam-runtime run the same thing: exec /usr/lib/steam/steam "$@"

Please copy and paste terminal output instead of posting screenshots. I’ve edited your reply accordingly.

Ah, okay, will do!

Is the output the same running steam-runtime?

It is.

The next thing that should run is Steam’s update checker. So possibly something is going wrong there.

Have a look at the logfiles in ~/.local/share/Steam/logs. There are a lot of them so it will be much easier to find the new stuff if you delete everything in that directory first. Then running steam probably won’t create many new log files because it terminates so quickly.

After clearing them out and running the command, the only log there is called console-linux.txt. This contains the following:

srt-logger[4385]: Log opened 2024-06-25 01:42:07+0200
steam.sh[4281]: Steam client's requirements are satisfied

Try journalctl -f for live system log and then run Steam. Anything output there?

The same as in the console, I’m afraid.

If you didnt change anything recently around your system, i guess it would be related to your Steam Background Updates, that Steam silently downloading from time to time.

Did you clean manually your steam folder after uninstalling it?

… I thought I had, but to be sure I went through the motions again and it works now. Thanks for your answers everyone!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.