Steam games won't start

Hello there,

I just tried to revive my old gaming tower, 10 yeares ago it was new. Now I wanted to try Subnautica on it, the game does not start, even though it kind of runs on my lower-spec laptop (Manjaro GNOME). What can I do about it? I got a Radeon HD 6770, dualcore i3, 4Gb RAM, 8GB Swap, 256GB SSD.
What Info do I need to get?

$ pacman -Qqs vulkan

That uses the legacy radeon driver that does not support Vulkan. Subnautica is a DX11 game, so you’re probably out of luck.

Either way, always check ProtonDB for playing Windows games via Proton.

1 Like

On Nobara, it started in OpenGL-Mode, but crashed when starting a new game. Nobara also had some Vulkan-issues and was buggy, so I thougt Manjaro… Is it safe the GPU is too old?

Have you tried the compatibility mode in Steam?

I just set the games to the latest proton version and until now every single game ran.

Also someone told me the following that I have tried and it worked as well:

sudo pacman -Syu base-devel yay
After that…
yay -S proton-ge-custom-bin

After that I ran a game by using following command without the need for Steam to even run:

proton ‘/run/media/(user-name)/(drive)/SteamLibrary/steamapps/common/(game-folder)/game.exe’

Via the latter way I could even start a game from an ntfs partition without it crashing. When running games via Steam it wont work to access the same Steam folder that Win is using.

No vulkan means no vulkan. Vulkan is needed on Linux for gaming modern games, since DirectX is Windows only. If your card was supported by the amdgpu driver instead of the radeon driver, you would have vulkan support, but it is not. OpenGL can work, but not with Dx10/11/12.