Steam games not working with prime dual card driver

When I use latest Proton 5.13-5 for my Steam client to launch Trine 4 it says “An error occurred while updating … (compatibility tool configuration failed)”. I followed suggested link to troubleshooting and tried to restart computer, reinstall steam, install latest NVidia drivers, update system, use stable LTS or latest kernel. Also checked that I have no antivirus, firewall or other interfering software.

When I use Proton 5.0-10 or 4.11-13 or 4.2-9 Trine 4 updates successfully and even tries to start, but ends in black screen with in-game cursors.

About system. It’s just fresh Manjaro Linux installation with 5.4.89-1 recommended LTS kernel, proprietary recommended graphics card drivers and last available in repository Steam client. Graphics card is nVidia Corporation GP107M (GeForce GTX 1050 Ti Mobile). Graphics driver is video-hybrid-intel-nvidia-prime.

When I use video-hybrid-intel-nvidia-390xx-bumblebee driver, have same issue with Proton 5.13-5. But with 5.0-10 it not launches at all. Just Play button appears again in few seconds after click it.

When I use video-nvidia drivers, on Proton 5.0-10 game works fine but main notebook screen is not working, shows static Dell picture from boot.

Trine 4 worked just fine on Ubuntu LTS 18.04 same hardware, so it’s not hardware problems.

Any ideas why it is not working on Prime driver or how to make work main screen with Nvidia only driver?