Steam crashing on launch on Desktop after installing SteamOS-Compositor-Plus

inxi -fxz

  Topology: Quad Core model: Intel Core i7-6700K bits: 64 type: MT MCP 
  arch: Skylake-S rev: 3 L2 cache: 8192 KiB bogomips: 64026 
  Speed: 800 MHz min/max: 800/4200 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 800 5: 800 6: 800 7: 801 8: 800 
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat arch_perfmon 
  art avx avx2 bmi1 bmi2 bts clflush clflushopt cmov constant_tsc cpuid 
  cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts ept ept_ad erms est f16c 
  flexpriority flush_l1d fma fpu fsgsbase fxsr hle ht hwp hwp_act_window 
  hwp_epp hwp_notify ibpb ibrs ida intel_pt invpcid invpcid_single lahf_lm 
  lm mca mce md_clear mmx monitor movbe mpx msr mtrr nonstop_tsc nopl nx pae 
  pat pbe pcid pclmulqdq pdcm pdpe1gb pebs pge pln pni popcnt pse pse36 pti 
  pts rdrand rdseed rdtscp rep_good rtm sdbg sep smap smep ss ssbd sse sse2 
  sse4_1 sse4_2 ssse3 stibp syscall tm tm2 tpr_shadow tsc tsc_adjust 
  tsc_deadline_timer vme vmx vnmi vpid x2apic xgetbv1 xsave xsavec xsaveopt 
  xsaves xtopology xtpr

lspci -vnn | grep AMD

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] [1002:67df] (rev ef) (prog-if 00 [VGA controller])

01:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590] [1002:aaf0]

Hello all,

it’s been a while since I’ve posted on the forums so if I have the commands incorrect from what they should be please feel free to let me know which ones I should use and I’ll append them. I’ve uploaded my system info above with the commands I remember.

What’s not shown is that the AMD graphics card has amdgpu as its graphics driver and snd_hda_intel as its sound driver, but neither one of those are affected otherwise with steam so I think that’s irrelevant.

What I do want to preface, however, is that I can’t seem to boot into steam from the Desktop but I can through steamos-compositor-plus, which I have installed and configured already.

Running through the desktop causes the application to segfault. The only information I could find about this is for NVIDIA GPUs which I don’t have one on my manjaro system anymore nor should this installation of Manjaro contain NVIDIA packages (I formatted a while ago).

I don’t remember where steam carries its main log file(s) on Linux, but this is what I got from the terminal.

I also noticed adwaita is missing to whatever extent that’s applicable, but I don’t think that’s the issue either.

Can someone help me please? Thanks!

As a test, I deleted the .steam folder (there wasn’t anything in there anyway, I keep my games in another directory) and reinstalled steam-manjaro. Solved!

Edit: I do keep my games in steamapps, actually. i was thinking of windows.

I also meant the .steam folder, not steamapps.

Unmarked as solution, this only works if steamos-compositor is not installed, as suspected.

Right … so … its all in the thread title.
“I installed this package, things stop working”. >> “I uninstall this third party package and things work again”
Not much of a solve :wink:



Strangest part is this package is exactly one of the two that the arch wiki recommends for big picture mode on OS boot. Nowhere does it mention that your desktop instance will become useless when installed so I’m guessing it’s a bug.

edit: see here, under Big Picture Mode without a window manager.

They are AUR packages … for all we know you didnt compile them correctly or they are simply out of date.
(for example … steamos-compositor-plus hasnt seen an update in ~4 months)

PS. How does the manual desktop file method work for you?

I’m guessing the latter. I installed through yay and there’s no indication anywhere on the AUR package website that I should do otherwise.

Works as expected…and that’s exactly the problem.

If you look at that method, you’ll see that you can’t control big picture that way with a keyboard or gamepad. That is an understatement for how useless Big PIcture is without either of those two functions if I’ve ever seen an understatement for big picture. i.e. big picture is intended for… well… big picture screens i.e. TVs. Now picture in your mind using a mouse sitting on a couch with something like this. I’m guessing it doesn’t sit right with you and it shouldn’t.

If I have no other alternative I’m just keeping the desktop client and creating a boot script that puts me in big picture on its own (i.e. no better than how windows handles it). that way with a display manager, but no way in heck am I using big picture mode with the application .desktop shortcut.

Ah fair enough.
I wonder how far you could get banging at the package
(I checked … nothing new in the github project)
Or conversely … I guess a test would be trying steam-native in conjunction to see if it makes a difference.

I can’t believe that actually worked. I thought I had tried that. There must be some weird difference in when I tested before and now.

(Hopefully this doesn’t bite me like it did last time, Steam says it’s open with the steamos compositor but I’m still doubtful

Hah. Well report back when it does … or doesnt I guess.
It would be somewhat interesting to see where the difference/breakage point is.
But … well, no such setup for me here to test. Maybe someone else will come along and like to play.

unmarked as the solution. It appears to be an issue with my steamapps folder.

For clarity, when I said I keep my games in another dir I was thinking about windows when it was needed. That’s my own fault for making that mistake!

Edit: it was working for like a minute after I installed steam-native and now it’s not. I can’t find the source of the issue.

Yea, I think this is part of a deeper issue with my OS and I don’t really have time to be spending forever debugging this so I’m probably going to give GamerOS a spin.

Sorry about this

cheers. good luck.

1 Like