Steam can't work correctly without STEAM_RUNTIME=1 anymore?

I noticied that recently(Yeah I know that’s not accurate :blush:) steam was unable to show store or profile page (anything http related) so I launched it via terminal and seen this error when attempting to connect:

./steamwebhelper: error while loading shared libraries: cannot open shared object file: No such file or directory

Just did a symbolic link to the correct library and now:

./steamwebhelper: error while loading shared libraries: cannot open shared object file: No such file or directory

So steam ask for something only available in AUR unless STEAM_RUNTIME=1 is set :partying_face:.


I had to use that myself for some games for at least a few years(?) now.

Nice. :smile:

I can confirm the behaviour. Oh, that ‘lovely’ news popup is black, what a pity. Still it would be nice to be able to view the store, etc.

I haven’t had any problem launching/playing single player games. Not sure if it might effect some multiplayer functions?

Reported here: Manjaro-specific packages which need an update

Using the latest Steam beta, still getting this error.

./steamwebhelper: error while loading shared libraries: cannot open shared object file: No such file or directory

And do it work after making symbolic link ? (need priviledges)

ln -s /usr/lib/ /usr/lib/

If yes need to be updated (Or wait for arch to update pcre).

PS: Can’t test anymore I removed steam-native and I’m too lazy to reinstall :woozy_face:.

Actually I think
sudo ln -s /usr/lib/ /usr/lib/
is better, in case ‘pcre’ package gets updated in the future.

Arch will not be ‘updating’ pcre. It is Debian messing with the soname; the Steam client presumes a Debian base. Arch follows upstream pcre and does not take their packages from Debian. :wink:

Do you have a date on that one?

I’m not sure where I am at, since I think am signed up for the beta client but only just got this update
[2019-03-25 12:03:29] Startup - updater built Mar 21 2019 21:46:57
which seems to predate the post @anon34396487 linked to above.

This update did nothing that addresses the problem on my end…

Okay, Steam seems only to display the correct update version on the next time the client is launched :crazy_face: and I now have

[2019-03-25 12:37:41] Startup - updater built Mar 22 2019 23:57:18
[2019-03-25 12:37:41] Opted in to client beta 'publicbeta' via beta file
You are in the 'publicbeta' client beta.

But still the problem.

Seems the same currently with Arch:

@anon34396487 - has it been fixed for you?

I’m going to play Steam game to see if I have the same issue. I last played one a few weeks ago and didn’t have any problems.

I don’t understand, I was just talking about arch adding the symlink in pcre PKGBUILD instead of manjaro in steam-native.

Outside of Debian does not exist.

Can you please unmark the thread as ‘solved’ since any solution is still pending. The steam fix was for Solus/Gentoo problems and not Arch/Manjaro ones.

There is a temp fix that worked for me in the aur: steam-native-pcre-fix


The AUR fix also worked for me. There are other libraries that Steam is looking for that are included in the AUR PKGBUILD

Can confirm this works for now.

One of the Arch mods (WorMzy) posted a workaround that I like better. First do:

export LD_PRELOAD="/usr/lib/ /usr/lib/"

Presumably recent steam clients are built using Debian version of glib2 that tries to link libraries missing on Arch (and Manjaro).

Still hoping Steam might rebuild their client without these unneeded dependencies… :slightly_frowning_face:


worked for me thanks !

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by