Steam beta client fails to start since today. 32-bit pipewire support missing?

I am getting the following error when starting Steam since todays Steam update:

You are missing the following 32-bit libraries, and Steam may not run:

I did not install pipewire or anything like that manually.

1 Like

What’s the output of:

systemctl --user list-units --type=service --state=running | grep 'pipewire\|pulseaudio


pactl info | grep Server

Second that issue, and no pipewire 32 bit available either. I was surprised to see pipewire at all.

I have the same issue as OP, my results are:

  pipewire.service                    loaded active running Multimedia Service                                          
  pulseaudio.service                  loaded active running Sound Service


 Server String: /run/user/1000/pulse/native
 Server Protocol Version: 34
 Server Name: pulseaudio
 Server Version: 14.2

I was able to start Steam again after installing lib32-pipewire from AUR

Thats a good interim solution for now.

But it does pull in a lot of stuff with it.

EDIT: And now that it starts, it no longer will connect my account.

I don’t have the pipewire service but i didn’t go looking for it. So i don’t know if there’s something i now need to install.

I had it due to enabling flatpack, but I didnt have the 32bit library.

Having the same issue as of today.

1 Like

Just to add more info im on steam beta. And im guessing poVoq is also. This post poped up about the same time as the update to the beta.

1 Like

Yes, sorry. I also use Steam beta.

1 Like

After adding pipewirelib-32 through AUR the Steam Native wont run, stops at account login. But the steam runtime works.

I just had steam try to update steam-beta and it did the same thing. I have the steam-manjaro installed. I too installed the ib32-pipewire from AUR and it works… I am also able to login. I’m glad it’s working but is there a better solution? Just curious. Thanks!


Found a solution in the Steam Beta Update Discussion Feed (steamcommunity .com/groups/SteamClientBeta/announcements/detail/3032590367259099679, sry not allowed to post links).

Delete ‘~/.local/share/Steam/package/beta’
Restart Steam
You still get the message the first time. Then it puts you back on the stable branch and Steam works again.


Beta is fine… until it isn’t :stuck_out_tongue:

1 Like

Related upstream issue:

See this comment:

beta shipped with an outdated runtime, will be fixed in next iteration. still, it’s a good idea to install lib32-pipewire on your host also.

EDIT: Apparently there’s an update to the Steam Runtime now that fixes it, run Steam (Runtime) from your application menu or steam-runtime from the terminal.

EDIT: FS#71005 : [steam-native-runtime] Requires lib32-pipewire to run


Running steam-runtime fixed it for me now.

Using steam-runtime worked for me, thanks Yochanan!

good to know, but getting 32bit binaries for pipewire into the next stable update should be looked into too

The funny thing is that Steam still requires 32-bit libraries TO RUN on 64-bit OS.

That’s because most of the games are actually 32-bit binaries.