Steam and games are broken since the latest upate

Steam freezes when I don't have compositing enabled with kwin. If I enable it, steam works but none of my games go past a black screen/crash. Everything worked fine yesterday with the 430.x and the latest 435 drivers. Ubuntu works with both kde and xfce and with nvidia 430.40.

inxi -Fxxxz:

System:
  Host: impc Kernel: 4.19.69-1-MANJARO x86_64 
  bits: 64 compiler: gcc v: 9.1.0 
  Desktop: Xfce 4.14.1 tk: Gtk 3.24.10 
  info: xfce4-panel wm: xfwm4 dm: SDDM 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: ASRock model: A320M-DGS 
  serial: <filter> 
  UEFI [Legacy]: American Megatrends v: P4.40 
  date: 01/03/2018 
CPU:
  Topology: 6-Core model: AMD Ryzen 5 1600 
  bits: 64 type: MT MCP arch: Zen rev: 1 
  L2 cache: 3072 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 
  sse4_2 sse4a ssse3 svm 
  bogomips: 76673 
  Speed: 1375 MHz min/max: 1550/3200 MHz 
  boost: enabled Core speeds (MHz): 1: 1375 
  2: 1374 3: 1374 4: 1375 5: 1373 6: 1373 
  7: 1374 8: 1373 9: 1374 10: 1375 11: 1375 
  12: 1373 
Graphics:
  Device-1: NVIDIA TU104 [GeForce RTX 2080] 
  vendor: eVga.com. driver: nvidia v: 430.40 
  bus ID: 26:00.0 chip ID: 10de:1e82 
  Display: x11 server: X.Org 1.20.5 
  driver: nvidia resolution: 3840x2160~60Hz 
  OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 
  v: 4.6.0 NVIDIA 430.40 direct render: Yes 
Audio:
  Device-1: NVIDIA vendor: eVga.com. 
  driver: snd_hda_intel v: kernel 
  bus ID: 26:00.1 chip ID: 10de:10f8 
  Device-2: AMD Family 17h HD Audio 
  vendor: ASRock driver: snd_hda_intel v: kernel 
  bus ID: 28:00.3 chip ID: 1022:1457 
  Sound Server: ALSA v: k4.19.69-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI 
  Express Gigabit Ethernet 
  vendor: ASRock driver: r8169 v: kernel 
  port: f000 bus ID: 25:00.0 chip ID: 10ec:8168 
  IF: enp37s0 state: up speed: 100 Mbps 
  duplex: full mac: <filter> 
Drives:
  Local Storage: total: 1.02 TiB 
  used: 706.62 GiB (67.7%) 
  ID-1: /dev/sda vendor: Team model: T2535T120G 
  size: 111.79 GiB speed: 6.0 Gb/s 
  serial: <filter> rev: 6B0 scheme: MBR 
  ID-2: /dev/sdb vendor: Crucial 
  model: CT500MX500SSD1 size: 465.76 GiB 
  speed: 6.0 Gb/s serial: <filter> rev: 023 
  scheme: MBR 
  ID-3: /dev/sdc vendor: Western Digital 
  model: WD5000AAKX-083CA1 size: 465.76 GiB 
  speed: 6.0 Gb/s rotation: 7200 rpm 
  serial: <filter> rev: 1H19 scheme: MBR 
Partition:
  ID-1: / size: 457.45 GiB 
  used: 268.05 GiB (58.6%) fs: ext4 
  dev: /dev/sdb1 
Sensors:
  System Temperatures: cpu: 31.0 C mobo: N/A 
  gpu: nvidia temp: 37 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 24% 
Info:
  Processes: 310 Uptime: 36m Memory: 15.66 GiB 
  used: 1.97 GiB (12.6%) Init: systemd v: 242 
  Compilers: gcc: 9.1.0 Shell: bash v: 5.0.9 
  running in: xfce4-terminal inxi: 3.0.36 

I got these logs:

Running Steam on manjarolinux 18.0.4 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
STEAM_RUNTIME_HEAVY: ./steam-runtime-heavy
[0908/193713.030858:INFO:crash_reporting.cc(242)] Crash reporting enabled for process: browser
[0908/193713.071458:WARNING:crash_reporting.cc(281)] Failed to set crash key: UserID with value: 0
[0908/193713.071512:WARNING:crash_reporting.cc(281)] Failed to set crash key: BuildID with value: 1566425010
[0908/193713.071517:WARNING:crash_reporting.cc(281)] Failed to set crash key: SteamUniverse with value: Public
[0908/193713.071521:WARNING:crash_reporting.cc(281)] Failed to set crash key: Vendor with value: Valve
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
CApplicationManagerPopulateThread took 35 milliseconds to initialize (will have waited on CAppInfoCacheReadFromDiskThread)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
Installing breakpad exception handler for appid(steam)/version(1566431379)
CAppInfoCacheReadFromDiskThread took 121 milliseconds to initialize
Installing breakpad exception handler for appid(steam)/version(1566431379)

** (steam:2866): WARNING **: 19:37:13.458: Unknown device type 14

** (steam:2866): WARNING **: 19:37:13.458: Could not create object for /org/freedesktop/NetworkManager/Devices/1: unknown object type
Installing breakpad exception handler for appid(steam)/version(1566431379)

** (steam:2866): WARNING **: 19:37:13.582: Unknown setting 'proxy'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'route-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'address-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'route-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'address-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'autoconnect-priority'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'interface-name'

** (steam:2866): WARNING **: 19:37:13.582: Unknown setting 'proxy'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'route-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'address-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'route-data'

** (steam:2866): WARNING **: 19:37:13.582: Ignoring invalid property 'address-data'
Installing breakpad exception handler for appid(steam)/version(1566431379)
Fossilize INFO: Overriding serialization path: "/home/steven7/.local/share/Steam/shader_cache_temp_dir_vk_64/fozpipelinesv4/steamapprun_pipeline_cache".
Fatal : VkResult is "ERROR_INITIALIZATION_FAILED" in /home/pgriffais/src/Vulkan/base/VulkanSwapChain.hpp at line 210
vulkandriverquery: /home/pgriffais/src/Vulkan/base/VulkanSwapChain.hpp:210: void VulkanSwapChain::initSurface(xcb_connection_t*, xcb_window_t): Assertion `res == VK_SUCCESS' failed.

OpenGL games work, Vulkan games don't. I reinstalled steam but it didn't help.

Fatal : VkResult is "ERROR_INITIALIZATION_FAILED" in /home/pgriffais/src/Vulkan/base/VulkanSwapChain.hpp at line 210
vulkandriverquery: /home/pgriffais/src/Vulkan/base/VulkanSwapChain.hpp:210: void VulkanSwapChain::initSurface(xcb_connection_t*, xcb_window_t): Assertion `res == VK_SUCCESS' failed.

Seems like there is a problem with vulkan, I remember seeing prompts about the drivers at the update.

Hello there!

First make sure your system is fully up to date sudo pacman-mirrors -f 5 && sudo pacman -Syyu

Can you try updating your kernel to 5.2.11 and also updating your nvidia driver to 435.21? Both of these can be done in the settings app

My system is up to date in that regard. Why do I need the vulkan beta drivers?

Those aren't the vulkan beta drivers, they're the latest nvidia drivers.

It didn't work. First time, my entire desktop froze and I had to hard reset. Second time, steam worked with kwin compositing:on but vulkan games still don't work.

Can you send inxi -G please

Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080] driver: nvidia v: 435.21 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 3840x2160~60Hz 
           OpenGL: renderer: GeForce RTX 2080/PCIe/SSE2 v: 4.6.0 NVIDIA 435.21 

Can you try using steam without the steam native package installed?

I have steam-manjaro-1.0.0.61.5 installed. Don't know what you meant by that.

Do not have steam-native installed?

I never had that. This package worked fine for a long time.

Alright yeah that works pretty well, this is weird. Can you verify you have all the wine dependencies installed then reboot?

sudo pacman -S wine-staging giflib lib32-giflib libpng lib32-libpng libldap lib32-libldap gnutls lib32-gnutls mpg123 lib32-mpg123 openal lib32-openal v4l-utils lib32-v4l-utils libpulse lib32-libpulse libgpg-error lib32-libgpg-error alsa-plugins lib32-alsa-plugins alsa-lib lib32-alsa-lib libjpeg-turbo lib32-libjpeg-turbo sqlite lib32-sqlite libxcomposite lib32-libxcomposite libxinerama lib32-libgcrypt libgcrypt lib32-libxinerama ncurses lib32-ncurses opencl-icd-loader lib32-opencl-icd-loader libxslt lib32-libxslt libva lib32-libva gtk3 lib32-gtk3 gst-plugins-base-libs lib32-gst-plugins-base-libs vulkan-icd-loader lib32-vulkan-icd-loader

Got from here, they list all all wine dependencies: https://github.com/lutris/lutris/wiki/Wine-Dependencies

Whi are you mentioning Kwin compositor on

?

1 Like

I don't use lutris or wine-staging. Steam-native didn't help.

No I didn't mean for you to install steam-native uninstall it. Also those dependencies include vulkan dependencies, which is why I asked to make sure they're installed.

Because steam only works with kwin compositing:on. It's obviously a bug in kwin.

I tried xfce too and I mentioned what I tried so far.

I did, and I'm installing those dependencies now.

1 Like

Once they're done be sure to restart

Forum kindly sponsored by Bytemark