Static noise in headphones

I have pulseaudio, if I plug my headphones I hear static even if nothing is playing. On windows there is no static instead

Most likely cause of static noise in headphones is from ALSA microphone monitor or loopback monitoring of capture inputs(Microphone or Line In)

Check playback controls in alsamixer - use F6 to locate onboard audio device

Ensure any mixer controls for Mic or Line monitoring are muted [MM] - use M to toggle mute state on or off [OO]

If there is also a control for Loopback monitoring, ensure that is set to Disabled - use

1 Like

This is my configuration, still static sound

Are you using USB or audio jack? I’ve had similar issues with USB speakers in past but never with audio jack.

It’s a common jack, not usb

Reduce level for Headphone from 100 to 10 to eliminate any noise from excessive level
and Increase level for Master control to 100

Open a music player and set volume in player to 100%
Play some loud music and adjust Headphone to suitable level
Then use this command to save ALSA mixer settings

sudo alsactl store

I have experimented a little, the static only disappears if I mute the master or the headphone, or the system volume. But if I do, also audio won’t play…

Use this command to suspend PulseAudio

pacmd suspend 1

Check if the noise in headphones stops and remove suspension of PulseAudio

pacmd suspend 0

If noise stops when PulseAudio is suspended post more information about PulseAudio configuration

pulseaudio --dump-conf; pacmd dump

It does not stop, unfortunately. Do you still want the info?

Use this command to stop PulseAudio server

systemctl --user stop pulseaudio.socket pulseaudio.service

Check if the noise is audible in headphones, and then restart PulseAudio

systemctl --user start pulseaudio.socket pulseaudio.service

If the noise does not stop when PulseAudio is stopped, the noise cannot originate from PulseAudio
and more information about PulseAudio is not needed

The static is still audible, I’m sorry.