Static noise Headphones, changing dB in alsamixer doesn't work

Hello everyone!

I have a Dell XPS 13 (9350) with Manjaro XFCE (Kernel 5.4.72) and I have a static noise on headphones all the time. From pavucontrol, there’s no option to fix that. When I was using Ubuntu, this problem could be easily fixed by increasing the dB of headset to 10 in alsamixer. Nevertheless, in Manjaro changing this option doesn’t make any difference on the sound… Any idea on how to improve the sound and stop this static noise?

Thanks guys!


Please be more specific about your device. There are multiple such models. This 3 are known for audio issues, yet the approach to fix them is a bit different:

This is how you provide good information

1 Like

Thanks, I added this information.

Cool, that means you have to do what is mentioned in my first link.

I did, but unfortunately it didn’t solve the problem… The weird thing is that modifying stuff in amixer or alsamixer has no effect at all on the sound. I can turn up and down the ‘Headphone Mic Boost’ on the HDA intel PCH, and it doesn’t change anything. Usually I should listen a high pitch sound if turning it up… Only the master volume has an effect on the sound. I suppose it’s because pulseAudio is the default card over this card but still. I don’t really understand.

Additionally, I saw this message on the bottom of the solution you sent me:

Note: Unfortunately, you must make the same modifications every time the PulseAudio package is updated. Additionally, this will entirely disable the internal microphone.

So… if I need to choose, I prefer to have this white noise than disabling the internal microphone :wink:
I’ve seen it could be a kernel problem or pulseAudio upgrade (sorry, cannot include links).

I upgraded pulseAudio but this made it worse… haha now I have the problem that when I turn on my computer, pavucontrol is not working, and shows this message:
“Establishing connection to PulseAudio. Please wait …” I solved the problem by launching pulseaudio --D command at startup, although not optimal solution.

Any suggestion?


I think you messed with PulseAudio configuration. Restore it to default.

If you manage to resolve with Alsamixer and PulseAudio is resetting the headset-gain, you can try to run a bash script at startup to apply the Alsamixer setting after PulseAudio is started.

Take a look at this one too.

Hello digitalone, thanks for the answer. I tried resetting or playing with the headset-gain with alsamixer. The problem is that it doesn’t matter the gain, it doesn’t have any effect on the noise. So doing a script to turn headset-gain to 10dB will not help. For instance amixer -c0 sset 'Headphone Mic Boost' 10dB has no effect at all. That’s the problem… I think my alsa settings are not being used. I thought maybe there’s a problem with the default card or something?

I already reinstalled pulseaudio and pavucontrol. I even tried the new version in AUR, without result.

If it can help, here the output of pacmd dump | grep -v 'module|source':
### Configuration dump generated at Sat Nov 7 15:05:58 2020

load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore
load-module module-augment-properties
load-module module-switch-on-port-available
load-module module-udev-detect
load-module module-alsa-card device_id="0" name="pci-0000_00_1f.3" card_name="alsa_card.pci-0000_00_1f.3" namereg_fail=false tsched=yes fixed_latency_range=no ignore_dB=no deferred_volume=yes use_ucm=yes avoid_resampling=no card_properties="module-udev-detect.discovered=1"
load-module module-jackdbus-detect channels=2
load-module module-bluetooth-policy
load-module module-bluetooth-discover
load-module module-bluez5-discover
load-module module-dbus-protocol
load-module module-native-protocol-unix
load-module module-gsettings
load-module module-default-device-restore
load-module module-always-sink
load-module module-intended-roles
load-module module-suspend-on-idle
load-module module-console-kit
load-module module-systemd-login
load-module module-position-event-sounds
load-module module-role-cork
load-module module-filter-heuristics
load-module module-filter-apply
load-module module-cli-protocol-unix

set-sink-volume alsa_output.pci-0000_00_1f.3.analog-stereo 0x5351
set-sink-mute alsa_output.pci-0000_00_1f.3.analog-stereo no
suspend-sink alsa_output.pci-0000_00_1f.3.analog-stereo yes

set-source-volume alsa_output.pci-0000_00_1f.3.analog-stereo.monitor 0xe147
set-source-mute alsa_output.pci-0000_00_1f.3.analog-stereo.monitor no
suspend-source alsa_output.pci-0000_00_1f.3.analog-stereo.monitor yes
set-source-volume alsa_input.pci-0000_00_1f.3.analog-stereo 0x50f6
set-source-mute alsa_input.pci-0000_00_1f.3.analog-stereo no
suspend-source alsa_input.pci-0000_00_1f.3.analog-stereo yes

set-card-profile alsa_card.pci-0000_00_1f.3 output:analog-stereo+input:analog-stereo

set-default-sink alsa_output.pci-0000_00_1f.3.analog-stereo
set-default-source alsa_input.pci-0000_00_1f.3.analog-stereo

### EOF

and arecord --list-devices

 **** List of CAPTURE Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC3246 Analog [ALC3246 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Any other possible explanation? Maybe the solution is to reinstall all Alsa and Pulseaudio and related stuff? Because now it got worse… even the microphone doesn’t work with some apps. One of my apps was using the alsa_input.pci[…] and there was no sound.

Cheers and thanks!


For instance, when I change the dB in alsamixer to 10dB; then I check in pacmd list sinks and my base volume is still 0.00dB. I guess that changing the configuration with alsamixer should change the 0.00dB to 10dB. Maybe if I could change the base volume with pactl that could solve the problem, although no idea how to.