start condition failed too Logitech MX Vertical

Hello an good evening. Today its the first time i try bluetooth with my 1 week jung Manjaro (before i was 95% Windows10 user).

I tried post it here but forum tells me "Your post contains a word that's not allowed" (https://www.youtube.com/watch?v=Pa5dm63Si-8)

I dont know wich of the 300 words are problematic.
There for i pasted it in here:
https://etherpad.net/p/ojszHEO2Qx

rfkill list
rfkill: cannot open /dev/rfkill: No such file or directory
rfkill: cannot read /dev/rfkill: Bad file descriptor
[seeh-pc seeh]# 

I tried:

    sudo pacman -S bluez bluez-utils
    sudo modprobe btusb
    sudo systemctl start bluetooth
    sudo systemctl enable bluetooth
    sudo rfkill unblock bluetooth
 bluetooth.service - Bluetooth service
   Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor p
   Active: inactive (dead)
Condition: start condition failed at Fri 
 ConditionPathIsDirectory=/sys/class/bluetooth was not met
     Docs: man:bluetoothd(8)

My System:

  Host: ... Kernel: 5.3.8-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 9.2.0 Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Machine:
  Type: Desktop Mobo: Micro-Star model: MPG X570 GAMING PLUS (MS-7C37) 
  v: 2.0 serial: <root required> UEFI [Legacy]: American Megatrends v: A.40 
  date: 09/10/2019 
CPU:
  Topology: ... AMD Ryzen ... 64 type: MT MCP arch: Zen 
  L2 cache: 4096 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 115233 

I assume your mouse is a bluetooth mouse.

If the system is not picking up your bluetooth it may be because your WiFi is not recognized.

Try searching the forum for you mainbord https://forum.manjaro.org/search?q=MPG%20X570 as it appear to have some general issues.

Bluetooth and WiFi is often tied to the same hardware.

If it is not enabled then rfkill will return messages on device not available.

yes of course. i used the mouse before with windows (other pc).

My motherboard does not have bluetooth. I using the bluetooth dongle delivered by Logitech togheter with the mouse.
image

ok. thanks i will do. and i need a little time too understand what you told me.

If a dongle is provided - are you sure it is bluetooth?

Often Logitech is pairing with a 2.4Ghz receiver - which is not bluetooth.

The reason for suggesting trouble shooting your mainboard is that your mainboard appears to have an onboard wireless device.

mouse supports 2.4Ghz wifi; Bluetooth and USB connections

Logitech Unifying Receiver may need additional packages to control pairing of devices
https://wiki.archlinux.org/index.php/Logitech_Unifying_Receiver

2 Likes

Woks now. what i did:

I bought a belkin mini bluetooth 4.0 usb adapter. 17,99€ . That's it.

image

expect some users will not be happy with suggestion that an £80 mouse requires another £20ish receiver to work.

suspect others will try wifi connection, or just plug in the USB cable, rather than spend more money on a workaround

But I had already spent so much time with it and I was not sure (as a freshman) if I continue trying not to break any more and achieve nothing. So I invested the 18 € and luckily it worked. Maybe I would have spent hours or days with this problem, maybe without success. After all, it may be interesting for others to find that way a option too.

all i see is a request from 3 days ago that i responded to on same day

concern about breaking system over a bluetooth/wifi adaptor seems very strange for a freshman
previously posting off-topic observations about D-Bus and RAID10

I do not understand right? Where is your problem? What you wish for? This is about the problem with my Bloototh ergonomic Mouse. I solved it by buying a new USB dongle. Did not I make that clear? Thanks for your help for me and other Logitech Mouse users.

Forum kindly sponsored by