Starship prompt -

Apparently starship-0.58.0-2 was built with the wrong version of libgit2. Well it doesn’t work. The libgit2 library used in starship v0.58.0 builds with libgit2 v1.2 by default.

It was built against and requires libgit2 1.2.

What do you mean “it doesn’t work”?

❯ starship
starship 0.58.0
Matan Kushner <>
The cross-shell prompt for astronauts. ☄🌌️

    starship <SUBCOMMAND>

    -h, --help       Prints help information
    -V, --version    Prints version information

    bug-report      Create a pre-populated GitHub issue with information about your configuration
    completions     Generate starship shell completions for your shell to stdout
    config          Edit the starship configuration
    explain         Explains the currently showing modules
    help            Prints this message or the help of the given subcommand(s)
    init            Prints the shell function used to execute starship
    module          Prints a specific prompt module
    print-config    Prints the computed starship configuration
    prompt          Prints the full starship prompt
    session         Generate random session key
    timings         Prints timings of all active modules
    toggle          Toggle a given starship module
» starship                                                           
starship: error while loading shared libraries: cannot open shared object file: No such file or directory

Sounds like you may be in a partial upgrade state. You should have libgit2 1:1.2.0-1 installed. Try refreshing your mirrors and making sure you’re fully up to date:

sudo pacman-mirrors -f5 && sudo pacman -Syyu
1 Like

Sorry, I found the error, it was up to me: In addition to the package, I had built starship with cargo, which now caused problems.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.