Ständig Hänger in Plasma seit letztem Update

Hallo,
seit dem letzten Update-Schwall von über 600 Updates vor 4 oder 5 Tagen hängen sich in KDE Plasma ständig die Programme auf. Allerdings nicht gleich nach dem Log-In, sondern erst nach einer Weile oder wenn der Rechner im Ruhemodus war. Das macht sich dann z. B. beim Scrollen bemerkbar: Wenn man hoch- und runterscrollt, hängt sich nach ein paar Sekunden das Programm für etwa 5 -10 Sekunden auf. Anschließend funktioniert es wieder, kurz danach aber wieder nicht. Anständiges Arbeiten ist so quasi unmöglich.
Unter LXQT gibt es das Problem nicht. Es scheint nur KDE Plasma zu betreffen.
Ich habe dann ein Backup von vor dem Update auf meine Festplatte zurückgespielt und dort läuft noch alles wie geschmiert. Ich habe auch getestet, ob das Problem immer nach dem Update auftritt, indem ich es nochmal installiert habe und dort gab es das Problem wieder.

Hat jemand auch dieses Problem und eine Lösung?

Kernel: Linux 5.0.7-1 ??
Kernel 5.1 + 5.2 EOL

inxi -Fxxxza --no-host

Kernel: 5.3.5-1

Ausgabe von inxi -Fxxxza --no-host:

System:    Kernel: 5.3.5-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.2.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.3-x86_64 root=UUID=96f8f85e-9e01-441a-a6c6-2d118b0c17af rw quiet splash 
           radeon.audio=1 quiet resume=UUID=93dfd0af-01d9-4c54-af3a-b7ebb557733d 
           Desktop: KDE Plasma 5.16.5 tk: Qt 5.13.1 wm: kwin_x11 dm: SDDM Distro: Manjaro Linux 
Machine:   Type: Laptop System: Acer product: Aspire E5-576 v: V1.47 serial: <filter> 
           Mobo: KBL model: Ironman_SK v: V1.47 serial: <filter> UEFI [Legacy]: Insyde v: 1.47 date: 09/06/2018 
Battery:   ID-1: BAT1 charge: 39.3 Wh condition: 39.3/41.4 Wh (95%) volts: 17.1/14.8 model: PANASONIC AS16A5K type: Li-ion 
           serial: <filter> status: Full 
           Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185 serial: <filter> charge: 55% (should be ignored) 
           rechargeable: yes status: Discharging 
CPU:       Topology: Dual Core model: Intel Core i7-7500U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: 9 microcode: B4 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 23209 
           Speed: 538 MHz min/max: 400/3500 MHz Core speeds (MHz): 1: 600 2: 600 3: 600 4: 600 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel HD Graphics 620 vendor: Acer Incorporated ALI driver: i915 v: kernel bus ID: 00:02.0 
           chip ID: 8086:5916 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 620 (Kaby Lake GT2) v: 4.5 Mesa 19.2.1 compat-v: 3.0 
           direct render: Yes 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel 
           bus ID: 00:1f.3 chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.3.5-1-MANJARO 
Network:   Device-1: Intel Dual Band Wireless-AC 3168NGW [Stone Peak] driver: iwlwifi v: kernel port: 4040 bus ID: 02:00.0 
           chip ID: 8086:24fb 
           IF: wlp2s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI driver: r8169 
           v: kernel port: 3000 bus ID: 03:00.1 chip ID: 10ec:8168 
           IF: enp3s0f1 state: down mac: <filter> 
Drives:    Local Storage: total: 238.47 GiB used: 142.40 GiB (59.7%) 
           ID-1: /dev/sda vendor: SK Hynix model: HFS256G39TND-N210A size: 238.47 GiB block size: physical: 4096 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 1P10 scheme: MBR 
Partition: ID-1: / raw size: 63.48 GiB size: 62.23 GiB (98.04%) used: 27.89 GiB (44.8%) fs: ext4 block size: 4096 B 
           dev: /dev/sda1 
           ID-2: /home raw size: 24.41 GiB size: 23.91 GiB (97.92%) used: 21.21 GiB (88.7%) fs: ext4 block size: 4096 B 
           dev: /dev/sda3 
           ID-3: swap-1 size: 9.77 GiB used: 0 KiB (0.0%) fs: swap swappiness: 60 (default) cache pressure: 100 (default) 
           dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 45.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 213 Uptime: 1m Memory: 7.66 GiB used: 1.12 GiB (14.6%) Init: systemd v: 242 Compilers: gcc: 9.2.0 
           Shell: bash v: 5.0.11 running in: yakuake inxi: 3.0.36
1 Like

Ich bin da auf unstable aber ohne Störung, kannst du in der konsole mal top oder htop starten um eventuell zu sehen warum es hängt?
In einer extra konsole das Programm öffnen (Browser/Text???) wo es hängt :wink: .

Da hängt dann jedes Programm.

Neustarten, dann sobald etwas hängt folgenes in der Konsole eingeben
sudo journalctl -b0 | curl -s --data-binary @- 'https://paste.c-net.org/'
und den Link zum Pastbin posten.

3 Likes

Hallo eugen-b,
gestern gab es keine Hänger, aber eben wieder.
Hier der Link:
https://paste.c-net.org/CutieBundt
Das Problem scheint meist dann aufzutreten, wenn der Computer im Ruhezustand war. Außerdem passiert es nur in KDE Plasma.

1 Like

Bin einfach mal den Journal mit der Suche nach dem Wort "error" durchgegangen.
Versuch mal den Plasmoid Task Manager zu entfernen.

1 Like

Meinst du KSysGuard? Auf meinem System ist auch der Taskmanager von Xfce installiert.

Ich glaube das führt zu nichts, wenn ich hier mutmaße. Gehe auch die Fehlermeldungen im Journal durch und schau, was es jeweils sein könnte. Vielleicht ist das aktuelle Plasma 5.16.5 noch nicht ganz ausgereift, keine Ahnung.

Hast du das Problem auch? Bei mir kamen letzte Woche über 600 Updates auf einmal und gestern kamen noch 100. Letztere haben das Problem nicht behoben.

Ich denke was @eugen-b damit meinte ist die Anwendung auf dem Desktop zu deaktivieren falls sie läuft, denn danach sieht zumindest die Fehlermeldung aus.

Okt 15 17:41:25 manjaro plasmashell[865]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:347: Unable to assign [undefined] to int
Okt 15 17:41:25 manjaro plasmashell[865]: file:///usr/share/plasma/plasmoids/org.kde.plasma.taskmanager/contents/ui/Task.qml:375: TypeError: Cannot read property 'length' of undefined
1 Like

Ich habe aber im Grunde nie einen Taskmanager in Verwendung. Mit ps -A wird mir auch kein Taskmanager angezeigt.
Um die mögliche Ursache etwas einzugrenzen: Der Fehler tritt auf, nachdem die Updates der letzten Woche installiert wurden. Außerdem erst, nachdem der Computer im Ruhezustand war und nur in KDE Plasma.
Hast du noch irgendeine Idee?

Um den Verursacher einzugrenzen würde ich erst mal einen neuen Benutzer anlegen um zu sehen ob das Problem weiterhin besteht auf dem neuen Account.

1 Like

Okay, ich habe einen neuen Benutzer angelegt und dort gibt es das Problem nicht.

Das ist schon mal gut, da wir jetzt wissen dass es etwas mit der Benutzerkonfiguration zu tun hat.

Versuch mal ~/.local/share/plasma/plasmoids umzubenennen und schau ob der Fehler weiterhin vorhanden ist.

Sollte das nichts helfen, dann greif zum Vorschlaghammer und mache das selbe(umbenennen) oder lösche
~/.config/plasma .
Damit wäre jedoch die eigene Plasma Konfiguration weg und du musst von neu anfangen.

Danach entweder den Computer oder Plasma neu starten
killall plasmashell; kstart5 plasmashell&

Hat leider beides nichts geholfen. Ich habe inzwischen Manjaro neu aufgesetzt und hoffe nun, dass es fortan funktioniert.

Forum kindly sponsored by