StableUpdate 2021-11-19: libzim6 and libzim are in conflict

As already discussed here, I get the conflict libzim6 ./. libzim and actualized the mirrors:
sudo pacman-mirrors --fasttrack && sudo pacman -Syyu

But in difference to the above topic, I already have libzim 7

$ pamac list
libzim                                    7.0.0-1                     community  585,2 kB

Nevertheless, I get this error and can’t update:

Warning: manjaro-hello: Local Version (0.6.7-2) ist newer than extra (0.6.6-9)
:: libzim6 und libzim are in conflict.

This means you can’t have both installed at the same time.
Check what packages require any of those, and probably uninstall those you don’t need.

pacman -Qi libzim libzim6

Thank you @maycne.sonahoz,
libzim is used by kiwix*. Actually, libzim6 is not installed here (as far as I can see)

As mentioned in my first post, I already did
sudo pacman-mirrors --fasttrack && sudo pacman -Syyuu

kiwix-lib specifically has libzim6 as a dependency.

And zim-tools is the only package that require libzim 7.0.


As shown by

pacman -Siip libzim libzim6

Thank you
Strange for me: pamac-manager says for kiwix-lib: depends on libzim >= 6.3.0
What can I do? I don’t like the idea to uninstall kiwix!

Thanks @ admdb: OK, tried again with your version:
sudo pacman-mirrors --fasttrack && sudo pacman -Syyuu
Same result

The extra u simply allows downgrades … such as if you wanted to return from Unstable Branch to Stable branch, and sync with its current ‘older’ packages.
In any case where there is not a lesser version being provided in the repos, the extra u does nothing.

1 Like

Remove zim-tools?

Thanks @maycne.sonahoz, zim-tools actually is not installed here.

Then my guess is kiwix-lib switched its dependency from libzim to libzim6, so your system wants to both update libzim and install libzim6.

A solution would be to explicitly update kiwix-lib and its (new) dependency. It should then ask to replace libzim by libzim6.

sudo pacman -S kiwix-lib libzim6
1 Like

Thank you @maycne.sonahoz,
I fired:

$ sudo pacman -S kiwix-lib libzim6
Searching for conflicts …
:: libzim6 and libzim are in Conflikt. remove libzim? [j/N] j
Packages (3) libzim-6.3.2-1 [Removal]  kiwix-lib-9.4.1-5  libzim6-6.3.2-2

After that:
$ pamac update -a
and it’s running …
… and worked fine. System is actualized, kiwix works fine. Thanks again @maycne.sonahoz

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.