[Stable Update x32] 2018-04-15 - Kernel 4.14, GNOME 3.28.1, catch-up

update
stable
manjaro32

#1

Hello i686ers!

This is a bit of a weird update set given the issues with resetting the repos. Essentially, with this set the three branches are now re-aligned correctly; all packages should be caught up, and all the correct library versions should be in place.

There’s an update to the archlinux32-keyring package. If you haven’t added that to the SyncFirst field in /etc/pacman.conf then you should update that package before updating the rest of the system, e.g.:

sudo pacman -Syy archlinux32-keyring
sudo pacman -Syu

Everything else should be a pretty standard update.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


Available kernels

Series Version
linux316 3.16.56
linux41 4.1.51
linux44 4.4.127
linux49 4.9.93
linux414 4.14.34

archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It’s a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren’t the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren’t as many packagers. If you notice an important package is lagging please report it; at the moment it’s only me packaging for i686:

I’m only packaging current LTS kernels. Any marked as EOL are dropped. I’ll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn’t this meant to be stable?

“Stable” means “infrequently changing”, not “everything will work perfectly all the time”. If you want it to mean everything works, you need to help test the things you’re interested in.

What about installer images?

Phil very kindly updated the preview installer images:

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by anyone who wants to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable.

Full list of changes

This is a comparison to the “recovery set” from a couple of days back. I don’t have a comparison to the previous stable set… :slightly_frowning_face:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
                            linux414            4.14.33-2            4.14.34-1
                    linux414-headers            4.14.33-2            4.14.34-1


:: Different sync package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
                         btrfs-progs           4.15.1-1.0             4.16-1.0
                               glib22.56.0+16+gecabc6e21-1.0           2.56.1-1.0
                          glib2-docs2.56.0+16+gecabc6e21-1.0           2.56.1-1.0
                               gnupg            2.2.5-2.0            2.2.6-1.0
                              libaio            0.3.110-1          0.3.110-1.1
                        libgpg-error             1.28-1.0             1.29-1.0
                          libsystemd           238.51-1.0           238.76-1.0
                       libutil-linux             2.32-2.0             2.32-3.0
                              sqlite           3.23.0-1.0           3.23.1-1.0
                     sqlite-analyzer           3.23.0-1.0           3.23.1-1.0
                          sqlite-doc           3.23.0-1.0           3.23.1-1.0
                          sqlite-tcl           3.23.0-1.0           3.23.1-1.0
                            syslinux             6.03-8.1            6.03-10.0
                             systemd           238.51-1.0           238.76-1.0
                  systemd-sysvcompat           238.51-1.0           238.76-1.0
                          util-linux             2.32-2.0             2.32-3.0


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
             manjaro-wallpapers-18.0                    -              1.0-0.2


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
                            alsa-oss             1.0.28-1            1.1.6-1.0
                          alsa-utils              1.1.5-2            1.1.6-1.0
                              anjuta             3.26.0-1           3.28.0-1.0
                            calligra            3.1.0-3.0            3.1.0-4.0
                              cantor          17.12.3-2.0          17.12.3-3.0
                             cfitsio            3.430-2.0            3.440-1.0
                              cheese             3.26.0-1           3.28.0-1.0
                               clang            5.0.1-2.0            6.0.0-1.0
                               clisp               2.49-6          2.49.93-1.0
                              colord            1.4.2-1.0            1.4.2-3.0
                            composer            1.6.3-1.0            1.6.4-1.0
                        cups-filters           1.20.0-1.0           1.20.3-1.0
                             devhelp           3.26.1-1.0           3.28.1-1.0
                      eclipse-common            4.7.3-1.0          4.7.3.a-1.0
                         eclipse-cpp            4.7.3-1.0          4.7.3.a-1.0
                        eclipse-java            4.7.3-1.0          4.7.3.a-1.0
                  eclipse-javascript            4.7.3-1.0          4.7.3.a-1.0
                         eclipse-jee            4.7.3-1.0          4.7.3.a-1.0
                         eclipse-php            4.7.3-1.0          4.7.3.a-1.0
                                 eog             3.26.2-1           3.28.1-1.0
                            epiphany3.28.0.1+14+g3ef21f143-2.0           3.28.1-1.0
                              evince3.26.0+14+g2a499547-1           3.28.2-1.0
                         flashplugin       29.0.0.113-1.0       29.0.0.140-1.0
                                 gdm           3.28.0-1.0           3.28.1-1.0
                               gedit3.22.1+1+gd21912e3e-1           3.28.1-1.0
                       gnome-builder           3.26.4-1.03.28.0+56+gc5dd7471b-1.0
                         gnome-chess3.28.0+6+g93fa6a2-1.0           3.28.1-1.0
                        gnome-clocks             3.26.1-13.28.0+1+gecbbce8-1.0
                gnome-control-center3.26.2+14+g5ac6a0da6-1           3.28.1-1.0
                       gnome-desktop         1:3.26.2-2.0         1:3.28.1-1.0
                     gnome-documents3.26.2+2+gfa6dd4f5-1.0           3.28.0-1.0
                   gnome-font-viewer             3.26.0-1           3.28.0-1.0
                         gnome-music       1:3.28.0.1-1.0         1:3.28.1-1.0
                       gnome-session             3.26.1-2           3.28.1-1.0
               gnome-settings-daemon             3.26.2-1           3.28.1-1.0
                gnome-sound-recorder3.24.0.1+8+g0b8e221-1           3.28.1-1.0
                    gnome-user-share3.27.90+3+g878737f-1.0           3.28.0-1.0
                              gspell            1.7.1-1.0            1.8.0-1.0
                             gtk-doc             1.27-1.0             1.28-1.0
                            gwenview          17.12.3-1.0          17.12.3-2.0
                                htop            2.1.0-2.0            2.2.0-2.0
                            inkscape           0.92.3-1.0           0.92.3-2.0
                                js52           52.7.0-1.1           52.7.3-1.0
                        jsonrpc-glib             3.26.1-2           3.28.0-1.0
                            kdevelop            5.2.1-2.0            5.2.1-4.0
                               krita            4.0.0-3.0            4.0.1-2.0
                           kuiserver           5.12.4-2.0           5.12.4-3.0
                              libclc0.2.0+374+0c31bd5-2.00.2.0+506+96d10f2-1.0
                           libdazzle           3.28.0-2.0           3.28.1-1.0
                              libgdm           3.28.0-1.0           3.28.1-1.0
                              libgee           0.20.1-1.0           0.20.1-2.0
                         libgweather           3.26.1-1.0           3.28.1-1.0
               libnautilus-extension         3.28.0.1-1.0           3.28.1-1.0
                        libqalculate            2.3.0-1.0            2.4.0-1.0
               libreoffice-fresh-sdk            6.0.3-1.0            6.0.3-1.1
                   libreoffice-still            5.4.5-1.0            5.4.6-1.1
               libreoffice-still-sdk            5.4.6-1.0            5.4.6-1.1
                          libsynctex      2017.44590-13.0      2017.44590-13.1
                   libva-mesa-driver           17.3.6-1.0           18.0.0-2.0
                                 lld            5.0.1-2.0            6.0.0-1.0
                                lldb            5.0.1-2.0            6.0.0-4.0
                                llvm            5.0.1-2.0            6.0.0-4.0
                           llvm-libs            5.0.1-2.0            6.0.0-4.0
                                lmdb             0.9.21-1           0.9.22-1.0
                                mesa           17.3.6-1.0           18.0.0-2.0
                          mesa-vdpau           17.3.6-1.0           18.0.0-2.0
                              mutter3.26.2+43+g77dd1bf63-1.0           3.28.0-1.0
                            nautilus           3.26.2-3.0           3.28.1-1.0
                         opencl-mesa           17.3.6-1.0           18.0.0-2.0
                        pepper-flash       29.0.0.113-1.0       29.0.0.140-1.0
              plasma-wayland-session           5.12.4-2.0           5.12.4-3.0
                    plasma-workspace           5.12.4-2.0           5.12.4-3.0
                             poppler             0.61.1-1           0.63.0-1.0
                        poppler-glib             0.61.1-1           0.63.0-1.0
                         poppler-qt5             0.61.1-1           0.63.0-1.0
                      python-astroid            1.6.1-1.0            1.6.3-1.0
                       python-pylint            1.8.2-2.0            1.8.4-1.0
               python-qscintilla-qt4           2.10.3-1.0           2.10.4-1.0
        python-qscintilla-qt4-common           2.10.3-1.0           2.10.4-1.0
                      python-wstools              0.4.5-1            0.4.8-1.0
                     python2-astroid            1.6.1-1.0            1.6.3-1.0
                      python2-pylint            1.8.2-2.0            1.8.4-1.0
              python2-qscintilla-qt4           2.10.3-1.0           2.10.4-1.0
              python2-qscintilla-qt5           2.10.3-1.0           2.10.4-1.0
                     python2-wstools              0.4.5-1            0.4.8-1.0
                       qalculate-gtk            2.3.0-1.0            2.4.0-1.0
                                 qbs           1.10.1-1.0           1.11.0-3.0
                             qca-qt4            2.1.3-9.0           2.1.3-10.0
                             qca-qt5            2.1.3-9.0           2.1.3-10.0
                                qpdf            7.1.1-1.0            8.0.2-1.0
                      qscintilla-qt4           2.10.3-1.0           2.10.4-1.0
                           qtcreator            4.5.1-1.0            4.6.0-1.0
                                sdl2            2.0.8-7.0            2.0.8-8.0
                                 srt            1.2.3-1.0            1.3.0-1.0
                                step          17.12.3-2.0          17.12.3-3.0
                          swell-foop3.28.0+2+g434fa58-1.03.28.0+5+g097a72c-1.0
                             sysprof           3.28.0-1.0           3.28.1-1.0
                              talloc           2.1.12-1.0           2.1.13-1.0
                        texlive-core       2017.46770-1.0       2017.46770-1.1
                               totem 3.26.0+1+g4e309671-13.26.0+37+g84700147-1.0
                                vala           0.38.8-1.0           0.40.3-1.0
                       vulkan-radeon           17.3.6-1.0           18.0.0-2.0
                          webkit2gtk           2.20.0-2.0           2.20.1-1.0
                 xf86-input-libinput           0.27.0-2.0           0.27.1-1.0
                                xfig            3.2.6-2.0          3.2.6.a-1.0
                         xorg-server1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                  xorg-server-common1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                   xorg-server-devel1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                    xorg-server-xdmx1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                  xorg-server-xephyr1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                   xorg-server-xnest1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                    xorg-server-xvfb1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                xorg-server-xwayland1.19.6+13+gd0d1a694f-1.01.19.6+13+gd0d1a694f-2.0
                                yelp           3.28.0-1.0           3.28.1-1.0
                              zenity           3.28.0-1.0           3.28.1-1.0
                                 zsh            5.4.2-2.0              5.5-1.0
                             zsh-doc            5.4.2-2.0              5.5-1.0


:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
           adapta-black-breath-theme         3.93.0.225-1         3.93.0.244-1
             adapta-black-maia-theme         3.93.0.225-1         3.93.0.244-1
                 adapta-breath-theme         3.93.0.225-1         3.93.0.244-1
                   adapta-maia-theme         3.93.0.225-1         3.93.0.244-1
                               copyq              3.3.0-4              3.3.1-1
                   deepin-session-ui              4.3.7-1            4.3.7.1-1
                         firefox-sse             59.0.2-0           59.0.2-0.1
       gnome-shell-extension-gnomenu                 23-1                 23-2
                                inxi             2.9.11-1             3.0.00-1
                      kmozillahelper              5.0.1-1              5.0.2-1
                     kvantum-manjaro             0.10.5-3             0.10.6-1
     libnautilus-extension-typeahead           3.26.0-2.0         3.28.0.1-1.1
            manjaro-awesome-settings           20180402-5           20180414-1
         manjaro-bspwm-mate-settings           20180402-5           20180414-1
              manjaro-bspwm-settings           20180402-5           20180414-1
      manjaro-bspwm-settings-minimal           20180402-5           20180414-1
             manjaro-budgie-settings           20180402-5           20180414-1
    manjaro-gnome-extension-settings           20180405-1           20180414-1
              manjaro-gnome-settings           20180405-1           20180414-1
                 manjaro-i3-settings           20180409-1           20180414-1
                manjaro-jwm-settings           20180402-5           20180414-1
        manjaro-kde-minimal-settings           20180317-1           20180414-1
                manjaro-kde-settings           20180317-1           20180414-1
               manjaro-lxde-settings           20180402-5           20180414-1
               manjaro-mate-settings           20180402-5           20180414-1
            manjaro-openbox-settings           20180402-5           20180414-1
               manjaro-openbox-walls                1.0-5                1.1-1
                  nautilus-typeahead           3.26.0-2.0         3.28.0.1-1.1
         python-jade-application-kit              0.a34-1              0.a35-1
       xfce4-whiskermenu-plugin-gtk3              2.1.5-1              2.1.6-1
                                 yay              5.657-2              5.675-2
      gnome-shell-extension-arc-menu                    -                 17-3
          manjaro-openbox-grub-theme                    -                1.0-1
                     python-svgwrite                    -             1.1.12-1
                    sublime-text-dev                    -             3.3143-1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-14           2018-04-15
-------------------------------------------------------------------------------
                                 0ad              a22-5.0              a22-6.0
                               atril           1.20.0-1.0           1.20.1-1.0
                              autofs            5.1.4-1.0            5.1.4-2.0
                             aws-cli           1.15.1-1.0           1.15.4-1.0
                               balsa              2.5.3-5            2.5.5-2.0
                             beignet            1.3.2-1.0            1.3.2-2.0
                         bitcoin-cli           0.16.0-1.0           0.16.0-2.0
                      bitcoin-daemon           0.16.0-1.0           0.16.0-2.0
                          bitcoin-qt           0.16.0-1.0           0.16.0-2.0
                          bitcoin-tx           0.16.0-1.0           0.16.0-2.0
                             blender         17:2.79-10.0        17:2.79.b-2.0
                               botan            2.4.0-1.0            2.5.0-4.0
                              brotli            1.0.2-1.0            1.0.3-1.0
                     brotli-testdata            1.0.2-1.0            1.0.3-1.0
                          browserify           16.1.1-1.0           16.2.0-1.0
                      budgie-desktop   10.4+8+gff09a510-110.4+34+gd6f3519f-1.0
                       cabal-install         2.0.0.1-45.0         2.0.0.1-47.0
                                caja           1.20.0-1.0           1.20.2-1.0
              caja-extensions-common           1.20.0-1.0           1.20.0-2.0
                caja-image-converter           1.20.0-1.0           1.20.0-2.0
                  caja-open-terminal           1.20.0-1.0           1.20.0-2.0
                         caja-sendto           1.20.0-1.0           1.20.0-2.0
                          caja-share           1.20.0-1.0           1.20.0-2.0
                      caja-wallpaper           1.20.0-1.0           1.20.0-2.0
                     caja-xattr-tags           1.20.0-1.0           1.20.0-2.0
                             catfish            1.4.4-1.0            1.4.5-1.0
                              ccfits                2.5-1              2.5-2.0
                               cgrep          6.6.23-20.0          6.6.23-21.0
               cldr-emoji-annotation          32.90.0-1.0           33.0.0-1.0
                          clementine           1.3.1-14.0           1.3.1-16.0
                              clinfo     2.2.17.10.25-1.0     2.2.18.04.06-1.0
                               cryfs            0.9.9-2.0            0.9.9-4.0
                            crypto++            6.1.0-1.0            7.0.0-1.0
                             crystal           0.24.1-1.0           0.24.2-2.1
                              csound           6.10.0-8.0          6.10.0-10.0
                          csound-doc           6.10.0-8.0          6.10.0-10.0
                              cython           0.28.1-1.0           0.28.2-1.0
                             cython2           0.28.1-1.0           0.28.2-1.0
              deepin-desktop-schemas   3.2.9.20180409-1.0           3.2.10-1.0
                       deepin-mutter            3.20.26-1          3.20.29-2.0
                           deepin-wm           1.9.21-2.0           1.9.24-2.0
                            deja-dup             36.3-4.0             38.0-1.0
                              devede           4.8.12-1.0            4.9.0-1.0
                      dnscrypt-proxy            2.0.8-3.0            2.0.9-2.0
                      docker-compose           1.20.1-1.0           1.21.0-1.0
                         dolphin-emu1:5.0.r6362.c08f6f0c53-1.01:5.0.r6362.c08f6f0c53-2.0
                                drbl            2.20.11-1          2.25.10-1.0
                               eolie           0.9.25-1.0           0.9.27-1.0
                               faust           2.5.21-1.0           2.5.23-2.0
                             fig2dev            3.2.6-1.1          3.2.6.a-1.0
  firefox-developer-edition-i18n-ach           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-af           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-an           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ar           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-as           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-ast           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-az           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-be           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-bg           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-bn-bd           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-bn-in           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-br           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-bs           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ca           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-cak           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-cs           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-cy           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-da           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-de           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-dsb           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-el           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-en-gb           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-en-us           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-en-za           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-eo           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-es-ar           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-es-cl           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-es-es           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-es-mx           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-et           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-eu           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-fa           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ff           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-fi           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-fr           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-fy-nl           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-ga-ie           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-gd           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-gl           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-gn           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-gu-in           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-he           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-hi-in           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-hr           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-hsb           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-hu           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-hy-am           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-id           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-is           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-it           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ja           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ka           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-kab           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-kk           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-km           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-kn           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ko           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-lij           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-lt           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-lv           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-mai           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-mk           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ml           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-mr           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ms           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-my           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-nb-no           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-nl           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-nn-no           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-or           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-pa-in           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-pl           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-pt-br           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-pt-pt           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-rm           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ro           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ru           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-si           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-sk           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-sl           59.0b3-1.0          60.0b12-1.0
  firefox-developer-edition-i18n-son           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-sq           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-sr           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-sv-se           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ta           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-te           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-th           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-tr           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-uk           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-ur           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-uz           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-vi           59.0b3-1.0          60.0b12-1.0
   firefox-developer-edition-i18n-xh           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-zh-cn           59.0b3-1.0          60.0b12-1.0
firefox-developer-edition-i18n-zh-tw           59.0b3-1.0          60.0b12-1.0
  firefox-extension-https-everywhere         2018.4.3-1.0        2018.4.11-1.0
                          foxtrotgps              1.2.0-2            1.2.1-1.0
                                 fpc            3.0.4-1.0            3.0.4-2.0
                             fractal           0.1.22-1.0           0.1.25-1.0
                      gambas3-gb-pdf             3.10.0-4           3.10.0-5.0
                             gbrainy          1:2.3.4-1.0          1:2.3.5-1.0
                            geogebra        6.0.445.0-1.0        6.0.451.0-1.0
                    gimp-plugin-gmic            2.2.1-2.0            2.2.2-1.0
                          gimp-ufraw            0.22-11.0            0.22-13.0
                          git-repair      1.20170626-20.0      1.20170626-21.0
                       gitlab-gitaly           0.95.0-1.0           0.96.1-1.0
                        gitlab-shell          2:7.1.1-1.0          2:7.1.2-1.0
                    gitlab-workhorse            4.0.0-1.0            4.1.0-1.0
                                gmic            2.2.1-2.0            2.2.2-1.0
                       gnome-applets             3.26.0-3           3.28.0-1.0
                     gnome-flashback             3.26.0-1           3.28.0-1.0
                 gnome-initial-setup           3.26.0-3.0           3.28.0-1.0
                       gnome-recipes              2.0.2-1            2.0.2-2.0
                   gnome-screensaver             3.6.1-13           3.6.1-14.0
                      gnome-software           3.26.6-1.0           3.28.1-1.0
    gnome-software-packagekit-plugin           3.28.0-1.0           3.28.1-1.0
                haskell-aeson-pretty           0.8.5-34.0            0.8.6-1.0
                    haskell-aeson-qq           0.8.2-27.0           0.8.2-28.0
                haskell-authenticate           1.3.4-79.0           1.3.4-80.0
                         haskell-aws            0.19-49.0            0.19-50.0
                       haskell-brick             0.35-8.0             0.36-2.0
         haskell-conduit-combinators           1.1.2-47.0           1.1.2-48.0
               haskell-conduit-extra         1.2.3.2-30.0         1.2.3.2-31.0
                  haskell-config-ini         0.2.2.0-32.0         0.2.2.0-33.0
                  haskell-configfile           1.1.4-10.0           1.1.4-11.0
                  haskell-connection           0.2.8-64.0           0.2.8-65.0
                   haskell-criterion         1.4.0.0-18.0         1.4.0.0-19.0
          haskell-cryptohash-conduit          0.1.1-155.0          0.1.1-156.0
          haskell-cryptonite-conduit           0.2.2-48.0           0.2.2-49.0
                         haskell-dav           1.3.2-37.0           1.3.2-38.0
                        haskell-dbus         0.10.15-19.0            1.0.1-3.0
                         haskell-dns           3.0.2-13.0           3.0.2-14.0
                haskell-doctemplates           0.2.1-21.0          0.2.2.1-1.0
                      haskell-either               5-35.0               5-36.0
                   haskell-esqueleto           2.5.3-89.0           2.5.3-91.0
                       haskell-extra            1.6.4-1.0            1.6.5-1.0
                  haskell-fdo-notify           0.3.1-39.0           0.3.1-42.0
                        haskell-feed         1.0.0.0-44.0         1.0.0.0-45.0
            haskell-hackage-security         0.5.2.2-19.0         0.5.2.2-20.0
                       haskell-hasql           1.1.1-54.0           1.1.1-56.0
                  haskell-hasql-pool           0.4.3-54.0           0.4.3-56.0
           haskell-hasql-transaction           0.5.2-54.0           0.5.2-56.0
                        haskell-here           1.2.13-4.0           1.2.13-5.0
                 haskell-hledger-lib              1.9-1.0              1.9-3.0
                    haskell-hopenpgp          2.5.5-194.0          2.5.5-195.0
                       haskell-hpack          0.27.0-35.0          0.27.0-37.0
                    haskell-hslogger          1.2.10-13.0          1.2.10-14.0
                haskell-html-conduit         1.2.1.2-35.0         1.2.1.2-36.0
                        haskell-http        4000.3.11-9.0       4000.3.11-10.0
                 haskell-http-client           0.5.12-1.0           0.5.12-2.0
             haskell-http-client-tls         0.3.5.3-31.0         0.3.5.3-32.0
                haskell-http-conduit           2.2.4-77.0           2.2.4-78.0
                  haskell-httpd-shed          0.4.0.3-9.0         0.4.0.3-10.0
                 haskell-interpolate            0.2.0-5.0            0.2.0-6.0
    haskell-interpolatedstring-perl6           1.0.0-43.0           1.0.0-44.0
                     haskell-iproute            1.7.3-2.0            1.7.3-3.0
                        haskell-jose         0.6.0.3-53.0         0.6.0.3-55.0
                   haskell-js-jquery           3.3.1-40.0           3.3.1-41.0
                     haskell-loch-th            0.2.1-6.0            0.2.2-1.0
                    haskell-missingh         1.4.0.1-19.0         1.4.0.1-20.0
                haskell-monad-logger         0.3.28.3-1.0         0.3.28.3-2.0
                  haskell-monad-time              0.2-4.0          0.3.1.0-1.0
                     haskell-network          2.6.3.4-2.0          2.6.3.5-1.0
           haskell-network-multicast           0.2.0-12.0           0.2.0-13.0
       haskell-network-protocol-xmpp           0.4.8-33.0           0.4.8-35.0
                  haskell-persistent         2.7.3.1-42.0         2.7.3.1-44.0
           haskell-persistent-sqlite           2.6.4-72.0           2.6.4-74.0
         haskell-persistent-template            2.5.4-9.0           2.5.4-11.0
                  haskell-pipes-http          1.0.5-119.0          1.0.5-120.0
           haskell-postgresql-binary          0.12.1-64.0          0.12.1-65.0
                 haskell-pretty-show           1.6.16-2.0              1.7-1.0
            haskell-project-template         0.2.0.1-25.0         0.2.0.1-26.0
       haskell-quickcheck-assertions            0.3.0-8.0           0.3.0-10.0
                      haskell-rebase           1.2.3-35.0           1.2.3-36.0
                    haskell-rerebase           1.2.1-43.0           1.2.1-44.0
                       haskell-retry          0.7.6.2-3.0          0.7.6.2-4.0
             haskell-servant-swagger           1.1.4-61.0           1.1.4-64.0
             haskell-simple-sendfile          0.2.27-22.0          0.2.27-23.0
                 haskell-skylighting             0.6-12.0             0.6-13.0
                       haskell-socks            0.5.6-8.0            0.5.6-9.0
                    haskell-src-exts           1.20.2-1.0           1.20.2-2.0
                    haskell-src-meta          0.8.0.2-9.0         0.8.0.2-10.0
                       haskell-store         0.4.3.2-73.0         0.4.3.2-74.0
           haskell-streaming-commons           0.1.19-8.0           0.1.19-9.0
                    haskell-swagger2             2.2-39.0            2.2.1-1.0
           haskell-tagstream-conduit        0.5.5.3-139.0        0.5.5.3-140.0
       haskell-tamarin-prover-theory            1.2.3-9.0           1.2.3-10.0
                    haskell-tasty-th           0.1.7-13.0           0.1.7-14.0
                         haskell-tls            1.4.1-9.0           1.4.1-10.0
         haskell-tls-session-manager         0.0.0.2-35.0         0.0.0.2-36.0
                         haskell-wai          3.2.1.2-4.0          3.2.1.2-5.0
                 haskell-wai-conduit          3.0.0.4-7.0          3.0.0.4-8.0
                    haskell-wai-cors           0.2.6-25.0           0.2.6-26.0
          haskell-wai-handler-launch         3.0.2.3-50.0         3.0.2.3-51.0
                  haskell-wai-logger           2.3.2-17.1           2.3.2-19.0
       haskell-wai-middleware-static           0.8.1-38.0            0.8.2-1.0
              haskell-wai-websockets          3.0.1.2-5.0          3.0.1.2-6.0
                        haskell-warp         3.2.18.2-3.0         3.2.18.2-4.0
                    haskell-warp-tls         3.2.4.2-37.0         3.2.4.2-38.0
                  haskell-websockets         0.12.4.0-6.0         0.12.4.0-7.0
                      haskell-xcffib           0.6.0-13.0           0.6.0-14.0
                 haskell-xml-conduit         1.7.1.2-25.0         1.7.1.2-26.0
                  haskell-xml-hamlet         0.4.1.1-50.0         0.4.1.1-51.0
                           hedgewars          0.9.23-10.0          0.9.23-11.0
                             hindent           5.2.5-19.0           5.2.5-20.0
                             hledger              1.9-1.0              1.9-3.0
                          hledger-ui              1.9-1.0              1.9-4.0
                      hopenpgp-tools         0.19.5-113.0         0.19.5-114.0
                         http-parser            2.8.0-1.0            2.8.1-1.0
                                 i7z        0.27.2.git1-4      0.27.2.git1-5.0
                          ibus-anthy              1.5.9-1           1.5.10-1.0
     intellij-idea-community-edition         2:2018.1-1.0       2:2018.1.1-1.0
                             ipython              6.2.1-2            6.3.1-1.0
                            ipython2              5.5.0-1            5.6.0-1.0
                               jedit              5.4.0-5            5.5.0-1.0
                             jenkins            2.115-1.0            2.116-1.0
                                 kea            1.3.0-5.0            1.3.0-6.0
             keepass-plugin-keeagent              0.8.1-5           0.10.0-1.0
                                knot            2.6.5-2.0            2.6.6-1.0
                   krita-plugin-gmic            2.2.1-2.0            2.2.2-1.0
                         kvantum-qt5             0.10.5-1           0.10.6-1.0
                            latexila             3.26.1-1           3.26.1-2.0
                                 ldc          1:1.8.0-1.0          1:1.8.0-2.0
                          libalkimia            7.0.1-1.0            7.0.2-1.0
                             libindi            1.7.0-1.0            1.7.1-1.0
                          libmatekbd           1.20.0-1.0           1.20.1-1.0
                             libmgba            0.6.1-3.0            0.6.2-1.0
                    libqtshadowsocks            2.0.2-1.0            2.0.2-2.0
                               lldpd            0.9.9-1.0            1.0.1-1.0
                              lolcat           90.8.8-2.0           99.9.9-1.0
                            lollypop          0.9.403-3.0          0.9.500-1.0
                               marco           1.20.0-1.0           1.20.1-1.0
                        mate-applets           1.20.0-1.0           1.20.1-1.0
                           mate-calc           1.20.0-1.0           1.20.1-1.0
                 mate-control-center           1.20.0-1.0           1.20.2-1.0
                        mate-desktop           1.20.0-1.0           1.20.1-1.0
                          mate-panel           1.20.0-1.0           1.20.1-1.0
                  mate-power-manager           1.20.0-1.0           1.20.1-1.0
                mate-settings-daemon           1.20.0-1.0           1.20.1-1.0
                            mednafen           1.21.1-1.0           1.21.2-1.0
                           megaglest             3.13.0-4           3.13.0-5.0
                             mgba-qt            0.6.1-3.0            0.6.2-1.0
                            mgba-sdl            0.6.1-3.0            0.6.2-1.0
                           miniupnpc     2.0.20180222-1.0     2.0.20180406-1.0
                            mldonkey              3.1.6-1            3.1.6-2.0
                   modem-manager-gui           0.0.19-1.0         0.0.19.1-1.0
                           musescore              2.2-2.0            2.2.1-1.0
                             ncmpcpp            0.8.1-4.0            0.8.2-1.0
                      nginx-mainline          1.13.11-1.0          1.13.12-1.0
                            normaliz            3.5.3-1.0            3.5.4-1.0
                                 npm            5.8.0-1.0            5.8.0-2.0
                              nuitka         0.5.29.3-1.0         0.5.29.4-1.0
                             opendht       1:1.7.0rc5-1.0       1:1.7.0rc6-1.0
                         openimageio           1.7.17-3.0            1.8.9-2.0
                 openshadinglanguage            1.7.6-4.0            1.9.8-1.0
                          opensubdiv              3.1.1-2            3.3.1-1.0
                             openvdb            4.0.2-6.0            5.0.0-1.0
                                osmo            0.4.2-2.0            0.4.2-3.0
                    otf-font-awesome            5.0.9-1.0           5.0.10-1.0
                              pandoc           2.1.3-13.0           2.1.3-17.0
                     pandoc-citeproc        0.13.0.1-55.0        0.13.0.1-59.0
                            pdf2djvu            0.9.8-1.0            0.9.8-2.0
                               pluma           1.20.0-1.0           1.20.1-1.0
                               ponyc           0.21.3-1.0           0.21.3-2.0
                            powerdns            4.1.1-1.0            4.1.1-2.0
                      pyneighborhood              0.5.4-3            0.5.4-4.0
                     python-autobahn           18.3.1-1.0           18.4.1-1.0
                        python-boto3            1.7.1-1.0            1.7.4-1.0
                     python-botocore           1.10.1-1.0           1.10.4-1.0
                    python-braintree           3.43.0-1.0           3.44.0-1.0
                       python-brotli            1.0.2-1.0            1.0.3-1.0
                python-canonicaljson              1.0.0-2            1.1.3-1.0
                      python-cheroot            6.2.0-1.0            6.2.1-3.0
                 python-glanceclient            2.9.1-1.0           2.11.0-1.0
                     python-httplib2             0.10.3-1           0.11.3-1.0
                        python-munch            2.3.0-1.0            2.3.1-1.0
                  python-oslo-config            6.0.1-1.0            6.0.2-1.0
                          python-pbr            4.0.1-1.0            4.0.2-1.0
                       python-pipenv           11.9.0-4.0          11.10.0-1.0
                  python-progressbar           3.37.0-1.0           3.37.1-1.0
                  python-pycodestyle              2.3.1-1            2.4.0-1.0
                python-pycryptodomex            3.5.1-1.0            3.6.0-1.0
                       python-pylast            2.1.0-1.0            2.2.0-1.0
                         python-pyte              0.7.0-1            0.8.0-1.0
             python-requests-credssp              0.1.0-1            1.0.0-1.0
             python-sphinx_rtd_theme              0.2.4-1            0.3.0-1.0
                  python-subunit2sql            1.8.0-1.0            1.9.0-1.0
                          python-tox              2.9.1-1            3.0.0-1.0
                     python-wxpython            4.0.1-1.0            4.0.1-2.0
                    python2-autobahn           18.3.1-1.0           18.4.1-1.0
                       python2-boto3            1.7.1-1.0            1.7.4-1.0
                    python2-botocore           1.10.1-1.0           1.10.4-1.0
                   python2-braintree           3.43.0-1.0           3.44.0-1.0
                      python2-brotli            1.0.2-1.0            1.0.3-1.0
               python2-canonicaljson              1.0.0-2            1.1.3-1.0
                     python2-cheroot            6.2.0-1.0            6.2.1-3.0
                python2-glanceclient            2.9.1-1.0           2.11.0-1.0
                    python2-httplib2             0.10.3-1           0.11.3-1.0
                       python2-munch            2.3.0-1.0            2.3.1-1.0
                 python2-oslo-config            6.0.1-1.0            6.0.2-1.0
                         python2-pbr            4.0.1-1.0            4.0.2-1.0
                      python2-pipenv           11.9.0-4.0          11.10.0-1.0
                 python2-progressbar           3.37.0-1.0           3.37.1-1.0
                 python2-pycodestyle              2.3.1-1            2.4.0-1.0
               python2-pycryptodomex            3.5.1-1.0            3.6.0-1.0
                      python2-pylast            2.1.0-1.0            2.2.0-1.0
                        python2-pyte              0.7.0-1            0.8.0-1.0
            python2-requests-credssp              0.1.0-1            1.0.0-1.0
            python2-sphinx_rtd_theme              0.2.4-1            0.3.0-1.0
                 python2-subunit2sql            1.8.0-1.0            1.9.0-1.0
                         python2-tox              2.9.1-1            3.0.0-1.0
                           qmapshack           1.10.0-1.0           1.11.0-1.0
                             radare2            2.4.0-1.0            2.5.0-1.0
                             remmina  1:1.2.0rcgit.27-2.0  1:1.2.0rcgit.29-1.0
                        riot-desktop           0.13.5-2.0           0.14.1-1.0
                            riot-web           0.13.5-2.0           0.14.1-1.0
                          ruby-async            1.4.1-1.0            1.5.0-1.0
                      ruby-async-dns            1.0.0-2.0            1.1.0-1.0
                       ruby-async-io            1.6.1-1.0            1.7.0-1.0
                               stack           1.6.5-65.0           1.6.5-68.0
                     stylish-haskell         0.9.0.2-19.0         0.9.0.2-20.0
                               sugar              0.112-1            0.112-2.0
               sugar-activity-browse              201.3-1              202-1.0
                 sugar-activity-read              119-1.0              120-1.0
                sugar-activity-write               99-1.0               99-2.0
                                sway           0.15.1-2.0           0.15.2-1.0
                             t1utils             1.41-1.0             1.41-2.0
                          terminator               1.91-5             1.91-6.0
                           terraform           0.11.6-1.0           0.11.7-1.0
                          testssl.sh          2.9.5.3-1.0          2.9.5.4-1.0
                    ttf-font-awesome            5.0.9-1.0           5.0.10-1.0
                      ubuntu-keyring       2016.10.27-1.0       2018.02.28-1.0
                           uglify-js           3.3.20-1.0           3.3.21-1.0
                            valabind            1.6.0-1.0            1.6.0-2.0
                               vault            0.9.6-1.0           0.10.0-1.0
                             whipper            0.6.0-1.0            0.7.0-1.0
                      wireguard-dkms     0.0.20180304-1.0     0.0.20180413-1.0
                     wireguard-tools     0.0.20180304-1.0     0.0.20180413-1.0
                                 wit              3.00a-1            3.01a-1.0
                           wxsqlite3            3.5.9-1.0            4.0.1-1.0
            xfce4-whiskermenu-plugin            1.7.5-1.0            2.1.6-1.0
                                zart            2.2.1-2.0            2.2.2-1.0
                        zerotier-one            1.2.4-3.0            1.2.4-4.0

Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters



Has 32-bit project been dropped?
[Testing Update x32] 2018-04-14 - The "Let's start over..." set
#2

Known issues and solutions

This is a wiki post; please edit as necessary.


#3

My Wife’s PC wasn’t updated for some time. I changed the branch to stable because I haven’t been able to keep up with updates and provide feedback. More than 200 packages were updated, apparently with no issues. Thanks and keep up the good work.


#4

All seems fine with XFCE. Thanks again.


#5

Update on 2 Machines and 1 VB without Problems.

DK3


#6

Left my xfce on asus eee-pc 1000h waiting when you fixed the repos. Checked yesterday, 390 updates, answered a lot of ‘replace?’ questions with ‘yes’ and all went through super smooth, fantastic job.


#7

Hello @jonathon

I don’t know why but I can’t update to 2018-04-15 and I’ve added the package archlinux32-keyring to the SyncFirst field in /etc/pacman.conf

> [x@x ~]$ sudo pacman -Syu
> :: Synchronizing package databases...
>  core is up to date
>  extra is up to date
>  community is up to date
> :: Starting full system upgrade...
>  there is nothing to do
[x@x ~]$ sudo pacman -Syyu
:: Synchronizing package databases...
 core                                         186.9 KiB   792K/s 00:00 [#######################################] 100%
 extra                                          2.4 MiB  1397K/s 00:02 [#######################################] 100%
 community                                               5.1 MiB  1590K/s 00:03 [##############################################] 100%
:: Starting full system upgrade...
 there is nothing to do
 [x@x ~]$ sudo pacman -Syyuu
:: Synchronizing package databases...
 core                                                         186.9 KiB   802K/s 00:00 [##################################################] 100%
 extra                                                          2.4 MiB  1559K/s 00:02 [##################################################] 100%
 community                                                      5.1 MiB  1601K/s 00:03 [##################################################] 100%
:: Starting full system upgrade...
 there is nothing to do

#8

This means your mirror doesn’t have the latest packages, or you already have them. Check your installed package versions against those in the OP.


#9

@jonathon

I can’t see the versions “linux414 4.14.34” or “util-linux 2.32-3.0” to update but I have “systemd-sysvcompat 238.76-1” there must be something wrong with the update

[x@x ~]$ yaourt linux414
1 core/linux414 4.14.33-2 [installed]
    The Linux414 kernel and modules
[x@x ~]$ yaourt util-linux
1 core/libutil-linux 2.32-2.0 [installed]
    util-linux runtime libraries
2 core/util-linux 2.32-2.0 (base base-devel) [installed]
    Miscellaneous system utilities for Linux
[x@x ~]$ yaourt systemd-sysvcompat
1 core/systemd-sysvcompat 238.76-1 (base) [installed]
    sysvinit compat for systemd

#10

Not really,

Or, I didn’t snap the packages… Let me check.

Edit:

So the snap didn’t happen. :confused: Packages should be flowing now.


#11

@jonathon

I can’t full update to 2018-04-15, man. What could possibly go wrong with it?

:: Starting full system upgrade...
 there is nothing to do

#12

@manja1 You have to wait for the mirror you’re using to sync the packages. Until then they won’t show as available. You can try refreshing your mirror list if you’re feeling especially impatient.


#13

when stable release .iso gonna be?


#14

When I get round to it. I have enough stuff to do as it is.


#15

umm great :slight_smile: I was looking forward to hear that. I need to fresh install that great manjaro/arch32 distro on my old machines


#16

A post was split to a new topic: Ranger exits woith “cannot find directory”


#17

This topic was automatically closed after 25 hours. New replies are no longer allowed.