[Stable Update x32] 2017-12-29 - i686'm too 686 for my 686

update
stable
i686
manjaro32

#11

Well, we announced to drop 32bit from Manjaro. However there was always an option for Manjaro-32 project. Also remember that Manjaro-32 is a very young project and even has no ISOs yet.

We hope that 32-bit lovers will join our Manjaro-Team to help out with Manjaro-32 and Manjaro in 2018. With our Motto Enjoy the simplicity we also have this effort with all our tools.

Lots of stuff will come in 2018 for both projects. By tomorrow I’ll release an article what happen so far with Manjaro in 2017. So stay tuned for more …


#12

plus mine is free from Intel ME… :smile:


#13

Little bonus snap from x32-testing for the kernel updates:

:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-12-29           2017-12-31
-------------------------------------------------------------------------------
                            linux414             4.14.9-2            4.14.10-1
                    linux414-headers             4.14.9-2            4.14.10-1
                             linux49             4.9.72-1             4.9.73-1
                     linux49-headers             4.9.72-1             4.9.73-1
                     manjaro-release            17.1rc4-1             17.1.0-1
                      manjaro-system           20171226-2           20171231-2


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-12-29           2017-12-31
-------------------------------------------------------------------------------
                           calamares             3.1.11-9            3.1.11-10
                         flashplugin       28.0.0.126-1.2                    -
                  linux414-acpi_call              1.1.0-9             1.1.0-10
                   linux414-bbswitch                0.8-9               0.8-10
                linux414-broadcom-wl       6.30.223.271-9      6.30.223.271-10
                     linux414-nvidia           1:384.98-9          1:384.98-10
               linux414-nvidia-304xx          1:304.137-9         1:304.137-10
               linux414-nvidia-340xx            340.104-9           340.104-10
                      linux414-r8168           8.044.02-9          8.044.02-10
                  linux414-rt3562sta         2.4.1.1_r4-9        2.4.1.1_r4-10
                        linux414-spl            0.7.5-1.9           0.7.5-1.10
                   linux414-tp_smapi               0.41-9              0.41-10
                linux414-vhba-module           20161009-9          20161009-10
                        linux414-zfs            0.7.5-1.9           0.7.5-1.10
                         linux49-spl           0.7.5-1.72           0.7.5-1.73
                         linux49-zfs           0.7.5-1.72           0.7.5-1.73
                        pepper-flash       28.0.0.126-1.2                    -


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-12-29           2017-12-31
-------------------------------------------------------------------------------
                         flashplugin       28.0.0.126-1.0       28.0.0.126-1.2
                               habak              0.2.5-5            0.2.5-6.0
                          libepubgen              0.0.1-1            0.1.0-1.0
                            liblouis              3.3.0-1            3.4.0-1.0
                        pepper-flash       28.0.0.126-1.0       28.0.0.126-1.2
                 perl-list-moreutils              0.419-4            0.428-1.0
                       perl-try-tiny               0.28-3             0.30-1.0
                 ttf-linux-libertine              5.3.0-3            5.3.0-4.0
                               xterm                330-1              330-1.1
              perl-list-moreutils-xs                    -            0.428-1.0

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-12-29           2017-12-31
-------------------------------------------------------------------------------
                    lightdm-settings            1.1.3-1.0              1.1.4-1
               lightdm-slick-greeter              1.1.3-1              1.1.4-1
    manjaro-gnome-extension-settings           20171230-1           20171231-1
              manjaro-gnome-settings           20171230-1           20171231-1
                              octopi              0.8.9-1             0.8.10-2
                 octopi-cachecleaner              0.8.9-1             0.8.10-2
          octopi-notifier-frameworks              0.8.9-1             0.8.10-2
                 octopi-notifier-qt5              0.8.9-1             0.8.10-2
                 octopi-pacmanhelper              0.8.9-1             0.8.10-2
                   octopi-repoeditor              0.8.9-1             0.8.10-2
             sddm-andromeda-qt-theme               1224-1               1230-1
               sddm-qt-manjaro-theme               1224-1               1230-1
       xfce4-whiskermenu-plugin-gtk3              2.1.3-1              2.1.5-1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-12-29           2017-12-31
-------------------------------------------------------------------------------
                            algol68g              2.8.4-3            2.8.4-4.0
                        algol68g-doc              2.8.4-3            2.8.4-4.0
                             asunder              2.9.1-1            2.9.2-1.0
                             aws-cli             1.12.0-1          1.14.15-1.0
                              batctl             2017.2-1           2017.4-1.0
                              bchunk              1.2.0-4            1.2.2-4.0
                          containerd            1.0.0-1.0            1.0.0-2.0
                             grafana              4.5.2-1            4.6.3-1.0
                      grafana-zabbix              3.7.0-1            3.8.1-1.0
                   npm-check-updates             2.13.0-1           2.14.0-1.0
            perl-module-build-xsutil               0.16-3             0.18-1.0
                              pifpaf           1.11.1-2.0           1.12.0-1.0
                        python-boto3              1.4.8-1            1.5.6-1.0
                     python-botocore              1.8.0-1           1.8.19-1.0
                 python-digitalocean               1.12-1           1.13.2-1.0
                         python-praw              5.2.0-1            5.3.0-1.0
                     python-prawcore             0.12.0-1           0.13.0-1.0
                   python-s3transfer             0.1.11-1           0.1.12-1.0
                    python-terminado                0.7-1            0.8.1-1.0
                python2-digitalocean               1.12-1           1.13.2-1.0
                      python2-pifpaf           1.11.1-2.0           1.12.0-1.0
                        python2-praw              5.2.0-1            5.3.0-1.0
                    python2-prawcore             0.12.0-1           0.13.0-1.0
                   python2-terminado                0.7-1            0.8.1-1.0
                        zerotier-one            1.2.4-2.0            1.2.4-3.0

#14

Way we go @jonathon. Maybe I should spin some Manjaro-32 ISOs. However, I must patch our tools to support the x32- branches …

--- a/manjaro-tools/lib/util.sh	2017-11-01 14:15:59.293276152 -0400
+++ b/manjaro-tools/lib/util.sh	2017-12-31 12:45:22.599475136 -0500
@@ -66,7 +66,7 @@ get_pac_mirrors_conf(){
     local conf="$tmp_dir/pacman-mirrors-$1.conf"
     cp "${DATADIR}/pacman-mirrors.conf" "$conf"
     sed -i "$conf" \
-        -e "s|Branch = stable|Branch = $1|"
+        -e "s|Branch = x32-stable|Branch = $1|"
 
     echo "$conf"
 }
@@ -201,7 +201,7 @@ set_branch(){
 }
 
 init_common(){
-    [[ -z ${target_branch} ]] && target_branch='stable'
+    [[ -z ${target_branch} ]] && target_branch='x32-stable'
 
     [[ -z ${target_arch} ]] && target_arch=$(uname -m)
 
@@ -749,7 +749,7 @@ is_valid_arch_iso(){
 
 is_valid_branch(){
     case $1 in
-        'stable'|'testing'|'unstable') return 0 ;;
+        'x32-stable'|'x32-testing'|'x32-unstable') return 0 ;;
         *) return 1 ;;
     esac
 }
--- a/manjaro-tools/lib/util-iso.sh	2017-11-01 14:15:59.269942128 -0400
+++ b/manjaro-tools/lib/util-iso.sh	2017-12-31 12:58:11.425522151 -0500
@@ -221,7 +221,7 @@ gen_iso_fn(){
     fi
     [[ ${initsys} == 'openrc' ]] && vars+=("${initsys}")
     vars+=("${dist_release}")
-    vars+=("${target_branch}")
+    vars+=("${target_branch/x32-/}")
     vars+=("${target_arch}")
     for n in ${vars[@]};do
         name=${name:-}${name:+-}${n}

#15

ISOs are now online and testers got PMs for giving them a dry-run :wink:


#16

It’s only two things:
-A CPU replacement(recommended:date>=2006).
-A RAM unit with more capacity.


#17

So you run the IME cleaning algorithm?


#18

Yea, but still…just pluggin in a 64 bit CPU? And…that should work? Wow :slight_smile:


#19

Ba carefull, okay?
(just poking you… :wink: )
:heart: :sunflower: :heart_decoration:
Melissa


#20

any chance you can copy me in with the ISO links please? I’d also like to test this and have a cobbled collection of old but working PC parts on my workbench I can test it as a bare metal install on. They do work okay as I got ubuntuMATE 16.04 running from them allbeit not that fast.


#21

#22

thanks, didn’t see that thread yet


#23

Just a reminder: We all know that intel stopped providing 32bit cpus since 2006
So now It’s 2018=12 years very enough for a setup upgrade, even mesa stopped supporting that years old gpus.
Anyway, We wouldn’t see any 32bit in the horizon of 2022, so all:be prepared, Linux 4.15 is in the way and the work goes on…


#24

no, is a 2004 laptop, IME was not embedded in the CPU


#25

This discussion has been had before and an announcement thread is not an appropriate place to continue it. If you’re not going to use the 32-bit packages be happy with the 64-bit ones and leave everyone else to enjoy these ones.


Edit: After reviewing dates, Yonah-based Core chips were in production until 2008, and the N270 Atom was used throughout 2010 (possibly available later), so they’re not all that old.


#26

well, I think a minimal xfce will be ok, not going tu use something less and not needed to many program, we can install what we want after
I’m having that old laptop but I’m not using it any more, just sometimes to keep it alive :smile:


#27

I already agree with you, that was just a reminder.


#28

I couldn’t upgrade due to a pepper-flash invalid signature issue. I removed pepper-flash and flashplugin. The upgrade completed, but now I have no pepper-flash. I tried to reinstall pepper-flash and I get an invalid signature or corrupt package error. Does anyone know a workaround? I have been working on a solution for two hours and I am ready to throw in the towel.


#29

Please check the new thread:


#30