[Stable Update i686] 2019-08-03 - GCC, systemd, Chromium, Palemoon, Kernels

Hey this was as fast as a lightning. What I'm missing is the updated ndiswrapper-utils 1.61 => 1.62 as indicated in e.g. [linux49-ndiswrapper-1.62-1-i686.pkg.tar.xz]

please, please upgrade this package too

Excuse, excuse, just discovered the package in x32-unstable. Would please merge this package with x32-stable

Thank you

Hmm... all the x32-* branches are currently level...

Misreading, made a mistake. My fault. The ndiswrapper-utils are stil of version 1.61

1 Like

OK, I don't actually know what package is providing ndiswrapper-utils now. There was a package split but there's no ndiswrapper-utils on GitLab...

@schinfo Any idea where the ndiswrapper-utils PKGBUILD is?

Ah, it's in here:

Here we go:

:: Different overlay package(s) in repository extra i686

                             PACKAGE           x32-stable          x32-testing
                   ndiswrapper-utils             1.61-166               1.62-1

merci vielmals (thank you)

It's a part of every PKGBUILD

# Disable the line before and use this to additionally build ndiswraper-utils
# It is needed only once!
pkgname=("$_linuxprefix-ndiswrapper" "ndiswrapper-utils")

It's always enabled for the main kernel (5.2 at the moment)

1 Like

I wonder whether it's worth completing the split and making it into a completely separate package. I don't think it needs building for each kernel release/ABI change anyway?

Update went smooth but my default browser was changed from chrome to Firefox. My i3 config and .profile are untouched. Where else could the default browser be set?

Update on 1 System and 1 VB without Problems.


Got this warning -

Warning: audit: directory permissions differ on /var/log/audit/filesystem: 755 package: 700

Fixed with this:
Execute sudo chmod 700 /var/log/audit/ in terminal

Thanks team. :+1:

1 Like

You can add this to the Known Issues wiki post if you want to. :wink:

Something went very wrong with this update. I got a bunch of errors related with systemd not finding a specific library. I tried to downgrade systemd packages to no avail. I knew rebooting would go bad, but I did it anyway and was dumped to a rootfs shell.

I currently don't have access to that machine. Later I'll burn a thumb drive and I'll post the errors I got.


1 Like

That sounds like a partial upgrade state...

But the update went through to the end!

1 Like

It can also be caused by one of the repos being behind the others on the mirror (e.g. [core] being ahead of [extra]).

Maybe... I always change mirrors before an update (ex.: pacman-mirrors -f5 && pacman -Syyu). Can it still happen?

It shouldn't... but I'm not sure. I can't think of another reason for having wrong library versions (e.g. it tested OK for me).

Ok, I chrooted and updated linux414, systemd, systemd-libs and systemd-sysvcompat. Everything working now.

Forum kindly sponsored by Bytemark