[Stable Update i686] 2019-06-30 - Perl 5.30; kernel 3.18 and Steam dropped

Hello i686ers!

This set mainly consists of rebuilds for Perl 5.30.

The EOL kernel 3.18 has now been dropped from the repos so please migrate to a different kernel if you're still using it.

Steam has also been dropped as it doesn't support a 32-bit OS anyway.

Plenty of kernel updates too.


Available kernels

Series Version PAE
linux316 3.16.69 No
linux44 4.4.183 No
linux49 4.9.183 No
linux414 4.14.130 No
linux419 4.19.56 Yes

Full list of changes

The full list is available here. ~1100 updated packages.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It's a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren't the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren't as many packagers. If you notice an important package is lagging please report it; at the moment it's only me packaging for i686:

I'm only packaging current LTS kernels. Any marked as EOL are dropped. I'll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn't this meant to be stable?

"Stable" means "infrequently changing", not "everything will work perfectly all the time". If you want it to mean everything works, you need to help test the things you're interested in.

What about installer images?

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by the adventurous who want to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable. However: expect breakage.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


2 Likes

Known issues and solutions


Something about keyrings or package validity

Update archlinux32-keyring first,

sudo pacman -S archlinux32-keyring
sudo pacman -Syu

Another faultless update. Huge thanks to all those involved. :+1:

2 Likes

Hello! Brand new install and when trying to do a update this happens:

error: libutil-linux: signature from "Andreas Baumann (sign) <mail@andreasbaumann.cc>" is unknown trust
:: File /var/cache/pacman/pkg/libutil-linux-2.34-3.0-i686.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] ^C

Do I click Yes or..?

Actually he just clicked Y

The “do you want to delete it” prompt shows up for every damn item in the update list

So in other words their all giving the “invalid or corrupted package (PGP signature)” error and doing y to all of them would just mean nothing installed

Even the nuclear option as the guide called it didn’t work

Just updated and have following issues:

  1. Warn about old perl modules
    WARNING: '/usr/lib/perl5/5.28' contains data from at least 3 packages which will NOT be used by the installed perl interpreter.
    -> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.28'

output of pacman -Qqo '/usr/lib/perl5/5.28' was :
graphviz
perl-xml-libxml
subversion

  1. ALL packages depending on qt5ct (e.g. manjaro-settings-manager, vlc) are not working

qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50c04) with this library (version 0x50c03)
Aborted (core dumped)

Solved issue no.2!

Installed package qt5-styleplugins-5.0.0.20170311-15.0-i686.pkg.tar.xz from archlinux32 community-testing repo

possible workaround for issue no.1:

copy files from folder /usr/lib/perl5/5.28 to corresponding location in /usr/lib/perl5/5.30
at least /usr/bin/gvedit from package graphviz 2.40.1-15.0 is working

I wont update my Wife's desktop anymore. The hardware is starting to fail and the case isn't adequate to summer time with the Pentium D CPU, so I backed data up and I'm disassembling it.

My Sister came to visit me and I asked to bring a dual core E5800 (overclocked) I assembled her some years ago (and I know she doeasn't use anymore in favour of Android phone and tablet). This machine is super silent and quite fast (64bit manjaro, 4GB RAM, SSD+HDD). It will my Wife's desktop from now on. It wasn't updated since February 2017, but after solving some conflicts it updated fine and it is running smooth (I cleaned a bunch of orphans, of course)

Now, my Wife's laptop was updated and it got ugly.

  1. After restarting and entering credentials in slim I got a black screen with fan running at full speed (no TTY change possible). This was reproducible.
  2. I checked the journal and the error was a Xorg crash report.
  3. Tried to downgrade xorg-server and xorg-common to no avail.
  4. Upgraded the Xorg packages and tried to downgrade the 3 systemd packages, to no avail.
  5. Upgraded the systemd packages and disabled the slim service. After reboot I tried to login with startx and saw libqtxdg expected qt5-base version 5.13 (I have 5.12.3).
  6. So I downgraded libqtxdg from version 3.3.1-5 to version 3.3.1-3.
  7. I was able to login but the LXQt interface was mess. So I saw which packages depended on libqtxdg and saw that lxqt-qtplugin had been updated too.
  8. I downgraded lxqt-qtplugin (0.14.0-2 -> 0.14.0-1) and now everything is working properly.

TL, DR: libqtxdg expects qt5-base to be version 5.13 and so login fails. Downgrading libqtxdg and lxqt-qtplugin fixes this issue.

Cheers,

I just want to say thank you for this version of Manjaro.

I run a 64bit KDE on my gaming machine, but I have a little 32bit Archos laptop (with 1gig ram !!) sitting next to it that has one purpose in life, display my twitch & discord chat.

being able to have manjaro on both machines makes me happy.. thank you.

Hello everybody,
nobody there with msm not working after the upgrade due to incompatible Qt library or outdated perlmodules? (s.o. post no. 6)

I don't have MSM installed on the 32bit machine, but there was a problem with incompatible Qt libraries. See my post above.

Update on 1 System and 1VB without Problems.

DK3

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.