[Stable Update i686] 2019-05-26 - Firefox, Thunderbird, LibreOffice, OpenJDK 8 and 11

Hello i686ers!

This is another smallish update set which brings in updates and fixes for Firefox, Thunderbird, OpenJDK 8 and 11, and LibreOffice.

Also, kernels, in particular 4.19 which had stopped working on some systems somewhere after 4.19.43.

Note that kernel 3.18 is now actually EOL and won't be receiving any further updates. Please switch to another kernel if you're still running on 3.18. It will be removed from the repos "soon".


Available kernels

Series Version PAE
linux316 3.16.68 No
linux318 3.18.140 EOL No
linux44 4.4.180 No
linux49 4.9.179 No
linux414 4.14.122 No
linux419 4.19.46 Yes

Full list of changes

The full list is available here. ~550 updated packages.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It's a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren't the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren't as many packagers. If you notice an important package is lagging please report it; at the moment it's only me packaging for i686:

I'm only packaging current LTS kernels. Any marked as EOL are dropped. I'll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn't this meant to be stable?

"Stable" means "infrequently changing", not "everything will work perfectly all the time". If you want it to mean everything works, you need to help test the things you're interested in.

What about installer images?

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by the adventurous who want to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable. However: expect breakage.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


2 Likes

Known issues and solutions


Incompatible libdevmapper 1.02.156 (2019-03-22) and kernel driver (unknown version)

This happens every so often when there's a kernel ABI change. As far as I know it's harmless and can be ignored.


The 18.0.4 installer image installs a base/unthemed Xfce desktop

I'll look into that/fix for the 18.1.0 installer (unless someone else identifies a fix which I can use to respin the image).


Received the error:

[2019-05-26 17:11] [ALPM-SCRIPTLET] Incompatible libdevmapper 1.02.156 (2019-03-22) and kernel driver (unknown version).

I have seen this before so I just rebooted and all appears to be OK.
Should this be added to

1 Like

Good update. I had to switch kernels from 419 to 414 as 419 would freeze at boot. All good now though.

2 Likes

Update on 1 System and 1 VB without problems.

DK3

1 Like

I'm not able to update...
I get
···
signature from "Erich Eckner (just to sign arch packages) arch@eckner.net" is unknown trust
signature from "Andreas Baumann (sign) mail@andreasbaumann.cc" is unknown trust
···
this for 92 packages total
I've tried several time to to perform the keys procedure as exposed here:

https://forum.manjaro.org/t/issues-with-signature-is-marginal-trust-or-invalid-or-corrupted-package/33268

and related pages but no success

anything else I may try?

have you checked others mirrors ?

yes, I deed pacman-mirrors -f0

I think I may restore an image but is one year old

Install/update the archlinux32-keyring package.

I deed restore the old image, from Jenuary '18, since I was having few more little issues not solved
got problem with one key, fixed immediately
then a lot of files already existed, so I used --force
reinstalled 4,2 GB...
everything seems well
great Manjaro!

1 Like

I can not update,
After verifying packages integrity,

error: alsa-lib: la firma de «Erich Eckner (just to sign arch packages) arch@eckner.net» es de confianza mínima
:: El archivo /var/cache/pacman/pkg/alsa-lib-1.1.9-1.0-i686.pkg.tar.xz está dañado (paquete no válido o dañado (firma PGP)).

That's the exact same issue as six posts up with the exact same answer two posts up:

1 Like

It says the same thing

error: archlinux32-keyring: signature from "Erich Eckner (just to sign arch packages) <arch@eckner.net>" is marginal trust
:: File /var/cache/pacman/pkg/archlinux32-keyring-20190108-1.0-any.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
sudo pacman -U /var/cache/pacman/pkg/archlinux32-keyring-20190108-1.0-any.pkg.tar.xz