[Stable Update i686] 2019-05-12 - BIG update, ICU rebuilds, KDE, LibreOffice

Hello i686ers!

This is another very large update set of around 3,200 packages.

The main cause is an update to icu version 64 which has prompted a large number of rebuilds. It's still possible some packages have been missed so please report them as you find them.

Due to the size of the update I recommend applying this update in a TTY or screen:

Another important development relates to the ongoing dropping of support for non-SSE2 CPUs by upstream projects.

Firefox has required SSE2 for quite some time, and now Webkit has followed suit. Webkit in particular is a dependency of a large number of packages (e.g. most of GNOME).

Therefore, this set is likely to be the last set with support for systems without SSE2.

I'll be testing a switch from the pure i686 to pentium4 as the oldest supported microarchitecture.

beforep4

archlinux32's i686 will retain x87 (non-SSE2) support (while dropping SSE2-dependent software), but with my current plan manjaro32's "i686" will actually be built for the pentium4 architecture.

This will remove support for CPUs older than the Pentium 4 ("NetBurst") and Athlon 64. Any CPU less than ~16 years old will remain working.

https://en.wikipedia.org/wiki/SSE2


Available kernels

Series Version PAE
linux316 3.16.67 No
linux318 3.18.139 No
linux44 4.4.179 No
linux49 4.9.175 No
linux414 4.14.118 No
linux419 4.19.42 Yes

Full list of changes

The full list is available here. ~3200 updated packages.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It's a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren't the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren't as many packagers. If you notice an important package is lagging please report it; at the moment it's only me packaging for i686:

I'm only packaging current LTS kernels. Any marked as EOL are dropped. I'll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn't this meant to be stable?

"Stable" means "infrequently changing", not "everything will work perfectly all the time". If you want it to mean everything works, you need to help test the things you're interested in.

What about installer images?

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by the adventurous who want to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable. However: expect breakage.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


4 Likes

Known issues and solutions

Seems everything OK on my 2004 Intellosaurus-Xfce K 4.9 - 4.14 :smile:

1 Like

Update on terminal no good?

Terminal should be fine but you should run it within a screen so you can recover it if X or the terminal crashes.

Essentially, remove as much chance for failure as possible.

Recently I was going through boxes from my move six years ago to Thailand, and I found an old Intel Atom/ nVidia Ion based PC that at one time I was using as an HTPC. I installed the i686 version of Manjaro on it and then applied the update. No problems with it here.

Everything that rely on akonadi no longer works

kmail: symbol lookup error: /usr/lib/libKF5AkonadiContact.so.5: undefined symbol: _ZN9KContacts12ContactGroup4dataEj
kaddressbook: symbol lookup error: /usr/lib/libKF5AkonadiContact.so.5: undefined symbol: _ZN9KContacts12ContactGroup4dataEj

Printers no longer work as expected. Sometimes they skip pages, sometimes they don't print dual, sometimes it both prints non dual and spams with dua printing even though only 1 copy was required. Reproducable with all printers i have here, each has different driver, all of them are Xerox.

Pretty sad update for me, can someone help me out?

Going by this https://github.com/void-linux/void-packages/issues/11347
19.04 might help, currently kmail, akonadi, okular and some others are still 18.12 while some like dolphin, kate, etc are 19.04. When there will be an update?

Hello,
again many thanks for the great work your doing.
I'm here on a TravelMate 290, manjaro i3 stable and kernel 3.18. Since the latest qt5 update some applications depending on qt5ct (e.g. manjaro-settings-manager, vlc, multibootusb) are broken.
The error message is
'qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50c02) with this library (version 0x50c03)
Aborted (core dumped)'
Is there any fix about this? :worried:

Installed versions of qt5:
qt5-base-5.12.3-2.2
qt5-svg-5.12.3-1.0
qt5ct-0.39-1.0

Tried qt5-base archlinux32which is version 5.12.3-2.3. Rebooted after install, but same error

I'm currently un-doing the preliminary/investigatory architecture changes in x32-unstable so I can put together a fix for these issues. It might take a little time but it will get done.

Updated KDE packages are in x32-testing for testing.

Just discovered, that linux414 4.14.118 have problems with Bluez package. Downgrading to 114 solves the problem.

What others say to the same issue:

1 Like

Also linux414 4.14.119 have the same sympthoms - bluetooth immediately disconnects from device as soon as connection is created. This cycle will be repeated endlessly. Journalctl doesnt show any errors, just disconnected by reason 3.
Linux 4.19.42 and 43 doesn't load session login dialog. Instead some kind of colorful mess is seen on the screen. Journalctl reports kernel: kernel BUG at arch/x86/kernel/alternative.c:726!.
And again - downgreading to 4.14.114 solves problems.

Could you please add other packages like kmail and other akonadi related packages in there?

If you give me a list of packages to build then I will (try to) build them. I don't use KDE so I don't know which packages are "akonadi related packages".

Here're some packages that no longer work and require new version: kmail, kaddressbook, akonadi, akonadi-contacts, akonadi-mime, akonadi-search, akonadi-calendar, akonadi-import-wizard, akonadi-notes, libkdepim, kdepim-runtime, kmailtransport, kmail-account-wizard, mbox-importer, pim-data-exporter, pim-sieve-editor

Scratched partitionmanager because new version is in testing already

1 Like

Those builds will take some time to do as they'll have a build order. Let's see what happens.

There's a non-trivial build chain for these packages which may mean they never get built. :frowning_face:

Edit:

OK, so I did actually manage to dive down each of the dependency chains and build all of the associated packages.

Please test.

1 Like