[Stable Update i686] 2019-02-18 - systemd, LibreOffice, KDE, firmware

update
stable
manjaro32

#1

Hello i686ers!

Another sizable update with some very notable changes.

The most interesting/potentially impactful is systemd 241 - though it seems to be working fine for x32-testers.

I strongly recommend you update using pacman, not “pamac”.

For the other more popular packages, LibreOffice Fresh reaches 6.2.0 with some nice new features, and there’s another update for KDE.

Also, kernels.


Full list of changes

Available here.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


Available kernels

Series Version PAE
linux316 3.16.63 No
linux318 3.18.134 No
linux44 4.4.174 No
linux49 4.9.158 No
linux414 4.14.101 No
linux419 4.19.23 Yes

archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It’s a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren’t the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren’t as many packagers. If you notice an important package is lagging please report it; at the moment it’s only me packaging for i686:

I’m only packaging current LTS kernels. Any marked as EOL are dropped. I’ll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn’t this meant to be stable?

“Stable” means “infrequently changing”, not “everything will work perfectly all the time”. If you want it to mean everything works, you need to help test the things you’re interested in.

What about installer images?

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by anyone who wants to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters



[Testing Update i686] 2019-01-27 to 02-16 - systemd, firmware, Qt5, LibreOffice
[Stable Update] 2019-02-19 - Kernels, KDE, LibreOffice, Systemd, VirtualBox, Deepin, Qt, Firmwares, Wine
#2

Known issues and solutions


Replace libsystemd with core/systemd-libs? [Y/n]

Yes.


MSM reports the wrong version of Kernel 4.19 installed, 4.19.16-1 should be 4.19.23-1

Not sure what’s going on here yet.


Pandoc is not working

This should be fixed with further/future Haskell updates.


python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/pycache/init.cpython-37.pyc exists in filesystem

You ran a Python application as root (or used sudo) and it created a cache file.

Move/delete this file and try again, same as normal: Package installation says FILENAME exists in filesystem; "Failed to commit transaction (conflicting files)"



split this topic #3

3 posts were split to a new topic: Buenas como estan equipo me gustaria saber si puedo tener manjaro32


#5

Libreoffice isn’t 6.2, its translations are, the program itself is
libreoffice-fresh 6.1.4-4.0 6.1.4-4.1


#6

Let me fix that for you:

:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           x32-stable           x32-stable
-------------------------------------------------------------------------------
                         libfbclient                    -      3.0.4.33054-1.0
                   libreoffice-fresh                    -              6.2.0-0
               libreoffice-fresh-sdk                    -              6.2.0-0

#7

I’ve been stuck for quite some time on “Downloading lib32-systemd (241.159-1-x86_64)”. It says it has downloaded all 1.3 GB. It started slowing way down at 1.2 GB. Is it safe to suspend my computer at this point? Is it safe to hit cancel and try again?


#8

Yes. If it is still downloading nothing has been installed yet.


#9

python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc existiert im Dateisystem

Had to rename the file, then everything went smooth.


#10

Hi,
after update I have problem with Libreoffice: copying (ctrl+c) text in editor results there is nothing to paste (ctr+v) for example in Firefox! Is there any solution for that?

Dario


#11

I did the same (renaming the py file). Subsequently my install hung midway.

After waiting a couple of hours I re-boot. It made it until the login, though with warnings about not being able to load netmanager. KDE-Plasma hung on starting. Then tried re-boot. Alt-ctrl_F2 for terminal. on logging in I get a flatpak error flatpak:error while loading shared libraries: libidn2.so.4: cannot open shareed object file.
When I try to run sudo pacman -Syyu or sudo pacman -Syyuu I get the same libidn2 missing message.
Will I just re-install or is there a way to get it working?
Thanks.


#12

I tried the chroot I found in other thread aboout libidn2.so. I tried several variations including arh-install-scripts and they al did not work. Re-install will only take about 1 hr. so I’ll do that. Hope it will run all updates without problems.


#13

Went very smoothly.


#14

Thanks, now i see new libreoffice package. However upon booting my system i’ve started to experiance non booting problem and some people here describe it as well. I couldn’t boot at all. Thankfully i’ve had old Kubuntu still installed(it was a nightmare experiance hence i went for Manjaro) but it hellped me out.

At first i’ve downgraded to

systemd-239.303-1-i686.pkg.tar.xz
systemd-sysvcompat-239.303-1-i686.pkg.tar.xz

There was also
systemd-libs-241.77-1-i686.pkg.tar.xz
but i wouldn’t downgrade it because i don’t have it

So i’ve downgraded systemd and after doing mkinitcpio -p linux414 i saw warnings about libidn2 not being present. So i’ve downgraded it as well.
Then i rebooted and with tons of errors(most of which were network related) it did the job. But i had no network connection and KDE was blinking like Christmas tree.
So i decided to downgrade GPU drivers, mesa and networkmanager. But i couldn’t because pacman doesn’t work with this old libidn2. So i chrooted again(because blinking KDE is hell) manually upgraded libidn2, then downgraded mesa, intel driver and nm, restored old libidn2, run mkinitcpio and succesffully got almost everything working, no more warning during boot process, network is there, cpu runs like crazy for whatever reason and plasma is still blinking.
I wanted to change compositing to draw without opengl but couldn’t because systemsettings hangs upon trying to go to an option(does anyone know what config file should i change to switch compositing settings?)
But i also so this error in Monitor section of System Settings:

Cannot load library /usr/lib/qt/plugins/kcm_kscreen.so: (/usr/lib/qt/plugins/kcm_kscreen.so: undefined symbol: _ZN7KScreen6Output9setClonesE5QListiE)

Ok, after i’ve opened Kate suddenly the blinking has stopped, it only blinks on plasma panel now. I guess i could like this for now maybe you have some ideas, downgrading option is always there

Oh, thats kwin_x11 thats eating up my CPU like crazy.

Another update on the situation. You would not believe it. kwin_x11 --replace did nothing to CPU load but when i killed kwin_x11 suddenly CPU load went to normal level and everything works almost correctly. I still have issues with blinking plasma panel(but not the same extent as before) and i can easily go through menus in systemsettings. I can even make screnshots now, previously they were blank. I haven’t rebooted yet though.
So there is still this issue i wrote about earlier


#15

My first laptop is currently updating after I re-installed it following a libidn2.so.4 problem after an initial python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc problem.

While waiting I started on my second laptop.
I first attempted the full update in Octopi which downloaded but did not run owing to python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc being present already.

I renamed it to *.old.

I tried starting my browser to get onto this forum. It failed.

I then thought I might be able to prevent the whole libidn2 hassle by simply installing libidn2 first pamac install libidn2 this did not work because of the missing python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc (which I had renamed to *.old) so I renamed it back. My browser appeared.

I then re-ran sudo pamac install libidn2 which worked and updated a good number of files.

Then my wifi disappeared and all terminal commands were met with libidn2.so.4 missing.
Whiile I was going online on 1st laptop running the updates my 2nd laptop tried to lock its screen and comes with a message that its broken. consolkit or logind is needed but neither present.

I have run this update on 2 very different systems (An 9 year old Acer 5742Z and a 3 year old Lenovo Z50 i7 and both give problems on the python-pyqt5: /usr/lib/python3.7/site-packages/PyQt5/__pycache__/__init__.cpython-37.pyc and the libidn2).

I will not be updating my other 2 systems before I know more. If my oldest system updates well I will probably re-install the second and run all updates from scratch there.
Unless someone knows how to get it working again. I do have a working USB-live version.


#16

If your only problem is libidn2 atleast for now you can try it like i did. I’ve downgraded to the previous version and run mkinitcpio -p linux414 AND i have the new version there(just unpack from the package you’ve downloaded and copy lib and 1 of the symlinks) as well so that pacman would work like this:

lrwxrwxrwx 1 root root     16 Nov  9 19:30 /usr/lib/libidn2.so -> libidn2.so.0.3.4*
lrwxrwxrwx 1 root root     16 Nov  9 19:30 /usr/lib/libidn2.so.0 -> libidn2.so.0.3.4*
-rwxr-xr-x 1 root root 119952 Nov  9 19:30 /usr/lib/libidn2.so.0.3.4*
lrwxrwxrwx 1 root root     16 Feb 20 10:51 /usr/lib/libidn2.so.4 -> libidn2.so.4.0.0*
-rwxr-xr-x 1 root root 119952 Feb 16 23:46 /usr/lib/libidn2.so.4.0.0*

#17

Thanks, but I am booting my second laptop from USB now, while my old one is at 550/629 updates. If It reboots in good health I will re-install my lenovo as well.


#18

Can I ask that people who are having problems:

Don’t use pamac

I test all of these updates using Pacman/pacman and they all proceed without issue. The majority of issues appear to be from people using Pamac/pamac.

I cannot guarantee that Pamac will work. It appears to be very buggy and causes issues all over the place (including on x86_64).

Once again: use Pamac at your own risk but don’t blame me if an update process fails.


#19

A bit of a nasty on my KDE installation.
plasmashell normally lives in about 3G of total memory. After the update, it’s using a bonkers 10G!
A bit of searching suggested that a mis-behaving widget might be the cause. And at first, this did seem to be the case. Removing any widget immediately caused plasmashell to go back to a sensible amount of memory. But logging out and back in, straight away it goes back to the 10G level.
Another suggestion was that it may have been due to using a slideshow for wallpaper, but again, this made no difference.
I’ve reverted my system from backup for the time being.
Anyone got any ideas what to look at next?

[Edit]: after some digging (and a lot of swearing), I’ve found the answer to this. The excess memory use is due to the system tray: specifically the “application status” entry on it. Unselecting this brings memory use down to a sensible level.

I’m not 100% sure what I’m going to miss by having this unselected, but it’s staying that way anyway.


#20

Try to disable effects. If this works you can enable one by one to check what’s causing it. Even 3GB is a huge RAM usage. I have only 2GB on my 32bit install and plasma uses arround 400MB upon launch (counting with NoMachine running).


#21

Thanks for the suggestion. Unfortunately it didn’t help.
I think my normal plasmashell memory is probably higher than some because I run a desktop widget which continually displays the output of my security camera. At least, that’s my assumption…

[update] My guess was confirmed by deleting the camera monitor widget, which (after a reboot) cut a significant chunk off plasmashell’s usage. This is after restoring to the backup from before the upgrade.