[Stable Update i686] 2018-09-14 - Large update, KDE, Firefox, Chromium, Python, Haskell, TeX Live, Virtualbox,

update
stable
manjaro32

#1

Hello i686ers!

This is a huge update. Please see the complete list for details.

Notably, libx264 is replaced with x264. Say Yes to replace.

There’s also a very early pre-release version of the next LTS kernel 4.19 available for testing. Please don’t rely on it. It might work OK. It might not.

Also, other kernels.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


Available kernels

Series Version
linux316 3.16.56
linux44 4.4.154
linux49 4.9.125
linux414 4.14.68
linux419 4.19rc2

archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It’s a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren’t the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren’t as many packagers. If you notice an important package is lagging please report it; at the moment it’s only me packaging for i686:

I’m only packaging current LTS kernels. Any marked as EOL are dropped. I’ll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn’t this meant to be stable?

“Stable” means “infrequently changing”, not “everything will work perfectly all the time”. If you want it to mean everything works, you need to help test the things you’re interested in.

What about installer images?

There’s a rapidly ageing image over here:

There’s work being done to fix i686 image building (it broke); a new image should be arrive after this update set.

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by anyone who wants to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable.

Full list of changes

Full list of changes is available here.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters



[Testing Update i686] 2018-08-29 to 09-09 - Many rebuilds, Virtualbox, KDE, Thunderbird, Xorg
#2

Known issues and solutions


Replace libx264?

Yes


Black screen after update on an AMD / ATI graphics card

Downgrade the following packages to this version

mesa-vdpau 18.1.7-1.0
libva-mesa-driver 18.1.7-1.0
mesa 18.1.7-1.0
DOWNGRADE_FROM_ALA=1 downgrade mesa mesa-vdpau libva-mesa-driver


Unable to login after a massive update (32 bit system)
#3

@jonathon

:thinking:

[manjaro@manjaro ~]$ sudo pacman-mirrors -g
.: INFO Downloading mirrors from repo.manjaro.org
.: INFO Using default mirror file
.: INFO Querying mirrors - This may take some time
.: INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
[manjaro@manjaro ~]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
warning: packer: local (20160325-1) is newer than community (1.2.5-1.0)
warning: sublime-text-dev: local (3.3176-1) is newer than community (3.3170-1)
resolving dependencies...
warning: cannot resolve "libmsym", a dependency of "avogadrolibs"
:: The following package cannot be upgraded due to unresolvable dependencies:
      avogadrolibs
:: Do you want to skip the above package for this upgrade? [y/N] y
looking for conflicting packages...
 there is nothing to do

#4

37 posts were merged into an existing topic: Any way to update to [Stable Update i686] 2018-08-29?


#12

Actually, it’s probably time to call it quits for this project. I can’t maintain a separate copy of every Manjaro package for i686 myself and trying to guess what changes have been made to the x86_64 packages is impossible. Given the number of Manjaro packaging updates being made to x86_64 which aren’t making it through to the GitLab repos, which I can then build for i686, it’s going to create problems like this.

So - It was a good run. A year’s extra support for i686 systems isn’t too bad, and the one physical 32-bit system I do have will probably run arch32 OK.


#13

Please sleep on it. @manjaroforlife does not speak for the rest of us.

I personally don’t hold you or anyone else responsible when something breaks on my system and most of us appreciate what you have been doing. It’s clearly something that happened due to upstream changes. I reported back what I found incase someone here knew a way to fix it. I tried a clean install this evening with Manjaro-Architect and got the same result.


#14

It was indeed a good run, thanks for your work on it mate :+1:


#15

It is very sad how many critical comments the Manjaro team receives. They do an exceptional job providing a great 100% gratis system that usually works extremely well.

What happens upstream is totally out of their control. Usually they manage to fix any breakages in a very timely manner. Please remember that these are all unpaid volunteers before making despairaging remarks about any of the Manjaro maintainers.

Thank you for all your time, and all the hard work you put into supporting all the Manjaro versions to everyone on the Manjaro team.


#16

people always forget that this is the work of enthusiast people not a profit company … at least people must know how to ask gentelly … indeed it was a good run and i think it’s better to focus on the x64 and forget the x32
great job as always manjaro team


#17

I too hope you’ll reconsider, but let me convey my gratitude for the success of your Manjaro x32 project. I’ve enjoyed using x32 on my troublesome baytrail and I appreciated that you listened. Many thanks for everything.


#18

Update on 1VB without Problems.

My NB is not starting anymore.

x.org.log:

[    11.645] 
X.Org X Server 1.20.1
X Protocol Version 11, Revision 0
[    11.645] Build Operating System: Linux Arch Linux
[    11.645] Current Operating System: Linux Home08 4.14.68-1-MANJARO #1 SMP PREEMPT Thu Sep 6 01:03:07 UTC 2018 i686
[    11.646] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.14-i686 root=UUID=156f069f-f11a-4dbb-8455-3297ecd17449 rw quiet resume=UUID=6f6e8038-4dcb-4ab0-bb86-5ba493dc3fe3
[    11.646] Build Date: 30 August 2018  09:21:50AM
[    11.646]  
[    11.646] Current version of pixman: 0.34.0
[    11.646] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    11.646] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    11.646] (==) Log file: "/var/log/Xorg.0.log", Time: Sat Sep 15 12:31:15 2018
[    11.646] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    11.646] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    11.647] (==) No Layout section.  Using the first Screen section.
[    11.647] (==) No screen section available. Using defaults.
[    11.647] (**) |-->Screen "Default Screen Section" (0)
[    11.647] (**) |   |-->Monitor "<default monitor>"
[    11.648] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[    11.648] (==) Automatically adding devices
[    11.648] (==) Automatically enabling devices
[    11.648] (==) Automatically adding GPU devices
[    11.648] (==) Automatically binding GPU devices
[    11.648] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    11.648] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/OTF".
[    11.648] 	Entry deleted from font path.
[    11.648] 	(Run 'mkfontdir' on "/usr/share/fonts/OTF").
[    11.648] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[    11.648] 	Entry deleted from font path.
[    11.648] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi".
[    11.648] 	Entry deleted from font path.
[    11.648] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi").
[    11.648] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi".
[    11.648] 	Entry deleted from font path.
[    11.649] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi").
[    11.649] (==) FontPath set to:
	/usr/share/fonts/misc,
	/usr/share/fonts/TTF
[    11.649] (==) ModulePath set to "/usr/lib/xorg/modules"
[    11.649] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[    11.649] (II) Module ABI versions:
[    11.649] 	X.Org ANSI C Emulation: 0.4
[    11.649] 	X.Org Video Driver: 24.0
[    11.649] 	X.Org XInput driver : 24.1
[    11.649] 	X.Org Server Extension : 10.0
[    11.653] (++) using VT number 7

[    11.653] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[    11.655] (II) xfree86: Adding drm device (/dev/dri/card0)
[    11.662] (--) PCI:*(1@0:5:0) 1002:4e50:1179:ff00 rev 0, Mem @ 0xf0000000/134217728, 0xe8100000/65536, I/O @ 0x00009000/256, BIOS @ 0x????????/131072
[    11.662] (II) LoadModule: "glx"
[    11.662] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    11.667] (II) Module glx: vendor="X.Org Foundation"
[    11.667] 	compiled for 1.20.1, module version = 1.0.0
[    11.667] 	ABI class: X.Org Server Extension, version 10.0
[    11.667] (II) Applying OutputClass "Radeon" to /dev/dri/card0
[    11.667] 	loading driver: radeon
[    11.667] (==) Matched radeon as autoconfigured driver 0
[    11.667] (==) Matched ati as autoconfigured driver 1
[    11.667] (==) Matched modesetting as autoconfigured driver 2
[    11.667] (==) Matched fbdev as autoconfigured driver 3
[    11.667] (==) Matched vesa as autoconfigured driver 4
[    11.667] (==) Assigned the driver to the xf86ConfigLayout
[    11.667] (II) LoadModule: "radeon"
[    11.668] (II) Loading /usr/lib/xorg/modules/drivers/radeon_drv.so
[    11.668] (II) Module radeon: vendor="X.Org Foundation"
[    11.668] 	compiled for 1.20.0, module version = 18.0.1
[    11.668] 	Module class: X.Org Video Driver
[    11.668] 	ABI class: X.Org Video Driver, version 24.0
[    11.668] (II) LoadModule: "ati"
[    11.668] (II) Loading /usr/lib/xorg/modules/drivers/ati_drv.so
[    11.669] (II) Module ati: vendor="X.Org Foundation"
[    11.669] 	compiled for 1.20.0, module version = 18.0.1
[    11.669] 	Module class: X.Org Video Driver
[    11.669] 	ABI class: X.Org Video Driver, version 24.0
[    11.670] (II) LoadModule: "modesetting"
[    11.670] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    11.672] (II) Module modesetting: vendor="X.Org Foundation"
[    11.672] 	compiled for 1.20.1, module version = 1.20.1
[    11.672] 	Module class: X.Org Video Driver
[    11.672] 	ABI class: X.Org Video Driver, version 24.0
[    11.672] (II) LoadModule: "fbdev"
[    11.672] (WW) Warning, couldn't open module fbdev
[    11.672] (EE) Failed to load module "fbdev" (module does not exist, 0)
[    11.672] (II) LoadModule: "vesa"
[    11.672] (WW) Warning, couldn't open module vesa
[    11.672] (EE) Failed to load module "vesa" (module does not exist, 0)
[    11.672] (II) RADEON: Driver for ATI/AMD Radeon chipsets:
	ATI Radeon Mobility X600 (M24), ATI FireMV 2400,
	ATI Radeon Mobility X300 (M24), ATI FireGL M24 GL,
	ATI Radeon X600 (RV380), ATI FireGL V3200 (RV380),
	ATI Radeon IGP320 (A3), ATI Radeon IGP330/340/350 (A4),
	ATI Radeon 9500, ATI Radeon 9600TX, ATI FireGL Z1, ATI Radeon 9800SE,
	ATI Radeon 9800, ATI FireGL X2, ATI Radeon 9600, ATI Radeon 9600SE,
	ATI Radeon 9600XT, ATI FireGL T2, ATI Radeon 9650, ATI FireGL RV360,
	ATI Radeon 7000 IGP (A4+), ATI Radeon 8500 AIW,
	ATI Radeon IGP320M (U1), ATI Radeon IGP330M/340M/350M (U2),
	ATI Radeon Mobility 7000 IGP, ATI Radeon 9000/PRO, ATI Radeon 9000,
	ATI Radeon X800 (R420), ATI Radeon X800PRO (R420),
	ATI Radeon X800SE (R420), ATI FireGL X3 (R420),
	ATI Radeon Mobility 9800 (M18), ATI Radeon X800 SE (R420),
	ATI Radeon X800XT (R420), ATI Radeon X800 VE (R420),
	ATI Radeon X850 (R480), ATI Radeon X850 XT (R480),
	ATI Radeon X850 SE (R480), ATI Radeon X850 PRO (R480),
	ATI Radeon X850 XT PE (R480), ATI Radeon Mobility M7,
	ATI Mobility FireGL 7800 M7, ATI Radeon Mobility M6,
	ATI FireGL Mobility 9000 (M9), ATI Radeon Mobility 9000 (M9),
	ATI Radeon 9700 Pro, ATI Radeon 9700/9500Pro, ATI FireGL X1,
	ATI Radeon 9800PRO, ATI Radeon 9800XT,
	ATI Radeon Mobility 9600/9700 (M10/M11),
	ATI Radeon Mobility 9600 (M10), ATI Radeon Mobility 9600 (M11),
	ATI FireGL Mobility T2 (M10), ATI FireGL Mobility T2e (M11),
	ATI Radeon, ATI FireGL 8700/8800, ATI Radeon 8500, ATI Radeon 9100,
	ATI Radeon 7500, ATI Radeon VE/7000, ATI ES1000,
	ATI Radeon Mobility X300 (M22), ATI Radeon Mobility X600 SE (M24C),
	ATI FireGL M22 GL, ATI Radeon X800 (R423), ATI Radeon X800PRO (R423),
	ATI Radeon X800LE (R423), ATI Radeon X800SE (R423),
	ATI Radeon X800 XTP (R430), ATI Radeon X800 XL (R430),
	ATI Radeon X800 SE (R430), ATI Radeon X800 (R430),
	ATI FireGL V7100 (R423), ATI FireGL V5100 (R423),
	ATI FireGL unknown (R423), ATI Mobility FireGL V5000 (M26),
	ATI Mobility Radeon X700 XL (M26), ATI Mobility Radeon X700 (M26),
	ATI Radeon X550XTX, ATI Radeon 9100 IGP (A5),
	ATI Radeon Mobility 9100 IGP (U3), ATI Radeon XPRESS 200,
	ATI Radeon XPRESS 200M, ATI Radeon 9250, ATI Radeon 9200,
	ATI Radeon 9200SE, ATI FireMV 2200, ATI Radeon X300 (RV370),
	ATI Radeon X600 (RV370), ATI Radeon X550 (RV370),
	ATI FireGL V3100 (RV370), ATI FireMV 2200 PCIE (RV370),
	ATI Radeon Mobility 9200 (M9+), ATI Mobility Radeon X800 XT (M28),
	ATI Mobility FireGL V5100 (M28), ATI Mobility Radeon X800 (M28),
	ATI Radeon X850, ATI unknown Radeon / FireGL (R480),
	ATI Radeon X800XT (R423), ATI FireGL V5000 (RV410),
	ATI Radeon X700 XT (RV410), ATI Radeon X700 PRO (RV410),
	ATI Radeon X700 SE (RV410), ATI Radeon X700 (RV410),
	ATI Radeon X1800, ATI Mobility Radeon X1800 XT,
	ATI Mobility Radeon X1800, ATI Mobility FireGL V7200,
	ATI FireGL V7200, ATI FireGL V5300, ATI Mobility FireGL V7100,
	ATI FireGL V7300, ATI FireGL V7350, ATI Radeon X1600, ATI RV505,
	ATI Radeon X1300/X1550, ATI Radeon X1550, ATI M54-GL,
	ATI Mobility Radeon X1400, ATI Radeon X1550 64-bit,
	ATI Mobility Radeon X1300, ATI Radeon X1300, ATI FireGL V3300,
	ATI FireGL V3350, ATI Mobility Radeon X1450,
	ATI Mobility Radeon X2300, ATI Mobility Radeon X1350,
	ATI FireMV 2250, ATI Radeon X1650, ATI Mobility FireGL V5200,
	ATI Mobility Radeon X1600, ATI Radeon X1300 XT/X1600 Pro,
	ATI FireGL V3400, ATI Mobility FireGL V5250,
	ATI Mobility Radeon X1700, ATI Mobility Radeon X1700 XT,
	ATI FireGL V5200, ATI Radeon X2300HD, ATI Mobility Radeon HD 2300,
	ATI Radeon X1950, ATI Radeon X1900, ATI AMD Stream Processor,
	ATI RV560, ATI Mobility Radeon X1900, ATI Radeon X1950 GT, ATI RV570,
	ATI FireGL V7400, ATI Radeon 9100 PRO IGP,
	ATI Radeon Mobility 9200 IGP, ATI Radeon X1200, ATI RS740,
	ATI RS740M, ATI Radeon HD 2900 XT, ATI Radeon HD 2900 Pro,
	ATI Radeon HD 2900 GT, ATI FireGL V8650, ATI FireGL V8600,
	ATI FireGL V7600, ATI Radeon 4800 Series, ATI Radeon HD 4870 x2,
	ATI Radeon HD 4850 x2, ATI FirePro V8750 (FireGL),
	ATI FirePro V7760 (FireGL), ATI Mobility RADEON HD 4850,
	ATI Mobility RADEON HD 4850 X2, ATI FirePro RV770,
	AMD FireStream 9270, AMD FireStream 9250, ATI FirePro V8700 (FireGL),
	ATI Mobility RADEON HD 4870, ATI Mobility RADEON M98,
	ATI FirePro M7750, ATI M98, ATI Mobility Radeon HD 4650,
	ATI Radeon RV730 (AGP), ATI Mobility Radeon HD 4670,
	ATI FirePro M5750, ATI RV730XT [Radeon HD 4670], ATI RADEON E4600,
	ATI Radeon HD 4600 Series, ATI RV730 PRO [Radeon HD 4650],
	ATI FirePro V7750 (FireGL), ATI FirePro V5700 (FireGL),
	ATI FirePro V3750 (FireGL), ATI Mobility Radeon HD 4830,
	ATI Mobility Radeon HD 4850, ATI FirePro M7740, ATI RV740,
	ATI Radeon HD 4770, ATI Radeon HD 4700 Series, ATI RV610,
	ATI Radeon HD 2400 XT, ATI Radeon HD 2400 Pro,
	ATI Radeon HD 2400 PRO AGP, ATI FireGL V4000, ATI Radeon HD 2350,
	ATI Mobility Radeon HD 2400 XT, ATI Mobility Radeon HD 2400,
	ATI RADEON E2400, ATI FireMV 2260, ATI RV670, ATI Radeon HD3870,
	ATI Mobility Radeon HD 3850, ATI Radeon HD3850,
	ATI Mobility Radeon HD 3850 X2, ATI Mobility Radeon HD 3870,
	ATI Mobility Radeon HD 3870 X2, ATI Radeon HD3870 X2,
	ATI FireGL V7700, ATI Radeon HD3690, AMD Firestream 9170,
	ATI Radeon HD 4550, ATI Radeon RV710, ATI Radeon HD 4350,
	ATI Mobility Radeon 4300 Series, ATI Mobility Radeon 4500 Series,
	ATI FirePro RG220, ATI Mobility Radeon 4330, ATI RV630,
	ATI Mobility Radeon HD 2600, ATI Mobility Radeon HD 2600 XT,
	ATI Radeon HD 2600 XT AGP, ATI Radeon HD 2600 Pro AGP,
	ATI Radeon HD 2600 XT, ATI Radeon HD 2600 Pro, ATI Gemini RV630,
	ATI Gemini Mobility Radeon HD 2600 XT, ATI FireGL V5600,
	ATI FireGL V3600, ATI Radeon HD 2600 LE,
	ATI Mobility FireGL Graphics Processor, ATI Radeon HD 3470,
	ATI Mobility Radeon HD 3430, ATI Mobility Radeon HD 3400 Series,
	ATI Radeon HD 3450, ATI Radeon HD 3430, ATI FirePro V3700,
	ATI FireMV 2450, ATI Radeon HD 3600 Series, ATI Radeon HD 3650 AGP,
	ATI Radeon HD 3600 PRO, ATI Radeon HD 3600 XT,
	ATI Mobility Radeon HD 3650, ATI Mobility Radeon HD 3670,
	ATI Mobility FireGL V5700, ATI Mobility FireGL V5725,
	ATI Radeon HD 3200 Graphics, ATI Radeon 3100 Graphics,
	ATI Radeon HD 3300 Graphics, ATI Radeon 3000 Graphics, SUMO, SUMO2,
	ATI Radeon HD 4200, ATI Radeon 4100, ATI Mobility Radeon HD 4200,
	ATI Mobility Radeon 4100, ATI Radeon HD 4290, ATI Radeon HD 4250,
	AMD Radeon HD 6310 Graphics, AMD Radeon HD 6250 Graphics,
	AMD Radeon HD 6300 Series Graphics,
	AMD Radeon HD 6200 Series Graphics, PALM, CYPRESS,
	ATI FirePro (FireGL) Graphics Adapter, AMD Firestream 9370,
	AMD Firestream 9350, ATI Radeon HD 5800 Series,
	ATI Radeon HD 5900 Series, ATI Mobility Radeon HD 5800 Series,
	ATI Radeon HD 5700 Series, ATI Radeon HD 6700 Series,
	ATI Mobility Radeon HD 5000 Series, ATI Mobility Radeon HD 5570,
	ATI Radeon HD 5670, ATI Radeon HD 5570, ATI Radeon HD 5500 Series,
	REDWOOD, ATI Mobility Radeon Graphics, CEDAR, ATI FirePro 2270,
	ATI Radeon HD 5450, CAYMAN, AMD Radeon HD 6900 Series,
	AMD Radeon HD 6900M Series, Mobility Radeon HD 6000 Series, BARTS,
	AMD Radeon HD 6800 Series, AMD Radeon HD 6700 Series, TURKS, CAICOS,
	ARUBA, TAHITI, PITCAIRN, VERDE, OLAND, HAINAN, BONAIRE, KABINI,
	MULLINS, KAVERI, HAWAII
[    11.681] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
[    11.682] (II) [KMS] Kernel modesetting enabled.
[    11.682] (WW) Falling back to old probe method for modesetting
[    11.682] (II) RADEON(0): Creating default Display subsection in Screen section
	"Default Screen Section" for depth/fbbpp 24/32
[    11.682] (==) RADEON(0): Depth 24, (--) framebuffer bpp 32
[    11.682] (II) RADEON(0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps)
[    11.682] (==) RADEON(0): Default visual is TrueColor
[    11.682] (==) RADEON(0): RGB weight 888
[    11.682] (II) RADEON(0): Using 8 bits per RGB (8 bit DAC)
[    11.682] (--) RADEON(0): Chipset: "ATI Radeon Mobility 9600/9700 (M10/M11)" (ChipID = 0x4e50)
[    11.682] (II) Loading sub module "fb"
[    11.682] (II) LoadModule: "fb"
[    11.683] (II) Loading /usr/lib/xorg/modules/libfb.so
[    11.683] (II) Module fb: vendor="X.Org Foundation"
[    11.683] 	compiled for 1.20.1, module version = 1.0.0
[    11.683] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    11.683] (II) Loading sub module "dri2"
[    11.683] (II) LoadModule: "dri2"
[    11.683] (II) Module "dri2" already built-in
[    11.683] (II) Loading sub module "exa"
[    11.683] (II) LoadModule: "exa"
[    11.683] (II) Loading /usr/lib/xorg/modules/libexa.so
[    11.684] (II) Module exa: vendor="X.Org Foundation"
[    11.684] 	compiled for 1.20.1, module version = 2.6.0
[    11.684] 	ABI class: X.Org Video Driver, version 24.0
[    11.684] (II) RADEON(0): KMS Color Tiling: enabled
[    11.684] (II) RADEON(0): KMS Color Tiling 2D: disabled
[    11.684] (==) RADEON(0): TearFree property default: auto
[    11.684] (II) RADEON(0): KMS Pageflipping: enabled
[    11.684] (II) RADEON(0): SwapBuffers wait for vsync: enabled
[    11.687] (II) RADEON(0): Output VGA-0 has no monitor section
[    11.688] (II) RADEON(0): Output LVDS has no monitor section
[    11.698] (II) RADEON(0): Output S-video has no monitor section
[    11.701] (II) RADEON(0): EDID for output VGA-0
[    11.702] (II) RADEON(0): EDID for output LVDS
[    11.702] (II) RADEON(0): Printing probed modes for output LVDS
[    11.702] (II) RADEON(0): Modeline "1280x800"x60.0   68.90  1280 1296 1328 1408  800 804 808 816 (48.9 kHz eP)
[    11.702] (II) RADEON(0): Modeline "1280x720"x60.0   74.65  1280 1344 1472 1664  720 723 728 748 -hsync +vsync (44.9 kHz)
[    11.702] (II) RADEON(0): Modeline "1152x768"x59.9   71.95  1152 1216 1328 1504  768 771 781 798 -hsync +vsync (47.8 kHz)
[    11.702] (II) RADEON(0): Modeline "1024x768"x59.9   63.53  1024 1072 1176 1328  768 771 775 798 -hsync +vsync (47.8 kHz)
[    11.702] (II) RADEON(0): Modeline "800x600"x60.0   38.31  800 832 912 1024  600 603 607 624 -hsync +vsync (37.4 kHz)
[    11.702] (II) RADEON(0): Modeline "848x480"x59.9   31.65  848 872 952 1056  480 483 493 500 -hsync +vsync (30.0 kHz)
[    11.702] (II) RADEON(0): Modeline "720x480"x59.9   26.85  720 744 808 896  480 483 493 500 -hsync +vsync (30.0 kHz)
[    11.702] (II) RADEON(0): Modeline "640x480"x59.9   23.98  640 664 720 800  480 483 487 500 -hsync +vsync (30.0 kHz)
[    11.712] (II) RADEON(0): EDID for output S-video
[    11.712] (II) RADEON(0): Output VGA-0 disconnected
[    11.712] (II) RADEON(0): Output LVDS connected
[    11.712] (II) RADEON(0): Output S-video disconnected
[    11.712] (II) RADEON(0): Using exact sizes for initial modes
[    11.712] (II) RADEON(0): Output LVDS using initial mode 1280x800 +0+0
[    11.712] (II) RADEON(0): mem size init: gart size :1dff000 vram size: s:4000000 visible:7bd8000
[    11.712] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM
[    11.712] (==) RADEON(0): DPI set to (96, 96)
[    11.712] (==) RADEON(0): Using gamma correction (1.0, 1.0, 1.0)
[    11.712] (II) Loading sub module "ramdac"
[    11.712] (II) LoadModule: "ramdac"
[    11.712] (II) Module "ramdac" already built-in
[    11.712] (II) UnloadModule: "modesetting"
[    11.713] (II) Unloading modesetting
[    11.713] (II) RADEON(0): [DRI2] Setup complete
[    11.713] (II) RADEON(0): [DRI2]   DRI driver: r300
[    11.713] (II) RADEON(0): [DRI2]   VDPAU driver: r300
[    11.713] (II) RADEON(0): Front buffer size: 4000K
[    11.713] (II) RADEON(0): VRAM usage limit set to 110505K
[    11.713] (==) RADEON(0): DRI3 disabled
[    11.713] (==) RADEON(0): Backing store enabled
[    11.713] (II) RADEON(0): Direct rendering enabled
[    11.713] (II) RADEON(0): Render acceleration enabled for R300/R400/R500 type cards.
[    11.714] (II) EXA(0): Driver allocated offscreen pixmaps
[    11.714] (II) EXA(0): Driver registered support for the following operations:
[    11.714] (II)         Solid
[    11.714] (II)         Copy
[    11.714] (II)         Composite (RENDER acceleration)
[    11.714] (II)         UploadToScreen
[    11.714] (II)         DownloadFromScreen
[    11.714] (II) RADEON(0): Acceleration enabled
[    11.714] (==) RADEON(0): DPMS enabled
[    11.714] (==) RADEON(0): Silken mouse disabled
[    11.714] (II) RADEON(0): Set up textured video
[    11.714] (II) RADEON(0): [XvMC] Associated with Radeon Textured Video.
[    11.714] (II) RADEON(0): [XvMC] Extension initialized.
[    11.715] (II) Initializing extension Generic Event Extension
[    11.715] (II) Initializing extension SHAPE
[    11.715] (II) Initializing extension MIT-SHM
[    11.716] (II) Initializing extension XInputExtension
[    11.716] (II) Initializing extension XTEST
[    11.717] (II) Initializing extension BIG-REQUESTS
[    11.717] (II) Initializing extension SYNC
[    11.718] (II) Initializing extension XKEYBOARD
[    11.718] (II) Initializing extension XC-MISC
[    11.719] (II) Initializing extension SECURITY
[    11.719] (II) Initializing extension XFIXES
[    11.719] (II) Initializing extension RENDER
[    11.720] (II) Initializing extension RANDR
[    11.721] (II) Initializing extension COMPOSITE
[    11.721] (II) Initializing extension DAMAGE
[    11.722] (II) Initializing extension MIT-SCREEN-SAVER
[    11.722] (II) Initializing extension DOUBLE-BUFFER
[    11.723] (II) Initializing extension RECORD
[    11.723] (II) Initializing extension DPMS
[    11.723] (II) Initializing extension Present
[    11.724] (II) Initializing extension DRI3
[    11.724] (II) Initializing extension X-Resource
[    11.724] (II) Initializing extension XVideo
[    11.725] (II) Initializing extension XVideo-MotionCompensation
[    11.725] (II) Initializing extension GLX
[    11.863] (EE) 
[    11.863] (EE) Backtrace:
[    11.864] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x52) [0x516d92]
[    11.864] (EE) 1: /usr/lib/Xorg (0x473000+0xa3ec2) [0x516ec2]
[    11.864] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7f64d38]
[    11.864] (EE) 3: /usr/lib/dri/r300_dri.so (0xb5f6b000+0x469167) [0xb63d4167]
[    11.864] (EE) 4: /usr/lib/dri/r300_dri.so (0xb5f6b000+0x3e69f) [0xb5fa969f]
[    11.864] (EE) 5: /lib/ld-linux.so.2 (0xb7f66000+0x10263) [0xb7f76263]
[    11.864] (EE) 6: /lib/ld-linux.so.2 (0xb7f66000+0x10366) [0xb7f76366]
[    11.864] (EE) 7: /lib/ld-linux.so.2 (0xb7f66000+0x13fd0) [0xb7f79fd0]
[    11.864] (EE) 8: /usr/lib/libc.so.6 (_dl_catch_exception+0x99) [0xb7e84349]
[    11.864] (EE) 9: /lib/ld-linux.so.2 (0xb7f66000+0x13873) [0xb7f79873]
[    11.864] (EE) 10: /usr/lib/libdl.so.2 (0xb7b8c000+0x11d7) [0xb7b8d1d7]
[    11.864] (EE) 11: /usr/lib/libc.so.6 (_dl_catch_exception+0x99) [0xb7e84349]
[    11.865] (EE) 12: /usr/lib/libc.so.6 (_dl_catch_error+0x34) [0xb7e84404]
[    11.865] (EE) 13: /usr/lib/libdl.so.2 (0xb7b8c000+0x19b7) [0xb7b8d9b7]
[    11.865] (EE) 14: /usr/lib/libdl.so.2 (dlopen+0x5a) [0xb7b8d27a]
[    11.865] (EE) 15: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0xc050) [0xb7200050]
[    11.865] (EE) 16: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0x2b294) [0xb721f294]
[    11.865] (EE) 17: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0xa98e) [0xb71fe98e]
[    11.865] (EE) 18: /usr/lib/Xorg (_CallCallbacks+0x3a) [0x5def0a]
[    11.865] (EE) 19: /usr/lib/Xorg (0x473000+0x920f4) [0x5050f4]
[    11.865] (EE) 20: /usr/lib/Xorg (InitExtensions+0x7e) [0x61e5ce]
[    11.865] (EE) 21: /usr/lib/Xorg (0x473000+0x29472) [0x49c472]
[    11.865] (EE) 22: /usr/lib/libc.so.6 (__libc_start_main+0xf9) [0xb7d64a49]
[    11.865] (EE) 23: /usr/lib/Xorg (0x473000+0x2a352) [0x49d352]
[    11.865] (EE) 
[    11.865] (EE) Illegal instruction at address 0xb63d4167
[    11.866] (EE) 
Fatal server error:
[    11.866] (EE) Caught signal 4 (Illegal instruction). Server aborting
[    11.866] (EE) 
[    11.866] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    11.866] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    11.866] (EE) 
[    11.866] (EE) 
[    11.866] (EE) Backtrace:
[    11.866] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x52) [0x516d92]
[    11.866] (EE) 1: /usr/lib/Xorg (0x473000+0xa3ec2) [0x516ec2]
[    11.867] (EE) 2: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7f64d38]
[    11.867] (EE) 3: /usr/lib/Xorg (xf86ScreenToScrn+0x13) [0x4e2ae3]
[    11.867] (EE) 4: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6f02000+0x4270c) [0xb6f4470c]
[    11.867] (EE) 5: /usr/lib/xorg/modules/drivers/radeon_drv.so (0xb6f02000+0x45dc6) [0xb6f47dc6]
[    11.867] (EE) 6: /usr/lib/Xorg (0x473000+0x6ca2e) [0x4dfa2e]
[    11.867] (EE) 7: /usr/lib/Xorg (AbortDDX+0x79) [0x4f65b9]
[    11.867] (EE) 8: /usr/lib/Xorg (FatalError+0x118) [0x509c68]
[    11.867] (EE) 9: /usr/lib/Xorg (0x473000+0xa3f0a) [0x516f0a]
[    11.867] (EE) 10: linux-gate.so.1 (__kernel_rt_sigreturn+0x0) [0xb7f64d38]
[    11.867] (EE) 11: /usr/lib/dri/r300_dri.so (0xb5f6b000+0x469167) [0xb63d4167]
[    11.867] (EE) 12: /usr/lib/dri/r300_dri.so (0xb5f6b000+0x3e69f) [0xb5fa969f]
[    11.867] (EE) 13: /lib/ld-linux.so.2 (0xb7f66000+0x10263) [0xb7f76263]
[    11.867] (EE) 14: /lib/ld-linux.so.2 (0xb7f66000+0x10366) [0xb7f76366]
[    11.867] (EE) 15: /lib/ld-linux.so.2 (0xb7f66000+0x13fd0) [0xb7f79fd0]
[    11.867] (EE) 16: /usr/lib/libc.so.6 (_dl_catch_exception+0x99) [0xb7e84349]
[    11.868] (EE) 17: /lib/ld-linux.so.2 (0xb7f66000+0x13873) [0xb7f79873]
[    11.868] (EE) 18: /usr/lib/libdl.so.2 (0xb7b8c000+0x11d7) [0xb7b8d1d7]
[    11.868] (EE) 19: /usr/lib/libc.so.6 (_dl_catch_exception+0x99) [0xb7e84349]
[    11.868] (EE) 20: /usr/lib/libc.so.6 (_dl_catch_error+0x34) [0xb7e84404]
[    11.868] (EE) 21: /usr/lib/libdl.so.2 (0xb7b8c000+0x19b7) [0xb7b8d9b7]
[    11.868] (EE) 22: /usr/lib/libdl.so.2 (dlopen+0x5a) [0xb7b8d27a]
[    11.868] (EE) 23: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0xc050) [0xb7200050]
[    11.868] (EE) 24: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0x2b294) [0xb721f294]
[    11.868] (EE) 25: /usr/lib/xorg/modules/extensions/libglx.so (0xb71f4000+0xa98e) [0xb71fe98e]
[    11.868] (EE) 26: /usr/lib/Xorg (_CallCallbacks+0x3a) [0x5def0a]
[    11.868] (EE) 27: /usr/lib/Xorg (0x473000+0x920f4) [0x5050f4]
[    11.868] (EE) 28: /usr/lib/Xorg (InitExtensions+0x7e) [0x61e5ce]
[    11.868] (EE) 29: /usr/lib/Xorg (0x473000+0x29472) [0x49c472]
[    11.868] (EE) 30: /usr/lib/libc.so.6 (__libc_start_main+0xf9) [0xb7d64a49]
[    11.869] (EE) 31: /usr/lib/Xorg (0x473000+0x2a352) [0x49d352]
[    11.869] (EE) 
[    11.869] (EE) Segmentation fault at address 0x2a0
[    11.869] (EE) 
FatalError re-entered, aborting
[    11.869] (EE) Caught signal 11 (Segmentation fault). Server aborting
[    11.869] (EE)

inxi -Fxz:

System:    Host: manjaro Kernel: 4.9.76-1-MANJARO i686 bits: 32 gcc: 7.2.1 Desktop: N/A Distro: Manjaro Linux
Machine:   Device: laptop System: TOSHIBA product: Satellite P10 v: PSP16E-0S23K-GR serial: N/A
           Mobo: TOSHIBA model: DAW01/DAL01 v: Null serial: N/A BIOS: TOSHIBA v: V1.60 date: 11/17/2005
Battery    BAT1: charge: 59.2 Wh 100.0% condition: 59.2/59.2 Wh (100%) model: TOSHIBA PA3307U status: N/A
CPU:       Single core Mobile Intel Pentium 4 (-MT-) arch: Netburst Prescott rev.4 cache: 1024 KB
           flags: (pae sse sse2 sse3) bmips: 6135
           clock speeds: max: 3066 MHz 1: 1866 MHz 2: 1866 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] RV350/M10 / RV360/M11 [Mobility Radeon 9600 (PRO) / 9700]
           bus-ID: 01:05.0
           Display Server: N/A drivers: ati,radeon (unloaded: modesetting) tty size: 126x37
Audio:     Card Advanced Micro Devices [AMD/ATI] IXP150 AC'97 Audio Controller
           driver: snd_atiixp bus-ID: 00:14.5
           Sound: Advanced Linux Sound Architecture v: k4.9.76-1-MANJARO
Network:   Card-1: Advanced Micro Devices [AMD/ATI] IXP200 3COM 3C920B Ethernet Controller
           port: 0000a000-0000afff bus-ID: 00:14.4
           IF: null-if-id state: N/A speed: N/A duplex: N/A mac: N/A
           Card-2: Qualcomm Atheros AR922X Wireless Network Adapter driver: ath9k bus-ID: 02:02.0
           IF: wlp2s2 state: down mac: <filter>
           Card-3: Realtek RTL-8100/8101L/8139 PCI Fast Ethernet Adapter
           driver: 8139too v: 0.9.28 port: a000 bus-ID: 02:03.0
           IF: enp2s3 state: down mac: <filter>
Drives:    HDD Total Size: 388.1GB (32.7% used)
           ID-1: /dev/sda model: TS128GPSD330 size: 128.0GB
           ID-2: USB /dev/sdb model: STORAGE_DEVICE size: 4.0GB
           ID-3: USB /dev/sdc model: Voyager_GTX size: 256.1GB
Partition: ID-1: / size: 1.5G used: 23M (2%) fs: overlay dev: N/A
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 147 Uptime: 9 min Memory: 288.1/2017.5MB Init: systemd Gcc sys: 7.2.1
           Client: Shell (bash 4.4.121) inxi: 2.3.53

It looks that a general Problem is the “ati,radeon” Video Driver.

DK3


#27

You cannot consider manjaro32 a reliable system for a user with so little experience as you have. You should have a distro you can better rely on. Seriously, you have much to learn to be able to use Manjaro!
See the first post?

A tip about could not satisfy dependencies: (i) you should read the Arch and Manjaro Wiki, the error is mentioned there, (ii) remove packages which depend on the package you want to remove.
sudo pacman -Rn packageA packageB ...


#49

Manjaro made a decision to end the 32-bit spin. You need to accept that. I know that is tough, like life. Now for some alternatives. Lubuntu has a 32-bit spin and so does Fedora. Check them out. I know you are stressed out but why? Have you messed up someone’s machine or something like that? I am telling you these words because I have been a software developer since 1963 and I have screwed up before. You need to learn from it. But, this is important, there are alternatives that are being kept up. Download one of them and give it a try, especially since this seems so urgent. Also, check out DistroWatch.com, you can search for other 32-bit spins.

Most of all, getting really freaked out is never kool. It affects you and those around you.

gary

Edit: Oh, I forgot to tell you, when any interaction with a computer system kicks out a bunch of errors, first try to solve the first error. Often the first error causes a waterfall of errors but when you fix the first one, many times the rest go away. Gary Kildall, the creator of the CP/M operating system, taught me that.


#50

14 posts were split to a new topic: Yet another advise to throw away 32bit hardware


#57

My System works again by Downgrading only 3 Mesa Packages:

mesa-vdpau-18.1.7-1.0-i686.pkg.tar.xz
libva-mesa-driver-18.1.7-1.0-i686.pkg.tar.xz
mesa-18.1.7-1.0-i686.pkg.tar.xz

DK3


#58

Thanks DK3! Mesa downgrades worked for my old 32bit machine which hung on boot after the update. Running a GeForce 6200 AGP card by Nvidia using the video-linux driver.


#59

No real problems. Remmina from repos works but doesn’t have icons anymore in tray or main program window. But its not something crucial so it doesn’t matter.


#60

If you feel this, then it may well be what you need to do, sad as it may be…
Still, you diserve a hug


…for all your effort.
And in the event that you do feel like continuing…I’m okay with some more stale packages as well. There is no reason for the bleeding edge where I stand :smiley_cat:
Thanks
:hugs:
Melissa


#61

Any way you got past wayland?
I’m stuck there, I did a “wet finger” (Flemmish expression :wink: ) downgrade and no luck… :smile:


#62

Downgrade of what precisely?