[Stable Update i686] 2018-06-07 - pacman 5.1, kernels, Chromium, Qt5

update
stable
manjaro32

#1

Hello i686ers!

This update set introduces pacman 5.1. All other package management tools should now be rebuilt and work with the new library version.

There’s an update to archlinux32-keyring. Please update that first to ensure the rest of the packages validate correctly.

There are plenty of updates for other software. Good news is that Chromium builds again on i686 without any changes from the Arch PKGBUILD, so we should get more regular builds now.

There’s the normal set of Haskell, Perl, and Python module updates.

Also, kernels.


Anyone who would like to help out testing the upstream packages, please read the archlinux32 thread for details about how they automate their testing process and how to get involved:

https://bbs.archlinux32.org/viewtopic.php?id=171

(running this in an archlinux32 VM would be fine, there will hopefully be a way of doing this directly from within manjaro32 in the future)


Available kernels

Series Version
linux316 3.16.56
linux41 4.1.51
linux44 4.4.135
linux49 4.9.105
linux414 4.14.47

archlinux32

If you find manjaro32 useful please consider donating to, or helping out with, archlinux32. It’s a small team taking on a huge project and any help will no doubt be very much appreciated.

Why aren’t the available packages/package versions the same as x86_64?

archlinux32 packages are based on Arch packages but may need editing to build correctly. Builds of less-popular packages are lower priority.

Manjaro-specific packages may lag behind x86_64 because there aren’t as many packagers. If you notice an important package is lagging please report it; at the moment it’s only me packaging for i686:

I’m only packaging current LTS kernels. Any marked as EOL are dropped. I’ll not be building the mainline kernel.

What about security updates?

I cannot guarantee timely security updates on x32-stable. If this is critical for you I recommend you switch to x32-testing or cherry-pick those packages from x32-testing or x32-unstable as they become available.

Something broke. Isn’t this meant to be stable?

“Stable” means “infrequently changing”, not “everything will work perfectly all the time”. If you want it to mean everything works, you need to help test the things you’re interested in.

What about installer images?

Phil very kindly updated the preview installer images:

What about x32-testing and x32-unstable?

These are already available, and I recommend you use x32-testing if you can to make sure testing is done.

x32-unstable should be used by anyone who wants to try and find any issues before they impact other people. If you have multiple/many machines you really should run one of those on x32-unstable.

Full list of changes

Full list is available here.


Any problems?

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters



[Testing Update i686] 2018-06-01 - pacman 5.1, kernels, Chromium, Qt5
[Testing Update i686] 2018-06-07 to 17 - GCC 8.1.1, kernels, Firefox, Chromium, KDE Framework, TeX Live
#2

Known issues and solutions


error: qt5-svg: signature from "Tyler Dence (Build Key) <tyzoid@archlinux32.org>" is marginal trust

First, make sure you have updated archlinux32-keyring:

sudo pacman -Sy archlinux32-keyring
sudo pacman -Syu

If you still get the same error, run:

sudo pacman-key --refresh-keys

Cannot mix incompatible Qt library (version 0x50a01) with this library (version 0x50b00)

If you get this:

qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50a01) with this library (version 0x50b00)
Aborted (core dumped)

Remove your qt5ct config,

rm $HOME/.config/qt5ct/qt5ct.conf

and let it be regenerated. Currently the gtk2 plugin causes a crash.

If you want the gtk2 look-and-feel then export QT_QPA_PLATFORMTHEME=gtk2 in your .profile (instead of qt5ct).


:: ffmpeg2.8: installing x265 (2.8-1.0) breaks dependency 'libx265.so=151-32'

ffmpeg2.8 is no longer in the repos. Remove it,

sudo pacman -Rncs ffmpeg2.8

and reinstall it from the AUR if you need it.



[Testing Update i686] 2018-07-14 - KDE and Plasma, Network Manager
#3

Had to remove python-pip, a dependency is not available in repo or AUR.

The dependency is listed as python-pytoml.

System upgrade would not proceed until I deleted python-pip


#4

CitaHad to remove python-pip, a dependency is not available in repo or AUR.

The dependency is listed as python-pytoml.

System upgrade would not proceed until I deleted python-pip

Same issue here… Everything goes fine after uninstalling that package…


#5

or use pacman -Syyu and choose Yes to ignore that package and wait for the fix to be released upstream. I traced it back to hplip scan to PDF on my system as the only thing requiring it. I’ve ended up uninstalling it because my HP printer is not an MFP. I use a canoscan LiDE 50.


#6

Same Problem:

python-pip and python2-pip needs
python-pytoml and python2-pythoml

After Uninstalling python-pip and python2-pip, Update on 1 Machine and 1 VB without Problems except I cannot use ocrfeeder due to the dependencies thing.

DK3


#7

python-pytoml and python2-pytoml are now available in the repo. That should fix this stuff.


#8

Confirmed!
Thank you very much for your prompt action and assistance.


#9

Works now.

Thx.

DK3


#10

Thank you!

Everything running fine here too.


#11

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.