Stable-Update causes Failed to start

Like many others I updated my Manjaro system and ended up with the dreaded Failed to start Load Kernel Modules and Failed to start Light Display Manager.

I did some searching and found several “fixes” that involved chroot and such with Live system. I was not able to resolve the situation using any of them because for whatever reason, even though I could browse the web, pacman said I had no internet, so I started digging a little deeper. Of course I ran a crossed the notation of the update removing older Nvidia drivers. A little testing proved that I could get into a tty with Ctrl + Alt + Fx (I used F3) and log in.

Knowing it is broken Nvidia causing the issue, I tried first to run sudo mhwd -a pci nonfree 0300 to install the latest Nvidia drivers. This failed because of dependency issues caused by other Nvidia related packages.

Long story short, I ended up using pacman -R … to uninstall pretty much anything Nvidia (sorry, I forget the package list). Once those were uninstalled I ran the sudo mhwd -a pci nonfree 0300 again. Like magic it zipped along and installed the latest Nvidia package and those dependencies that matched current kernel.

After a sudo restart all was well. I hope that this experience can help some other user with the same issues get their system back up and running.

1 Like

:+1: Thank you for sharing! :+1:

Please do me a favour and split the above into a question - answer (cut and paste the solution from your Q&A into a reply to your own question and then click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.