[Stable Update] 2024-06-10 - Kernels, Systemd, NVIDIA, Mesa, Qt5

Server synchronization issue?

pamac update -a                                                             1 ✘ 
Preparing...
Sincronización de bases de datos de paquetes...
Refreshing AUR...                                                                                          
Warning: ignoring package replacement (cpufrequtils-008-3 => cpupower-6.9-1)                               
Resolving dependencies...
Warning: cannot resolve "nvidia-utils=550.90.07", a dependency of "linux66-nvidia"
Warning: cannot resolve "nvidia-utils=550.90.07", a dependency of "linux68-nvidia"
Warning: cannot resolve "nvidia-utils=550.90.07", a dependency of "linux69-nvidia"
Error: Failed to prepare transaction:
could not satisfy dependencies:
- unable to satisfy dependency 'nvidia-utils=550.90.07' required by linux66-nvidia

It will take a while until the missing packages are synced: [manjaro-packages] [BoxIt] Memo (x64)

:facepalm:

4 Likes

Same issue … but if i take yay instead of pamac most packages could be updated:

Abhängigkeiten werden aufgelöst …
Warnung: Kann "nvidia-utils=550.90.07" nicht auflösen (eine Abhängigkeit von "linux515-nvidia")
Warnung: Kann "nvidia-utils=550.90.07" nicht auflösen (eine Abhängigkeit von "linux61-nvidia")
:: Die folgenden Pakete können aufgrund nicht auflösbarer Abhängigkeiten nicht aktualisiert werden:
      linux515-nvidia  linux61-nvidia

:: Möchten Sie die oben genannten Pakete bei dieser Aktualisierung überspringen? [j/N] j
Nach in Konflikt stehenden Paketen wird gesucht …
 Es gibt nichts zu tun

Info:

Generated on 2024-06-10 11:48:1718012919

#################### inxi -Fxzc0 ########################

System:
  Kernel: 6.1.92-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
  Desktop: Xfce v: 4.18.1 Distro: Manjaro base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81RS v: Lenovo Yoga S740-14IIL serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <superuser required> UEFI: LENOVO
    v: BYCN39WW date: 05/28/2021
Battery:
  ID-1: BAT0 charge: 63.2 Wh (96.8%) condition: 65.3/62.0 Wh (105.3%) volts: 17.0 min: 15.4
    model: LGC L19L4PD2 status: full
CPU:
  Info: quad core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake rev: 5 cache:
    L1: 320 KiB L2: 2 MiB L3: 8 MiB
  Speed (MHz): avg: 512 high: 1300 min/max: 400/3900 cores: 1: 400 2: 1300 3: 400 4: 400 5: 400
    6: 400 7: 400 8: 400 bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel arch: Gen-11
    bus-ID: 00:02.0
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Lenovo driver: nvidia v: 550.78 arch: Pascal
    bus-ID: 2b:00.0
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB bus-ID: 3-5:5
  Display: x11 server: X.Org v: 21.1.13 driver: X: loaded: modesetting,nvidia unloaded: nouveau
    dri: iris gpu: i915 resolution: 1: 1920x1080~60Hz 2: N/A
  API: EGL v: 1.5 drivers: iris,nvidia,swrast platforms: active: gbm,x11,surfaceless,device
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.9-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Iris Plus Graphics (ICL GT2)
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo driver: sof-audio-pci-intel-icl
    bus-ID: 00:1f.3
  API: ALSA v: k6.1.92-1-MANJARO status: kernel-api
  Server-1: sndiod v: N/A status: off
  Server-2: PipeWire v: 1.0.7 status: active
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB bus-ID: 2-1.4:4
  IF: enp0s13f0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB bus-ID: 3-10:8
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 1.86 TiB used: 226.26 GiB (11.9%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA1T0TCK size: 953.87 GiB temp: 47.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10EARX-00N0YB0 size: 931.51 GiB type: USB
  ID-3: /dev/sdb vendor: Kingston model: DataTraveler 2.0 size: 14.54 GiB type: USB
Partition:
  ID-1: / size: 57.85 GiB used: 40.3 GiB (69.7%) fs: ext4 dev: /dev/nvme0n1p8
  ID-2: /boot/efi size: 259.5 MiB used: 103.6 MiB (39.9%) fs: vfat dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 16.67 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p9
Sensors:
  System Temperatures: cpu: 46.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.19 GiB used: 3.43 GiB (22.6%)
  Processes: 292 Uptime: 1d 14h 25m Init: systemd
  Packages: 2113 Compilers: clang: 17.0.6 gcc: 14.1.1 Client: Unknown Client: wrapper-2.0
    inxi: 3.3.34

No other probs so far …

just for the info. after the upgrade, i can get GDM to boot with nvidia non-free drivers. free drivers are working. i’ll post more later… need to get some work done!

7 posts were split to a new topic: Not enough free disk space during update

Hi,

After update Manjaro boots to a black screen. Both on kernel 5.15 and 6.6. I can access other terminals but that is CLI only.

Journalctl shows activation request for org.freedesktop.nm_dispatcher' failed.

Nvidia SMI shows version 550.90.07 and CUDA 12.4.

Only have mobile now, so hard to post logs. My last update was the big Wydnesday one.

Not sure what to do next. Thanks.

5 Likes

Same here.
Tried:
5.4
5.10
5.15
6.1
6.6
No success.
Awaiting assistance.

AT

2 Likes

i got the same issue, gdm won’t start. as a temporary fix in installed free drivers and uninstalled nonfree (nvidia) drivers.

2 Likes

Same issue here on KDE as well.
I tried these older kernels too and even moved to the unstable branch hoping that the latest beta Nvidia drivers and the 6.10rc kernel would fix that but unfortunately not :dizzy_face:

In the end I reverted to an old Timeshift backup since this was my work laptop.

1 Like

Seems there is a problem with the proprietary NVIDIA and this update.

  1. My Main-PC Desktop with RTX4070 updated fine → No Problem
  2. My Razer Blade 15 with Intel/Nvidia combo gets stuck at Reached target Graphical Interface → had to timeshift back before the update

Problem exists with both Kernels 6.9 and 6.6

PS: I am on KDE on both machines.

PSS: One very random sidenote: On my Desktop-PC shortly before switching to grahpical interface (sddm) I noticed a change of the tty font. Didn’t notice this before (but could have overlooked it in the past).
And this change does not happen on the laptop → maybe this is a hint to something?

Maybe only a problem with hybrid gpus on notebooks?

inxi -G
Graphics:
  Device-1: Intel CometLake-H GT2 [UHD Graphics] driver: i915 v: kernel
  Device-2: NVIDIA TU116M [GeForce GTX 1660 Ti Mobile] driver: nvidia
    v: 550.78
  Device-3: IMC Networks USB Camera driver: uvcvideo type: USB
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 1920x1080~144Hz
  API: EGL v: 1.5 drivers: iris,kms_swrast,nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.8-manjaro1.1
    renderer: Mesa Intel UHD Graphics (CML GT2)
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib
mhwd -li                                                                                                                                                                         ✔ 
> Installed PCI configs:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
video-hybrid-intel-nvidia-prime            2023.03.23               false            PCI
     video-modesetting            2020.01.13                true            PCI


Warning: No installed USB configs!

As always, timeshift backup, updated via GUI within KDE. no issues.

Thanks guys.

2 Likes

My PC won’t start KDE anymore nor shell. Just blinking 5 times on a single text line.
What can I do?
(I still have Grub menu, with multiboot).
HEEEEEELP!!!

(I’m writing from Windows dual boot partition)

1 Like

I found the culprit:

Info from first post from @philm:

NVIDIA 550.90.07-2: nvidia-drm parameters are now set by default
With the NVIDIA 550.90.07-2 packages, the nvidia-drm modeset=1 and fbdev=1 parameters are now set by default…

When I boot my notebook Intel/NVIDIA combo with nvidia_drm.modeset=1 I can reproduce the same behaviour.
I guess we have to disable it on hybrid?
Anyone knows how to disable this new default configuration?

EDIT: Just updated again and rebooted with edited grub commandline: nvidia_drm.modeset=0. And it worked.
Is editing GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub the best practice way or is there a better solution?

5 Likes

In the same boat with an Intel/Nvidia hybrid laptop. I switched to open source graphics drivers using mhwd and can get to the desktop at least. Had other problems so I’m on a fresh minimal Gnome install

I have my desktop back. Only change I made was adding nvidia-drm modeset=0 to grub as explained in the top post. Of course reloading grub after that.

1 Like

Sorry had a typo: edited it in my post above: nvidia_drm.modeset=0

3 Likes

Many thanks!

1 Like

I encountered the next weird thing on my desktop machine (rtx4070):
When calling fastfetch in TTY: results in a blackscreen → switching to graphic session and back to tty solves this.
But with this issue I can’t say with certainty if it did exist before the update.
Maybe a problem in tty when querying GPU info?

PS: After a few tries I can pinpoint the problem: it occurs when calling the display module.

inxi -G
Graphics:
  Device-1: NVIDIA AD104 [GeForce RTX 4070] driver: nvidia v: 550.90.07
  Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0 driver: X:
    loaded: nvidia gpu: nvidia,nvidia-nvswitch resolution: 1: 2560x1440
    2: 2560x1440
  API: EGL v: 1.5 drivers: nvidia,swrast
    platforms: gbm,x11,surfaceless,device
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.90.07
    renderer: NVIDIA GeForce RTX 4070/PCIe/SSE2
  API: Vulkan v: 1.3.279 drivers: nvidia surfaces: xcb,xlib

A post was split to a new topic: Vmware-horizon-client stopped working on KDE ever since Plasma 6 update