[Stable Update] 2024-03-06 - Kernels, Systemd, KDE Gear, Qt, GNOME, Firefox, Thunderbird

A post was split to a new topic: Unison-gui crashes

Somehow, transparency for inactive windows on my Xfce desktop was activated with this update. Annoying because I usually have one reading-from window and one writing-to window open side-by-side. It should have been easy to fix, but I couldn’t remember where, among all the similarly named settings apps, compositing effects can be controlled.

The most promising Settings menu choices are titled: Appearance, Desktop, Display, Settings Manager, Window Manager, Window Manager Tweaks, and Workspaces. And then there are the less promising app titles, such as Manjaro Settings Manager, Kvantum, and Qt5 Settings.

All is fine now, but there should be a punishment for people-who-name-things-inadequately. I found the transparency effects are controlled under the Compositor tab of the Window Manager Tweaks app. Grr!

2 Likes

After working for a while, my touchpad’s click does not work anymore. I’ve also tested with a mouse and faced the same issue. Disabling all the gnome shell extensions does not prevent this issue!

Thanks for the updates, previously Vivaldi won’t start now it’s fixed. But screen tearing after wakeup still persist.

1 Like

A post was split to a new topic: Unable to launch any gtk+ applications

Hi!

Using aom (libaom-av1) in ffmpeg for generating avif images with film grain keeps failing for some images.

First upgrade I can remember that told me my installation would be 50M smaller afterwards :laughing:

One message that may have zipped past people un-noticed:

MariaDB was updated to a new feature release. To update the data run:
systemctl restart mariadb.service && mariadb-upgrade -u root -p

I don’t know what the implications of not doing this might be…

I am on stable branch but don’t get this update?!

Some infos:

[john1@manjaro Dokumente]$ yay
[sudo] Passwort für john1: 
:: Paketdatenbanken werden synchronisiert …
 core ist aktuell
 extra                                                                                               8,7 MiB  16,4 MiB/s 00:01 [-----------------------------------------------------------------------------] 100%
 multilib ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
 Es gibt nichts zu tun

[john1@manjaro ~]$ pacman-mirrors
Pacman-mirrors version 4.24.0
Local mirror status for stable branch
Mirror #1   OK  02:37   Germany  https://mirror.23m.com/manjaro/
Mirror #2   OK  00:27   Germany  https://manjaro.kurdy.org/
Mirror #3   OK  00:57   Germany  https://mirror.netcologne.de/manjaro/
Mirror #4   OK  00:17   Germany  https://mirror.alpix.eu/manjaro/
Mirror #5   OK  05:37   Germany  http://ftp.tu-chemnitz.de/pub/linux/manjaro/
Mirror #6   OK  00:27   Germany  https://ftp.gwdg.de/pub/linux/manjaro/

Generated on 2024-03-07 11:28:1709807328

#################### inxi -Fxzc0 ########################

System:
  Kernel: 6.1.80-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
  Desktop: Xfce v: 4.18.1 Distro: Manjaro base: Arch Linux
Machine:
  Type: Laptop System: LENOVO product: 81RS v: Lenovo Yoga S740-14IIL serial: <superuser required>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709 WIN serial: <superuser required> UEFI: LENOVO
    v: BYCN39WW date: 05/28/2021
Battery:
  ID-1: BAT0 charge: 62.6 Wh (95.9%) condition: 65.3/62.0 Wh (105.3%) volts: 16.9 min: 15.4
    model: LGC L19L4PD2 status: full
CPU:
  Info: quad core model: Intel Core i7-1065G7 bits: 64 type: MT MCP arch: Ice Lake rev: 5 cache:
    L1: 320 KiB L2: 2 MiB L3: 8 MiB
  Speed (MHz): avg: 508 high: 1264 min/max: 400/3900 cores: 1: 400 2: 1264 3: 400 4: 400 5: 400
    6: 400 7: 400 8: 400 bogomips: 23968
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Graphics:
  Device-1: Intel Iris Plus Graphics G7 vendor: Lenovo driver: i915 v: kernel arch: Gen-11
    bus-ID: 00:02.0
  Device-2: NVIDIA GP108M [GeForce MX250] vendor: Lenovo driver: nvidia v: 550.54.14 arch: Pascal
    bus-ID: 2b:00.0
  Device-3: Chicony Integrated Camera driver: uvcvideo type: USB bus-ID: 3-5:5
  Display: x11 server: X.Org v: 21.1.11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
    dri: iris gpu: i915 resolution: 1: 1920x1080~60Hz 2: N/A
  API: EGL v: 1.5 drivers: iris,nvidia,swrast platforms: active: gbm,x11,surfaceless,device
    inactive: wayland,device-1
  API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.0.2-manjaro1.1 glx-v: 1.4
    direct-render: yes renderer: Mesa Intel Iris Plus Graphics (ICL GT2)
Audio:
  Device-1: Intel Ice Lake-LP Smart Sound Audio vendor: Lenovo driver: sof-audio-pci-intel-icl
    bus-ID: 00:1f.3
  API: ALSA v: k6.1.80-1-MANJARO status: kernel-api
  Server-1: sndiod v: N/A status: off
  Server-2: PipeWire v: 1.0.3 status: active
Network:
  Device-1: Intel Ice Lake-LP PCH CNVi WiFi driver: iwlwifi v: kernel bus-ID: 00:14.3
  IF: wlp0s20f3 state: up mac: <filter>
  Device-2: Realtek RTL8153 Gigabit Ethernet Adapter driver: r8152 type: USB bus-ID: 2-1.4:4
  IF: enp0s13f0u1u4 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IF-ID-1: pan1 state: down mac: <filter>
Bluetooth:
  Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB bus-ID: 3-10:8
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
Drives:
  Local Storage: total: 1.86 TiB used: 385.96 GiB (20.3%)
  ID-1: /dev/nvme0n1 vendor: Micron model: MTFDHBA1T0TCK size: 953.87 GiB temp: 43.9 C
  ID-2: /dev/sda vendor: Western Digital model: WD10EARX-00N0YB0 size: 931.51 GiB type: USB
  ID-3: /dev/sdb vendor: Kingston model: DataTraveler 2.0 size: 14.54 GiB type: USB
Partition:
  ID-1: / size: 57.85 GiB used: 38.44 GiB (66.4%) fs: ext4 dev: /dev/nvme0n1p8
  ID-2: /boot/efi size: 259.5 MiB used: 132.8 MiB (51.2%) fs: vfat dev: /dev/nvme0n1p1
Swap:
  ID-1: swap-1 type: partition size: 16.67 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p9
Sensors:
  System Temperatures: cpu: 47.0 C mobo: N/A
  Fan Speeds (rpm): N/A
Info:
  Memory: total: 16 GiB note: est. available: 15.19 GiB used: 3.38 GiB (22.3%)
  Processes: 289 Uptime: 1d 44m Init: systemd
  Packages: 2063 Compilers: clang: 16.0.6 gcc: 13.2.1 Client: Unknown Client: wrapper-2.0
    inxi: 3.3.33
06T21:54:53+0100] [ALPM] upgraded thunderbird-i18n-de (115.8.0-1 -> 115.8.1-1)
[2024-03-06T21:54:53+0100] [ALPM] upgraded thunderbird (115.8.0-1 -> 115.8.1-1)

So thunderbird update worked yesterday but no stable branch update?!

What to do next?

Look further back in the log. You’re running kernel 6.1.80 so you must have installed this update.

mpf, my bad … got several updates on 06.03.2024. So everything seemes to be ok!

For minor version updates (e.g. 11.2 to 11.3) things don’t usually break but obviously it’s best to do what it says. See https://mariadb.com/kb/en/upgrading-between-minor-versions-on-linux/

mariadb-upgrade does two things:

  1. Ensures that the system tables in the mysql database are fully compatible with the new version.
  2. Does a very quick check of all tables and marks them as compatible with the new version of MariaDB.
1 Like

5 posts were split to a new topic: Some apps freeze after suspend indefinitely

Some Qt5-Apps like KeepassXC and Manjaro Settings Manager do not respect the Kvantum theme anymore, while others do so. How can this issue be solved?

Probably 3.3

1 Like

After recent update for lightdm, system is not applying configuration settings in ~/.profile including: export QT_QPA_PLATFORMTHEME="qt5ct"
for QT theme

If there is no response to this command

echo $QT_QPA_PLATFORMTHEME

Forum users have posted 3 different ways to resolve this:

  1. Copy configuration in ~/.profile to ~/.bash_profile

OR

  1. Configure ~/.bash_profile to read ~/.profile

    tee -a ~/.bash_profile <<< "[[ -f ~/.profile ]] && . ~/.profile"
    

OR

  1. create a symlink for ~/.profile to ~/.xprofile

    cd $HOME; ln -s .profile .xprofile
    

Xfce theming theming issues with some applications green others blue

2 Likes

After upgrade While sddm starts (as I understood), screen flickers with some garbage. Autologin brings me to Plasma X11 session with compositing turned off. Triet to switch to Wayland - compositing is working but everything is choppy, even mouse. Amd laptop with Amd graphics + discrete nvidia. I think it might be running at Nvidia now? How to revert back to Amd?

Fixed. The problem was in mesa from non-free repository. Downgraded everything to Manjaro’s repos, now everything works (sad that without video acceleration from non-free repo)

After one of the last updates copy/paste stopped working for me on Manjaro sway.
Somebody by any chance has a hint on how to solve this?

And Standby stopped working too.

Looks like update fine but had to do a couple of things due to mozilla/thunar crashes:
sudo pacman -R libva-vdpau-driver
downgrade thunar

Unsure if I miss something from the link or if it is really necessary for me “to deal with the seal” at this point…

╭─░▒▓    ~ ▓▒░                                                   ░▒▓ 3 ✘  15:59:42  ▓▒░─╮
╰─ sudo systemctl restart mariadb.service && mariadb-upgrade -u root -p                     ─╯
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xeu mariadb.service" for details.

╭─░▒▓    ~ ▓▒░                                                   ░▒▓ 1 ✘  15:59:45  ▓▒░─╮
╰─ systemctl status mariadb.service                                                         ─╯
× mariadb.service - MariaDB 11.3.2 database server
     Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2024-03-09 15:59:45 CET; 3s ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
    Process: 2479 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION (c>
    Process: 2480 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR=`>
    Process: 2508 ExecStart=/usr/bin/mariadbd $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START_P>
   Main PID: 2508 (code=exited, status=1/FAILURE)
     Status: "MariaDB server is down"
        CPU: 303ms

Mar 09 15:59:45 COMPUTENAME mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] InnoDB: Loading buffer pool(s>
Mar 09 15:59:45 COMPUTENAME mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] InnoDB: Buffer pool(s) load c>
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Can't open and lock privileg>
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] Server socket created on IP: >
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] Server socket created on IP: >
Mar 09 15:59:45 COMPUTENAME mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Fatal error: Can't open and >
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Aborting
Mar 09 15:59:45 COMPUTENAME  systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FA>
Mar 09 15:59:45 COMPUTENAME  systemd[1]: mariadb.service: Failed with result 'exit-code'.
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Can't open and lock privilege tables: Table 'mysql.se>
Mar 09 15:59:45 COMPUTENAME mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] Server socket created on IP: '0.0.0.0'.
Mar 09 15:59:45 COMPUTENAME mariadbd[2508]: 2024-03-09 15:59:45 0 [Note] Server socket created on IP: '::'.
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Fatal error: Can't open and lock privilege tables: Ta>
Mar 09 15:59:45 COMPUTENAME  mariadbd[2508]: 2024-03-09 15:59:45 0 [ERROR] Aborting
Mar 09 15:59:45 COMPUTENAME  systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ An ExecStart= process belonging to unit mariadb.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Mar 09 15:59:45 COMPUTENAME  systemd[1]: mariadb.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ The unit mariadb.service has entered the 'failed' state with result 'exit-code'.
Mar 09 15:59:45 COMPUTENAME  systemd[1]: Failed to start MariaDB 11.3.2 database server.
░░ Subject: A start job for unit mariadb.service has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ A start job for unit mariadb.service has finished with a failure.
░░ 
░░ The job identifier is 2470 and the job result is failed.
~
~
~
~

╭─░▒▓    ~ ▓▒░                                                                    ░▒▓ ✔  1m 2s   16:01:03  ▓▒░─╮
╰─ mariadb --version                                                                                                 ─╯
mariadb from 11.3.2-MariaDB, client 15.2 for Linux (x86_64) using readline 5.1

journalctl -xeu mariadb.service                                                                                 ─╯
Mar 09 16:07:54COMPUTENAME mariadbd[3018]: 2024-03-09 16:07:54 0 [Note] Plugin 'wsrep-provider' is disabled.
Mar 09 16:07:54COMPUTENAME  mariadbd[3018]: 2024-03-09 16:07:54 0 [Note] InnoDB: Loading buffer pool(s) from /var/lib/mysql/ib_>
Mar 09 16:07:54 COMPUTENAME mariadbd[3018]: 2024-03-09 16:07:54 0 [ERROR] Could not open mysql.plugin table: "Table 'mysql.plug>
Mar 09 16:07:54COMPUTENAME mariadbd[3018]: 2024-03-09 16:07:54 0 [Note] InnoDB: Buffer pool(s) load completed at 240309 16:07:>
Mar 09 16:07:54COMPUTENAME  mariadbd[3018]: 2024-03-09 16:07:54 0 [ERROR] Can't open and lock privilege tables: Table 'mysql.se>
Mar 09 16:07:54 COMPUTENAME mariadbd[3018]: 2024-03-09 16:07:54 0 [Note] Server socket created on IP: '0.0.0.0'.
Mar 09 16:07:54 COMPUTENAME mariadbd[3018]: 2024-03-09 16:07:54 0 [Note] Server socket created on IP: '::'.
Mar 09 16:07:54 COMPUTENAME  mariadbd[3018]: 2024-03-09 16:07:54 0 [ERROR] Fatal error: Can't open and lock privilege tables: Ta>
Mar 09 16:07:54COMPUTENAME  mariadbd[3018]: 2024-03-09 16:07:54 0 [ERROR] Aborting
Mar 09 16:07:54COMPUTENAME systemd[1]: mariadb.service: Main process exited, code=exited, status=1/FAILURE
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ An ExecStart= process belonging to unit mariadb.service has exited.
░░ 
░░ The process' exit code is 'exited' and its exit status is 1.
Mar 09 16:07:54 COMPUTENAME  systemd[1]: mariadb.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ The unit mariadb.service has entered the 'failed' state with result 'exit-code'.
Mar 09 16:07:54COMPUTENAME systemd[1]: Failed to start MariaDB 11.3.2 database server.
░░ Subject: A start job for unit mariadb.service has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ 
░░ A start job for unit mariadb.service has finished with a failure.
░░ 
░░ The job identifier is 2590 and the job result is failed.



I also tried reinstalling and starting it before.

There seem to be permission errors. Did you follow the post-install instructions?

Install mariadb, and run the following command before starting the mariadb.service:

$ mariadb-install-db --user=mysql --basedir=/usr --datadir=/var/lib/mysql

1 Like