[Stable Update] 2024-02-21 - Kernels, KDE, VirtualBox, Calamares, ROCm, Firefox, Thunderbird

People with black screen - remove plymouth as per this post. @philm I suspect there will be many more users like these, perhaps add this to Known Issues.

EDIT For users who don’t know how to get into their system to do that please read the post further down by @Running_Dead89


This implies booting Manjaro via USB? Right? Or any other way? To reach /etc/default/grub and remove splash?

You can also remove splash via the grub menu before booting into the OS.

I am in grub and I guess I have to edit boot options for Manjaro Linux? Or use grub command line? I am totally new to this thing I never touched it. And I wouldn’t want to screw up. Can you be a bit more precise?

Jan 13 stable update came with a problem in Mesa 23.3.3: color boxes appearing while browsing internet, strange images repeated, problems with 3D acceleration, VLC playing only sound in AVIs, etc.

Feb 21 update comes with Mesa 23.3.5 but the problems remain so I had to downgrade Mesa to 23.1.9 again to avoid this issues.

1 Like

As @CrackalackingZ wrote remove splash via grub menu before booting. To do so, highlight your standard boot entry and press ‘E’ on your keyboard. Navigate to the line containing splash, remove only ‘splash’ from it and press F10 to boot. Than you can apply the steps in the post which @MrLavender posted before.


Ok I did it before reading it. I had “quiet splash” I changed it to nosplash
Then a terminal appeared and loaded stuff and puf I was in KDE login page.
Is this supposed to have fixed the issue from now on? Do I have to wait for a fix and revert this to quiet splash later? Just to be clear.
I also updated grub so I guess it saved the option with nosplash and we call it a day? I’ll just look at that flashy terminal when I boot up Manjaro?

As you did this from GRUB itself no, the changes won’t be saved.

You’ll need to edit /etc/default/grub as root to remove it … it’s near the top in this one so not hard to find (for a change!).

I’ve seen there’s a pacman.conf.pacnew file. Compared with pacman.conf one of the changes is the missing “SigLevel = PackageRequired” line in each repository. I don’t understand why… this means the packages signature won’t be checked before install?


SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist


Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist

Include = /etc/pacman.d/mirrorlist```
1 Like

Done! thanks. I guess I’ll keep it like this forever

1 Like

4 posts were split to a new topic: Updated but no sound

After editing, don’t forget to run sudo update-grub in terminal. And you don’t have to add nosplash there, just remove splash from it and you’re good.


I could solve it by using pacman -Syu

This one complains the same, but gives me an option to continue. When I read surrounding messages, I don’t know if I have enough power to continue today :wink:

ostrzeżenie: nie można rozwiązać "alsa-lib=1.2.11", zależności od "lib32-alsa-lib"
:: Następujące pakiety nie mogły zostać zaktualizowane w wyniku niespełnionych zależności:
      lib32-alsa-lib  lib32-libjpeg-turbo

:: Czy chcesz pominąć powyższe pakiety przy aktualizacji? [t/N] 

Ok. My mirror list was out-of-date. After running pacman-mirrors it went smoothly

Re “Please post your solution”: I ran into the the following 6 issues (and found the following 6 solutions) during and after this update:

  1. Pacman couldn’t be updated because that would break “rebuild-detector”. Pacman itself couldn’t proceed and offered no solutions. Pamac, however, simply deleted “rebuild-detector” and forged ahead. I was able to re-install “rebuild-detector” after update and restart.

  2. Pacman or Pamac decided to wipe-out my “/etc/bash.bashrc” file and replace it with a nearly-empty changeling. This was completely unacceptable, as that file contained years of enhancements (settings, paths, aliases, etc). I was considering Timeshift-ing back a week or two until I noticed that my previous file had been saved as “bash.bashrc.pacsave”. So I did “mv bash.bashrc bash.bashrc_DESTROYED-BY-PAMAC” followed by “cp bash.bashrc.pacsave bash.bashrc” and bash now works correctly again.

  3. Apparently all AUR files now require a program called “fakeroot” to be present before they can be updated. it wasn’t present, so all AUR updates failed. So I installed it, and AUR updates then succeeded.

  4. Upgrading kernel from 6.7 to 6.8 changed system-tray network icon from a picture of a computer monitor to 3 parallel curves and disabled all networking completely, on multiple computers. Work-around: Reboot, select “Advanced Linux” on Grub menu, scroll down to kernel 6.7 and boot that, then erase kernel 6.8.

  5. After running this update on my work computer, LibreOffice stopped being able to save changes to files on my company’s Unix server. Workaround found: I added a “nobrl” (apparently “no bit range lock”, whatever that means) option in the cifs mount line in “/etc/fstab” and the problem went away. (I found this workaround tacked onto the end of a very-long-but-otherwise-unhelpful thread in the official LibreOffice forum, where some helpful soul tacked-on the only real solution, almost as an afterthought, after finding it on a German web site.)

  6. After this update, perldoc stopped using less as its pager and reverted to using more. Workaround: I added the following line to my (restored, after repairing Pamac’s devastation) “/etc/bash.bashrc” file: “export PERLDOC_PAGER=less”. Voila, problem solved. (But why did it exist in the first place? Very-weird and oddly-specific bug.)

  1. Read Known Issues? sudo pacman -Syu pacman-contrib

  2. That is how updates of configuration files on Arch-based systems works and always has.

  1. It is impossible to build any package, AUR or otherwise, without fakeroot. It is a dependency of pacman. So you removed it by whatever you were doing trying to resolve 1.
1 Like

Read whole pacman.conf.pacnew and you’ll find there is global SigLevel.

Apparently you haven’t ever read what prerequisites for using AUR are: Arch User Repository - ArchWiki

I guess it was before Manjaro made separate pacman-contrib package as is in Arch.


With this update, ~/.profile is no longer sourced upon or before invoking an interactive non-login bash shell. I noticed it when bringing up a manpage. I set $MANWIDTH to 72 columns from .profile and export ten or so other environmental variables from that file. Same non-sourcing of .profile occurred using xterm, xfce-terminal, or urxvt.

My work-around is to source ~/.profile from ~/.bashrc.

See: https://forum.manjaro.org/t/after-2024-02-21-stable-update-profile-file-is-no-longer-sourced/156914


and Plasma6 is still on the run.
this update broke both of my systems, great job…
i’m used to it that one system crashes at such an major update but never experienced that both hang up. very curious that i even couldn’t get to any console at startup, still black screen of dead. tried to edit the grub to start into runlevel 3 and even that wasn’t working at the first boot (identical on both different pc-systems !). what the heck is going on ??? eventually i could boot into runlevel 3, recompiled and used the actual clear-linux kernel, btw installed the most actual 550-nvidia driver, sucked several bottles of beer to calm down and got it running finally. actually i’m redoing the procedure at the second pc, with an intel/radeon system, hoping that i don’t run on empty …
what a pain and btw can anyone explain what i have to edit at the mkinitcpio because of plymouth ???

Hello, people! had black screen too. so if you decide to boot from usb drive

  • mount disk
  • edit /etc/default/grub (remove splash)
  • bind (mount --bind) /sys, /dev, /proc, /dev/pts
  • chroot to mount dir
  • and update-grub

huawei matebook, intel i9 12th gen. (iris xe)


well that is the most curious, i couldn’t start runlevel 3 by editing the grub and had to redo it twice until it booted to a console. never saw this and it’s against all wiki’s etc…