[Stable Update] 2024-02-21 - Kernels, KDE, VirtualBox, Calamares, ROCm, Firefox, Thunderbird

One strange problem since this update.

Firefox is started on my Plasma system through an autostart script. When another application (such as Thunderbird or Tickr) tries to open a web page I get a pop-up telling me that Firefox is already running and I need to shut it down before I can run it (previously the link would simply open). When I do shut it down and restart it, I get another pop-up telling me that it didn’t shut down cleanly. Though at least after that, other applications can pass links to it.

Kvantum themes aren’t being respected. So Qt apps open with a theme other than the one I chose. I’m going to let it be for now, don’t feel like fighting with this now.

Ksnip core dumps with the new -qt5 dependencies. I already dealt with this in Artix and here I did the same thing - downgraded and locked everything involved in this (ksnip, kcolorpicker, kimageannotator and gwenview, a casualty that also depends on the newer -qt5 ones) for the foreseeable future.

1 Like

Then you don’t have it configured correctly.

What new dependencies? It seems you haven’t updated since at least November.

Please create a new Support topic for each issue.

1 Like

Yet, there are several of us having issue with Qt apps since the last update. My DE is XFCE.
Kvantum was correctly configured before this update and i did not change anything.

It seems the issue is reported here https://bugs.launchpad.net/kvantum/+bug/2054321

My issue is a little bit different with Qt apps though because i only have theming issues with Qt 5 apps (not with Qt 6), they do not “catch” the theme defined with kvantum.

1 Like

Have you tried this

1 Like

bashrc-manjaro has recently been replaced by bash. New package does not apply configuration settings in ~/.profile, including: export QT_QPA_PLATFORMTHEME="qt5ct"

After update, system is not applying configuration settings in ~/.profile including: export QT_QPA_PLATFORMTHEME="qt5ct" for QT theme

If there is no response to this command


Copy the configuration in ~/.profile to ~/.bash_profile


Add this to ~/.bash_profile

[[ -f ~/.profile ]] && . ~/.profile

After 2024-02-21 stable update ~/.profile file is no longer sourced

1 Like

Thanks, that solved VLC not using the dark theme of my Cinnamon DE :+1:

1 Like

In my last message i said i do not have issues with Qt5 apps, but only with Qt6 (Polychromatic, Qbittorrent). In reality, i also have issue with Okular (which is Qt5), but no issues with VLC for instance.

Maybe some Qt apps also support GTK integration, i do not have the clue.
→ For those who are using zsh like me, i created a .zprofile file instead of .bash_profile.

Do you also have an issue Okular or Qbittorrent or Polychromatic (even though for the last two one i could use their custom internal theming) ? just to have an idea

Qbittorrent, Okular and vlc are fine (follow the theme) here on XFCE.

1 Like

My .profile is being read just fine. What does bash have to do with it? Nothing actually changed except for the two packages merging into one. Do you have any bash pacsaves left over?

I tried following this guide, but I missed up something and kind of deleted my user. After a reboot, I can not login anymore. I had to restore a Timeshift backup.
Should I “Merge” or “Overwrite”?

Some time ago I used DIFFPROG=meld pacdiff -s . It is the same thing but using meld?

Sorry about my “noob” question. In 2 years, I almost don’t verified pacnew files

Neither (merge doesn’t work as expected for some reason). Do this;

I have installed paccache with pacman -Syu pacman-contrib.

Never overwrite, always use Merge… when the files are identical after the merge, the pacnew file will automatical deleted… Meld is the recommended tool for merging files… the useability is nice,
but keep in mind, that this .pacnew are always config files and sometimes the default settings
can lead to problems, using your brain is required… manually intervention is needed specially if the changes not behind a # icon.

Its always a good idea to create a snapshot before messing around…

Don’t merge to many files at the same time… if you running into a problem, you probably don’t know where exactly was the mistake, max 2 files and restart and only 2 files when 1 file only has changes behind a # icon, because the chance are low that something will lead to problems after a restart.

Which file did you try to merge after you got problems?

I think you understand @Zesko wrong.

He just showed 2 option… skip this .pacnew changes or (optionally) merge only the first line.

/etc/environment and add the following line for permanent usage:

or only Temporary Meld link for pacdiff:
DIFFPROG=meld pacdiff -s

So you decided in the past to use meld temporary… its your choice, but i would use the first option when you happy with Meld.

And in future you only need to write in terminal:
pacdiff -s

Read my post in that thread. Merging with meld doesn’t work as expected for that particular .pacnew, you need to edit the line manually.

You only can’t use the arrow icon (feature) in Meld but Meld merging still should work when you manually copy+paste the first mentionend line.

At the end of the day, this called merging.

That’s obvious to you and me and any experienced user, but I suspect that it’s not to a lot of people here.

Don’t get me wrong, i think this special .pacnew file merging is a little bid confusing for some users.

But when you tell people that:“Merging with meld doesn’t work as expected”
its also confusing for the unexperienced users.

What do you think, what they would think after this statement?

I guess, they would think:

okay… Meld don’t work and i need another program to edit this file now.

I just point to the final problem, without a hidden message:
Don’t use this arrow icon feature for this particular pacnew file… and copy+overwrite just the first lane, thats it… problem solved.

Could some-one kindly explain what manjaro-bash is, or was?
I never heard of it until now.

EDIT: I guess you mean bashrc-manjaro mentioned in the wiki-post.
(I read it a week ago and didn’t remember the exact word.)

Is there a typo in the wiki-post? I get:

# ll /etc/.bash*
ls: cannot access '/etc/.bash*': No such file or directory

# ll /etc/bash*
-rw-r--r-- 1 root root 1153 231115_154254.564 /etc/bash.bashrc
-rw-r--r-- 1 root root   28 231124_012418.000 /etc/bash.bash_logout

A post was split to a new topic: Network regression for mt7922 wifi adapter after update