[Stable Update] 2024-01-13 - Kernels, Systemd, Qt5, Mesa, Dbus, Firefox, Thunderbird

You’re really missing on the simplicity and speed of the CLI and a sudo nano /path/to/the/directory/name_of the_file > write or paste the text with Ctrl+Shift+V > Ctrl+O to save > Ctrl+X to quit. You could also do a half-way GUI/half-way CLI by creating the file in your home directory with your favorite editor, then sudo cp -v /home/you/your_file /path/to/the/directory/it/should/go/, but if you want to do it the full “GUI and as root”, I recommend you to read those pages:

Kate seems able to handle it, but I can’t confirm this, as I’m using neither KDE nor Wayland…

1 Like

I’ve been through the rigamarole over a decade ago(not completely new to linux, though certainly a bit rusty), just tired of it. I’d like to have the option of going gui/mouse driven interaction when I feel like it. I’m not against doing larger operations via terminal, though. There are situations where it genuinely becomes more convenient that way.

Perhaps Kate can save files into the directory, but alas it can’t browse into it(same as dolphin) so won’t be opening any files from it either. No way to see what even might be inside there if any.

I’m pretty sure this is manjaro specific tho, like KDE/dolphin can if configured for it do these things, but whatever the manjaro polkit rules are just wont allow for it. I’m on Testing btw, may have something to do with it perhaps.

Have you tried this ?

Otherwise, I think Manjaro allows GUI login as root, so you could do your editing, and log out / log back in as your regular user when done.
It might not be as convenient as what you would like, but could be the next best (and simple) thing…

No but I’ve tried this without success:

I recon it’s probably essentially the same thing. TBH it’s probably time to distro hop and work with a clean install again anyways so I’m probably going to stop diggin’ on this systems issues soon. They aren’t major, but annoying enough.

kde /plasma walled garden issues … pkexec kate or sudo kate fail…

I tend to use mc (midnight commander) a console based gui app for this kind of thing

sudo mc

You’ll need to silence any f10 shortcut in order to exit cleanly , or use the mouse… has a built in editor function

activate under options/panel → lynx-like motion and you can use the arrow keys to change directories

1 Like

There is no need to use pkexec or sudo with kate, because kate is polkit-aware. It will ask you for a password when needed.


NO NO !!!
The official way ! kde recommends using the admin protocol, which works with dolphin if kio-admin is installed
dolphin admin:///etc/

And, with kio-admin, we have in dolphin a menu “open as admin” : dolphin - config - context menu - Administrative Actions :wink: (dolphin display this context menu only in directories owned by root)


If it absolutely has to be, then maybe like this:


Thanks for the tip, it seems I missed that one! As I said, I don’t use KDE on Manjaro, and rather use the CLI when I’m on Mageia and OpenSuse, but I will give it a try next time I boot one of those…
@megalomaniakaal that might indeed be the answer to your problem, as the one who wrote it said the reason for doing it was “I’ve gotten annoyed with the inability to manage system files so I’ve made a KIO worker that enables Dolphin to view and edit files as root.:wink:
Have a look here: KIO Admin | 💺 Blog

2 posts were split to a new topic: Update fails after some time

Just to confirm, this seems to be the best method indeed and actually works. (As I expected the locked directory was empty, but without the sanity check I couldn’t know for sure).

Beware that there was (quote) “a crash that occurred when using kio-admin to do privilege escalation” that is now fixed with KDE Frameworks 5.115.
Source here: KDE Frameworks 5.115 Improves Copy/Move of Large Number of Files - 9to5Linux

Hi guys, please don’t hate me for asking this question… It’s not a criticism.

I just noticed that it is taking an unusually long time for the new stable release to appear.

Are we waiting for something specific? For… Plasma 6 maybe? Or are there other show stoppers?


It’s not uncommon for releases to be more than a month apart. Although they’re usually more frequent, it’s not something to get worried about.

I assume it may be because there aren’t enough updated packages to make a release worthwhile, or perhaps because the maintainers are busy (like most open-source projects, Manjaro is probably not their main source of income). Or it could be that there’s a bad problem that’s come to light in testing that needs an up-stream bugfix.

1 Like

Take a look beforehand

You can always take a look at the preparations for the next stable update:




1 Like

I wish I’d gone with dbus-daemon-units too. Since the update I’ve been having issues with flatpaks causing core dumps. Sat down tonight to diagnose that and figured it was the new dbus. Switched back to dbus-daemon-units and all is well again.

Sorry, can’t reproduce. :man_shrugging:

the inxi-command does not work properly and stops with the following error

Can't use string ("HDMI-A-1") as an ARRAY ref while "strict refs" in use at /usr/bin/inxi line 18804.

don’t know but i think this is also related with the change to the new dbus-daemon.

I doubt it - this is a perl error regarding data types (inxi is written in perl).
Pinging @h2-1
Code/issue tracker seems to have moved just this weekend, you can also open a bug report:

edit: not necessary, as 3.3.33 release already fixes this. It’s currently available in unstable:

1 Like