[Stable Update] 2023-12-15 - Kernels, Blender, Thunderbird, Xorg-Server, Xwayland, Warzone2100

Hello community,

it took us some months to prepare and finally release Manjaro 23.1.0 Vulcan. I’ll announce the new release in a separate release announcement, so check that for more details. With this update we also fixed some security issues in the xorg-stack and added small fixes and updates to usual packages we provide.

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Most Kernels got updated
    • a wifi regression got fixed
    • we have now more or less a full feature complete support of the ASUS ROG ALLY via linux65, linux66 and linux67
    • linux-firmware got updated to December release
  • packaging of blender got fixed to add package assets
  • Thunderbird is now at 115.5.2
  • Xorg-Server and XWayland got some security updates
  • the game warzone2100 is now at 4.4.2
  • Usual KDE-git, Haskell and Python updates

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.302
  • linux54 5.4.264
  • linux510 5.10.204
  • linux515 5.15.143
  • linux61 6.1.68
  • linux65 6.5.13 [EOL]
  • linux66 6.6.7
  • linux67 6.7-rc5
  • linux61-rt 6.1.66_rt19
  • linux65-rt 6.5.2_rt8
  • linux66-rt 6.6.0_rt15

Package Changes (Wed Dec 13 22:28:14 CET 2023)

  • stable core x86_64: 15 new and 15 removed package(s)
  • stable extra x86_64: 238 new and 238 removed package(s)
  • stable kde-unstable x86_64: 129 new and 126 removed package(s)
  • stable multilib x86_64: 3 new and 3 removed package(s)
:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2023-12-10           2023-12-15
                            linux419           4.19.301-1           4.19.302-1
                    linux419-headers           4.19.301-1           4.19.302-1
                            linux510           5.10.203-1           5.10.204-1
                    linux510-headers           5.10.203-1           5.10.204-1
                            linux515           5.15.142-1           5.15.143-1
                    linux515-headers           5.15.142-1           5.15.143-1
                             linux54            5.4.263-1            5.4.264-1
                     linux54-headers            5.4.263-1            5.4.264-1
                             linux61             6.1.67-2             6.1.68-1
                     linux61-headers             6.1.67-2             6.1.68-1
                             linux66              6.6.6-2              6.6.7-1
                     linux66-headers              6.6.6-2              6.6.7-1
                             linux67           6.7.0rc5-3           6.7.0rc5-4
                     linux67-headers           6.7.0rc5-3           6.7.0rc5-4

:: Different sync package(s) in repository core x86_64

                             PACKAGE           2023-12-10           2023-12-15
             thin-provisioning-tools              1.0.9-1              1.0.9-2

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2023-12-10           2023-12-15
                            chromium     120.0.6099.109-1                    -
                             discord             0.0.38-1                    -
                  linux419-acpi_call            1.2.2-101            1.2.2-102
                   linux419-bbswitch              0.8-314              0.8-315
               linux419-nvidia-390xx           390.157-46           390.157-47
               linux419-nvidia-470xx         470.223.02-6         470.223.02-7
                     linux419-nvidia          545.29.06-3          545.29.06-4
                   linux419-nvidiabl             0.88-313             0.88-314
                      linux419-r8168           8.052.01-7           8.052.01-8
                  linux419-rtl8723bu          20220818-56          20220818-57
                   linux419-tp_smapi               0.44-8               0.44-9
                linux419-vhba-module          20211218-97          20211218-98
    linux419-virtualbox-host-modules             7.0.12-6             7.0.12-7
                        linux419-zfs              2.2.2-1              2.2.2-2
                  linux510-acpi_call            1.2.2-137            1.2.2-138
                   linux510-bbswitch              0.8-238              0.8-239
               linux510-nvidia-390xx           390.157-61           390.157-62
               linux510-nvidia-470xx         470.223.02-6         470.223.02-7
                     linux510-nvidia          545.29.06-3          545.29.06-4
                      linux510-r8168           8.052.01-7           8.052.01-8
                  linux510-rtl8723bu          20220818-76          20220818-77
                   linux510-tp_smapi              0.44-10              0.44-11
                linux510-vhba-module         20211218-133         20211218-134
    linux510-virtualbox-host-modules             7.0.12-6             7.0.12-7
                        linux510-zfs              2.2.2-2              2.2.2-3
                  linux515-acpi_call            1.2.2-152            1.2.2-153
                   linux515-bbswitch              0.8-167              0.8-168
               linux515-nvidia-390xx           390.157-73           390.157-74
               linux515-nvidia-470xx         470.223.02-7         470.223.02-8
                     linux515-nvidia          545.29.06-4          545.29.06-5
                      linux515-r8168          8.052.01-10          8.052.01-11
                  linux515-rtl8723bu          20220818-89          20220818-90
                   linux515-tp_smapi              0.44-12              0.44-13
                linux515-vhba-module         20211218-149         20211218-150
    linux515-virtualbox-host-modules             7.0.12-8             7.0.12-9
                        linux515-zfs              2.2.2-2              2.2.2-3
                   linux54-acpi_call            1.2.2-116            1.2.2-117
                    linux54-bbswitch              0.8-290              0.8-291
                linux54-nvidia-390xx           390.157-48           390.157-49
                linux54-nvidia-470xx         470.223.02-6         470.223.02-7
                      linux54-nvidia          545.29.06-3          545.29.06-4
                    linux54-nvidiabl             0.88-290             0.88-291
                       linux54-r8168           8.052.01-7           8.052.01-8
                   linux54-rtl8723bu          20220818-64          20220818-65
                    linux54-tp_smapi               0.44-8               0.44-9
                 linux54-vhba-module         20211218-112         20211218-113
     linux54-virtualbox-host-modules             7.0.12-6             7.0.12-7
                         linux54-zfs              2.2.2-2              2.2.2-3
                   linux61-acpi_call             1.2.2-79             1.2.2-80
                    linux61-bbswitch               0.8-79               0.8-80
                linux61-nvidia-390xx           390.157-79           390.157-80
                linux61-nvidia-470xx        470.223.02-11        470.223.02-12
                      linux61-nvidia          545.29.06-7          545.29.06-8
                       linux61-r8168          8.052.01-15          8.052.01-16
                   linux61-rtl8723bu          20220818-79          20220818-80
                    linux61-tp_smapi              0.44-18              0.44-19
                 linux61-vhba-module          20211218-79          20211218-80
     linux61-virtualbox-host-modules            7.0.12-12            7.0.12-13
                         linux61-zfs              2.2.2-5              2.2.2-6
                   linux66-acpi_call             1.2.2-26             1.2.2-27
                    linux66-bbswitch               0.8-26               0.8-27
                linux66-nvidia-390xx           390.157-25           390.157-26
                linux66-nvidia-470xx        470.223.02-26        470.223.02-27
                      linux66-nvidia         545.29.06-21         545.29.06-22
                       linux66-r8168          8.052.01-26          8.052.01-27
                   linux66-rtl8723bu          20220818-26          20220818-27
                    linux66-tp_smapi              0.44-26              0.44-27
                 linux66-vhba-module          20211218-26          20211218-27
     linux66-virtualbox-host-modules            7.0.12-26            7.0.12-27
                         linux66-zfs             2.2.2-13             2.2.2-14
                   linux67-acpi_call           1.2.2-0.14           1.2.2-0.15
                    linux67-bbswitch             0.8-0.14             0.8-0.15
                linux67-nvidia-390xx         390.157-0.14         390.157-0.15
                linux67-nvidia-470xx      470.223.02-0.13      470.223.02-0.14
                      linux67-nvidia       545.29.06-0.13       545.29.06-0.14
                       linux67-r8168        8.052.01-0.14        8.052.01-0.15
                   linux67-rtl8723bu         20231204-0.8         20231204-0.9
                    linux67-tp_smapi            0.44-0.14            0.44-0.15
                 linux67-vhba-module        20211218-0.14        20211218-0.15
     linux67-virtualbox-host-modules          7.0.12-0.14          7.0.12-0.15
                 tuxedo-drivers-dkms             3.2.14-1              4.0.0-1
            tuxedo-keyboard-ite-dkms              0.4.4-3                    -
                         xorg-server             21.1.9-1            21.1.10-1
                  xorg-server-common             21.1.9-1            21.1.10-1
                   xorg-server-devel             21.1.9-1            21.1.10-1
                  xorg-server-xephyr             21.1.9-1            21.1.10-1
                   xorg-server-xnest             21.1.9-1            21.1.10-1
                    xorg-server-xvfb             21.1.9-1            21.1.10-1

:: Different sync package(s) in repository extra x86_64

                             PACKAGE           2023-12-10           2023-12-15
                             blender           17:4.0.2-3           17:4.0.2-4
                         cargo-about              0.5.7-1              0.6.0-1
                      cargo-binstall              1.4.6-1              1.4.7-1
                      cargo-llvm-cov             0.5.37-1             0.5.38-1
                       cargo-shuttle             0.35.0-1             0.35.1-1
                            chromium      120.0.6099.71-1     120.0.6099.109-1
                                ddgr                2.1-4                2.1-5
                             discord             0.0.37-1             0.0.38-1
                                dolt             1.29.3-1             1.29.4-1
                               eclib           20231211-1           20231212-1
                     element-desktop            1.11.50-1            1.11.51-1
                         element-web            1.11.50-1            1.11.51-1
                                exim             4.96.2-1               4.97-1
                                 eza             0.16.3-1             0.17.0-1
                             fastjet              3.4.1-1              3.4.2-1
                   firefox-tridactyl             1.23.0-1             1.24.0-1
                      geoip-database           20230901-1           20231213-1
                geoip-database-extra           20230901-1           20231213-1
                               gitea             1.21.1-1             1.21.2-1
                          github-cli             2.40.0-1             2.40.1-1
                               go-yq             4.40.4-1             4.40.5-1
                               godot                4.2-1              4.2.1-1
                            goverlay              0.9.1-3                1.0-1
                              gpxsee              13.10-1              13.12-1
                                 gum             0.12.0-1             0.13.0-1
                           handbrake              1.7.1-2              1.7.1-3
                       handbrake-cli              1.7.1-2              1.7.1-3
     intellij-idea-community-edition         4:2023.2.4-1           4:2023.3-1
                             jenkins              2.435-1              2.436-1
               jupyter-collaboration              1.2.0-1              2.0.0-1
                             kak-lsp             15.0.0-1             15.0.1-1
                             klayout            0.28.13-1            0.28.14-1
                               kubie             0.22.0-1             0.23.0-1
                        languagetool                6.3-1              6.3.a-1
                         libva-utils             2.20.0-1             2.20.1-1
                       lxqt-archiver              0.9.0-1              0.9.0-2
                          mattermost              9.2.3-1              9.3.0-1
                               mmctl              9.2.3-1              9.3.0-1
                             netdata             1.44.0-1             1.44.1-1
                              netpbm           10.73.43-2           10.86.39-1
                             nushell             0.87.1-1             0.88.0-1
                         ocaml-stdio             0.15.0-5             0.16.0-1
                              okteta          1:0.26.13-2          1:0.26.14-1
                              opensc             0.23.0-1             0.24.0-1
                               opera      105.0.4970.34-1      105.0.4970.48-1
                            polymake               4.11-2               4.11-3
                             pyright            1.1.339-1            1.1.340-1
                    python-fakeredis             2.20.0-1             2.20.1-1
                    python-geopandas             0.14.0-1             0.14.1-1
     python-googleapis-common-protos             1.61.0-1             1.62.0-1
                        python-patsy              0.5.3-2              0.5.4-1
               python-prompt_toolkit             3.0.41-1             3.0.42-1
                  python-pylint-venv              3.0.2-1              3.0.3-1
                    python-pyscipopt              4.3.0-2              4.3.0-3
                   python-sentry_sdk             1.38.0-1             1.39.0-1
                                 qbs              2.1.2-1              2.2.1-1
                           qtcreator             12.0.0-2             12.0.1-1
                     qtcreator-devel             12.0.0-2             12.0.1-1
                         qutebrowser              3.0.2-1              3.1.0-1
                               rnote              0.9.3-1              0.9.4-1
                          rustypaste             0.14.2-1             0.14.3-1
                                scip              8.0.4-1              8.1.0-2
                             sdl_gfx             2.0.26-5             2.0.27-1
                                 sip              6.8.0-1              6.8.1-1
                         thunderbird            115.5.1-1            115.5.2-1
                 thunderbird-i18n-af            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ar            115.5.1-1            115.5.2-1
                thunderbird-i18n-ast            115.5.1-1            115.5.2-1
                 thunderbird-i18n-be            115.5.1-1            115.5.2-1
                 thunderbird-i18n-bg            115.5.1-1            115.5.2-1
                 thunderbird-i18n-br            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ca            115.5.1-1            115.5.2-1
                thunderbird-i18n-cak            115.5.1-1            115.5.2-1
                 thunderbird-i18n-cs            115.5.1-1            115.5.2-1
                 thunderbird-i18n-cy            115.5.1-1            115.5.2-1
                 thunderbird-i18n-da            115.5.1-1            115.5.2-1
                 thunderbird-i18n-de            115.5.1-1            115.5.2-1
                thunderbird-i18n-dsb            115.5.1-1            115.5.2-1
                 thunderbird-i18n-el            115.5.1-1            115.5.2-1
              thunderbird-i18n-en-gb            115.5.1-1            115.5.2-1
              thunderbird-i18n-en-us            115.5.1-1            115.5.2-1
              thunderbird-i18n-es-ar            115.5.1-1            115.5.2-1
              thunderbird-i18n-es-es            115.5.1-1            115.5.2-1
                 thunderbird-i18n-et            115.5.1-1            115.5.2-1
                 thunderbird-i18n-eu            115.5.1-1            115.5.2-1
                 thunderbird-i18n-fi            115.5.1-1            115.5.2-1
                 thunderbird-i18n-fr            115.5.1-1            115.5.2-1
              thunderbird-i18n-fy-nl            115.5.1-1            115.5.2-1
              thunderbird-i18n-ga-ie            115.5.1-1            115.5.2-1
                 thunderbird-i18n-gd            115.5.1-1            115.5.2-1
                 thunderbird-i18n-gl            115.5.1-1            115.5.2-1
                 thunderbird-i18n-he            115.5.1-1            115.5.2-1
                 thunderbird-i18n-hr            115.5.1-1            115.5.2-1
                thunderbird-i18n-hsb            115.5.1-1            115.5.2-1
                 thunderbird-i18n-hu            115.5.1-1            115.5.2-1
              thunderbird-i18n-hy-am            115.5.1-1            115.5.2-1
                 thunderbird-i18n-id            115.5.1-1            115.5.2-1
                 thunderbird-i18n-is            115.5.1-1            115.5.2-1
                 thunderbird-i18n-it            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ja            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ka            115.5.1-1            115.5.2-1
                thunderbird-i18n-kab            115.5.1-1            115.5.2-1
                 thunderbird-i18n-kk            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ko            115.5.1-1            115.5.2-1
                 thunderbird-i18n-lt            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ms            115.5.1-1            115.5.2-1
              thunderbird-i18n-nb-no            115.5.1-1            115.5.2-1
                 thunderbird-i18n-nl            115.5.1-1            115.5.2-1
              thunderbird-i18n-nn-no            115.5.1-1            115.5.2-1
              thunderbird-i18n-pa-in            115.5.1-1            115.5.2-1
                 thunderbird-i18n-pl            115.5.1-1            115.5.2-1
              thunderbird-i18n-pt-br            115.5.1-1            115.5.2-1
              thunderbird-i18n-pt-pt            115.5.1-1            115.5.2-1
                 thunderbird-i18n-rm            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ro            115.5.1-1            115.5.2-1
                 thunderbird-i18n-ru            115.5.1-1            115.5.2-1
                 thunderbird-i18n-sk            115.5.1-1            115.5.2-1
                 thunderbird-i18n-sl            115.5.1-1            115.5.2-1
                 thunderbird-i18n-sq            115.5.1-1            115.5.2-1
                 thunderbird-i18n-sr            115.5.1-1            115.5.2-1
              thunderbird-i18n-sv-se            115.5.1-1            115.5.2-1
                 thunderbird-i18n-th            115.5.1-1            115.5.2-1
                 thunderbird-i18n-tr            115.5.1-1            115.5.2-1
                 thunderbird-i18n-uk            115.5.1-1            115.5.2-1
                 thunderbird-i18n-uz            115.5.1-1            115.5.2-1
                 thunderbird-i18n-vi            115.5.1-1            115.5.2-1
              thunderbird-i18n-zh-cn            115.5.1-1            115.5.2-1
              thunderbird-i18n-zh-tw            115.5.1-1            115.5.2-1
                               typos            1.16.24-3            1.16.25-1
         v2ray-domain-list-community     20231208065009-1     20231212122459-1
                            vbam-sdl              2.1.7-2              2.1.8-1
                             vbam-wx              2.1.7-2              2.1.8-1
                         warzone2100              4.3.5-2              4.4.2-2
                           watchexec             1.24.0-1             1.24.0-3
                              waybar             0.9.24-1             0.9.24-2
                           wvstreams             4.6.1-20             4.6.1-21
                    wxwidgets-common              3.2.4-2              3.2.4-3
                      wxwidgets-gtk3              3.2.4-2              3.2.4-3
                       wxwidgets-qt5              3.2.4-2              3.2.4-3
                       xorg-xwayland             23.2.2-1             23.2.3-1
                               xsimd             12.1.0-1             12.1.1-1
                                   z               1.11-2               1.12-1
                           zxing-cpp              2.2.0-2              2.2.1-1
                      otf-montserrat                    -              7.222-2
                 perl-file-fcntllock                    -               0.22-1
                      ttf-montserrat                    -              7.222-2

:: Different overlay package(s) in repository kde-unstable x86_64

                             PACKAGE           2023-12-10           2023-12-15
                        kpeoplevcard  0.1.r128.g2d8ed99-1  0.1.r129.g840dbc2-1
                         libquotient    r3256.g8c603adf-1    r3259.g885cbc93-1
                       plasma-camera  1.0.r218.g743279d-1  1.0.r219.gb6bcd46-1
                             dolphin                    -23.08.4.r7729.g78d6b2b35-1
                     dolphin-plugins                    -23.08.4.r864.g5e3cdc8-1
                           konqueror                    -23.08.4.r15715.gc7d47392d-1

:: Different sync package(s) in repository multilib x86_64

                             PACKAGE           2023-12-10           2023-12-15
                         lib32-lcms2               2.15-1               2.16-1
                        lib32-libdrm            2.4.117-1            2.4.118-1
                      lib32-pcsclite              2.0.0-1              2.0.1-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-12-15


Broken Wifi with 6.1.66 and 6.6.5 kernels

Some users report broken Wifi driver support with the latest 6.x kernel series, mostly based on Realtek drivers, either from the AUR or provided by the kernels itself. It is also reported that linux515 and linux67 kernel series don’t have those issues. So if you have a potential Wifi driver problem, consider to install those kernels before updating your system. Older kernels can be found here:

Possible issues reported upstream

The Author of the original patch Johannes Berg had reviewed Léo Lam’s patch by now. So everybody who had tested 6.6.5-3 or 6.1.66-2 should reply to the upstream mailing list with a Tested-by tag as described here: [Stable Update] 2023-12-10 - Kernels, Plasma, Phosh, Systemd, Cinnamon, Gnome, libpamac - #95 by philm


  • IMPORTANT → Linux 6.5 is EOL

    Linux 6.5 is EOL and will be removed from the repo.

    If you use Linux 6.5 and Nvidia or as virtual machine, it is of great importance, that you install Linux 6.6 to avoid driver problems.

    sudo mhwd-kernel -i linux66


Blender 4.0 may fail on AMD GPUs

The current native ALPM package of Blender provided by our mirrors may fail with AMD GPUs. As an alternative you may want to use Blender-Bin from the AUR, flatpak version, snap version or load it directly from Blender. More infos here: 17:4.0.1-2 Segfault on start (#2) · Issues · Arch Linux / Packaging / Packages / blender · GitLab


mkinitcpio needs base hook

With the update of mkinitcpio 37 make sure you have the base hook in your /etc/mkinitcpio.conf file, unless you use systemd hook instead. See also wiki for all hook documentation.


Changes in JDK / JRE 21 packages may require manual intervention

2023-11-02 - Frederik Schwan

We are introducing a change in JDK/JRE packages of our distro. This is triggered from the way a JRE is build in modern versions of Java (>9). We are introducing this change in Java 21.

To sum it up instead of having JDK and JRE packages coexist in the same system we will be making them conflict. The JDK variant package includes the runtime environment to execute Java applications so if one needs compilation and runtime of Java they need only the JDK package in the future. If, on the other hand, they need just runtime of Java then JRE (or jre-headless) will work.

This will (potentially) require a manual user action during upgrade:

  • If you have both JDK and JRE installed you can manually install the JDK with pacman -Sy jdk-openjdk && pacman -Su and this removes the JRE related packages.
  • If you have both JRE and JRE-headless you will need to choose one of them and install it manually since they would conflict each other now.
  • If you only have one of the JDK/JRE/JRE-headless pacman should resolve dependencies normally and no action is needed.

At the moment this is only valid for the upcoming JDK 21 release.

Arch Linux - News: Incoming changes in JDK / JRE 21 packages may require manual intervention


Powerdevil fails in KDE Plasma

In KDE Plasma, Powerdevil fails and energy settings (Power save v Normal v Performance) are unavailable. See:
Powerdevil fails, Energy settings unavailable

Restarting gnome-shell using Alt+F2 and entering R, causes a crash

FS#79884 : [gnome-shell] Restarting gnome-shell using Alt+F2 and entering R, causes a crash

GNOME Extensions that target older GNOME versions will not work in GNOME 45

It is recommended to remove all third-party extensions before updating, then install the compatible versions after updating and rebooting. All Most extensions in the Manjaro repos are already updated.

kpeoplevcard update requires manual intervention

A “newer” version of kpeoplevcard accidently existed, so to install the current version, either update with sudo pacman -Syu kpeoplevcard or sudo pacman -Syuu.


glibc-locales update requires manual intervention

If you had the old glibc-locales package from the extra repo installed, the update to the new core package will need manual intervention:

 sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\*


Changes to default password hashing algorithm and umask settings

2023-09-22 - David Runge

With shadow >= 4.14.0, Arch Linux’s default password hashing algorithm changed from SHA512 to yescrypt [1].

Furthermore, the umask [2] settings are now configured in /etc/login.defs instead of /etc/profile.

This should not require any manual intervention.

Reasons for Yescrypt

The password-based key derivation function (KDF) and password hashing scheme yescrypt has been chosen due to its adoption (readily available in libxcrypt, which is used by pam [3]) and its stronger resilience towards password cracking attempts over SHA512.

Although the winner of the Password Hashing Competition [4] has been argon2, this even more resilient algorithm is not yet available in libxcrypt [5][6].

Configuring yescrypt

The YESCRYPT_COST_FACTOR setting in /etc/login.defs is currently without effect, until pam implements reading its value [7]. If a YESCRYPT_COST_FACTOR higher (or lower) than the default (5) is needed, it can be set using the rounds option of the pam_unix [8] module (i.e. in /etc/pam.d/system-auth).

General list of changes

  • yescrypt is used as default password hashing algorithm, instead of SHA512
  • pam honors the chosen ENCRYPT_METHOD in /etc/login.defs and does not override the chosen method anymore
  • changes in the filesystem (>= 2023.09.18) and pambase (>= 20230918) packages ensure, that umask is set centrally in /etc/login.defs instead of /etc/profile

[1] yescrypt - scalable KDF and password hashing scheme

[2] umask(1p) — Arch manual pages

[3] PAM - ArchWiki

[4] https://www.password-hashing.net/

[5] [RFC] Add argon2 backend. by ferivoz · Pull Request #113 · besser82/libxcrypt · GitHub

[6] Add support for Argon2 by maandree · Pull Request #150 · besser82/libxcrypt · GitHub

[7] pam_unix: Support reading YESCRYPT_COST_FACTOR from /etc/login.defs · Issue #607 · linux-pam/linux-pam · GitHub

[8] pam_unix(8) — Arch manual pages

Arch Linux - News: Changes to default password hashing algorithm and umask settings


filesystem and bashrc-manjaro pacnews

With the filesystem 2023.09.03-1 and bashrc-manjaro 5.1.016-3 updates there may be pacnews for the following files if you have local modifications:

  • /etc/shells
  • /etc/bash.bashrc

This would be a good time to test @Ste74’s new manjaro-pacnew-checker program. See Check and manage pacnew files for more info.

updates for linux515-r8168 and linux61-6168 drivers fail to load r8168 driver

See this post for how to revert to using r8168 driver or install r8168-dkms driver from AUR
Problem with 6.5 kernel and-r8168 module

R8168 driver not loaded on kernel 6.5 after testing update 2023-09-22

All 3 versions of network-r8168 drivers are working again following [Testing Update] 2023-09-27

  • linux65-r8168 8.051.02-7
  • linux61-r8168 8.051.02-5
  • linux515-r8168 8.051.02-4


LLVM 16 update may break 3rd party MESA drivers

Mesa drivers are affected when there is no matching LLVM version they are complied on. If you use a 3rd party repo like mesanonfree you may want to install llvm15-libs until those get recompiled. See for releases: Releases · mesa-freeworld/mesa-nonfree · GitHub


Avoid black screen on Ryzen 7 / ThreadRipper / RX7xxx - perhaps others as well

You may be able to avoid black screen if you - prior to rebooting after the update - sync the latest stable kernel - currently - linux64 or linux65 - any of those solves the issue.

sudo mhwd-kernel -i linux65
budgie-desktop >= 10.7.2-6 update requires manual intervention

When upgrading from budgie-desktop 10.7.2-5 to 10.7.2-6, the package mutter43 must be replaced with magpie-wm, which currently depends on mutter. As mutter43 conflicts with mutter, manual intervention is required to complete the upgrade.

First remove mutter43, then immediately perform the upgrade. Do not relog or reboot between these steps.

pacman -Rdd mutter43
pacman -Syu
Manjaro-hello does not start after update

Known issue: "Manjaro Hello" does not start after Update

rm -f ~/.config/autostart/manjaro-hello.desktop
Multiple sink outputs shown in KDE audio controls

Known issue: Bluetooth headset showing multiple entries in KDE after update


A bug in KDE Frameworks can delete targets of symlinks.

More info here.

Steam cashes on startup with lib32-libgudev installed

The latest lib32-libgudev update does not cooperate with the version of the same package provided by steam, and steam seems to attempt making calls to both leading to the crash.

Details: bug report, arch task, arch forum thread.

  • Workaround #1 (causes steam to avoid making any calls to lib32-libgudev by using a different library altogether)

    • sudo pacman -S lib32-libnm
  • Workaround #2 (forces steam and any other application to always use the new lib32-libgudev)

    • sudo pacman -S lib32-libudev0-shim
  • Workaround #3 (use steam-native-runtime, which doesn’t have the issue)

    • sudo pacman -S steam-native-runtime


libpamac 11.5.5-1 breaks update function

We are currently working on fixing a reported security vulnerability which gave you root access via pamac-daemon. During that process we broke the update functionality. Hence use sudo pacman -Syu to update to the latest libpamac release (11.5.7-2)

The community repository has been merged into extra and is now empty

The Arch git migration is now complete .

The [community] repository has been merged into [extra] and is now empty.
It may take a bit of time for mirrors to catch up (more details here).

Update your system and handle the pacman

sudo pacman -Syu "pacman>=6.0.2-11"

In order to remove the defunct [community] repo changes must be made to /etc/pacman.conf.
Changes will be provided in a file with the extension .pacnew.
Pacman provides the utility pacdiff to manage these files and will use vim -d for comparison if the environment variable DIFFPROG is not set.

pacdiff -s

If you would like to use a different comparison tool you may prepend the env var:

DIFFPROG=meld pacdiff -s

Then sync with the repositories again:

sudo pacman -Syu

And you can also remove the now unused repository.

sudo pacman -Sc

NOTE: Be aware that this last command will also remove all packages in the pacman cache that are not currently installed: in other words, backup copies of packages that you have uninstalled at some point will no longer be stored on your hard drive.

In most cases, this probably will not cause headaches. To prevent even minor aches and pains, see the Arch Wiki for information on cleaning the cache

Steam fails to launch

A while ago the Steam Runtime developer maintaining the library detection/promotion “greatly encouraged” that the Steam package would (opt)depends on lib32-libnm and friends. The bugs have been opened since alas

In the absence of an updated steam package with updated dependencies,
A workaround is to install lib32-libnm

sudo pacman -Syu lib32-libnm

Steam will not launch - #12 by cscs
FS#79006 : [lib32-libgudev] Recent Update broke steam
Steam crashes at launch with libgudev 238 · Issue #9805 · ValveSoftware/steam-for-linux · GitHub

OpenBLAS >= 0.3.23-2 update requires manual intervention

2023-06-14 - Felix Yan

The openblas package prior to version 0.3.23-2 doesn’t ship optimized LAPACK routine and CBLAS/LAPACKE interfaces for compatibility. This decision has been reverted now, and the ability to choose a different default system BLAS/LAPACK implementation while keeping openblas installed is now provided to allow future co-installation of BLIS, ATLAS, etc.

The default BLAS implementation will be used for most packages like NumPy or R. Please install blas-openblas and blas64-openblas to make OpenBLAS the default BLAS implementation, just like the old behavior.

Unfortunately you will get errors on updating if you currently have OpenBLAS installed as the default BLAS implementation:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by cblas
:: installing openblas (0.3.23-2) breaks dependency 'blas' required by lapack

Please append your preferred default BLAS implementation to the regular -Syu command line to get around it. For example:

sudo pacman -Syu blas-openblas


sudo pacman -Syu blas

Arch Linux - News: OpenBLAS >= 0.3.23-2 update requires manual intervention

TeX Live package reorganization

2023-06-18 - Antonio Rojas

Starting from version 2023.66594-9, TeX Live packages have been reorganized to mirror upstream collections. Even though the new texlive-basic replaces the old texlive-core, many of the texlive-core contents (including language specific files) are now split between different packages. To find out which Arch package contains a specific CTAN package, you can use the tlmgr utility, eg.

$ tlmgr info euler | grep collection
collection:  collection-latexrecommended

which means the euler CTAN package is contained in texlive-latexrecommended. You may also use pacman -F to query for specific files.

A new metapackage texlive-meta is available to install all subpackages (except for language specific ones), and the new texlive-doc package provides the full documentation for offline use.

Arch Linux - News: TeX Live package reorganization

Pamac GUI theme does not match system theme

pamac-gtk 11.0.1 uses Gtk 4 that is not supported on Xfce or Cinnamon
user can replace pamac-gtk with pamac-gtk3

sudo pacman -S pamac-gtk3
Black screen after login with SDDM 0.20

Check ~/.profile for any commands that don’t execute properly (but return non-zero exit code instead). May include ~/.bash_profile and .zprofile too. Downgrading to SDDM 0.19 also restores desktop after login.

The issue has been reported upstream.


DKMS is currently broken as our kernels got compiled against an older gcc

Since the last stable update provided an older toolchain our kernels and binaries got compiled against GCC 12.2.0-1. A similar issue was already posted at Arch years ago: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc / [testing] Repo Forum / Arch Linux Forums. Therefore users of DKMS have to wait for kernel updates compiled against the new toolchain or downgrade to the older one.

Update (2023-06-05): We pushed a rebuild of all regular kernels against the new toolchain to all branches. Real-Time Kernels we still have to check.

Many applications (firefox, thunderbird, telegram, etc) slow to start on desktops other than Gnome

There is a bug with xdg-desktop-portal-gnome (more details here).

Workaround for gtk-based desktops (including Xfce)
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-gtk
Workaround for KDE
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-kde
Workaround for Lxqt
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-lxqt
Workaround for desktops using hyprland
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-hyprland
Workaround for desktops using wlroots
sudo pacman -Rdd xdg-desktop-portal-gnome
sudo pacman -S xdg-desktop-portal-wlr

If you have a lot of pip/AUR packages to upgrade to Python 3.11, read this.

If you installed python311 from the AUR, you need to uninstall it before running this update.

Previous stable update threads:


In case someone is having problems using tuxedo-drivers-dkms 4.0.0 on Kernel < 6.2.x, consider using 6.6.x Kernel instead.

This is already fixed with the next version of tuxedo-drivers, but I thought it might be worth mentioning.


tuxedo-drivers 4.0.1 is published:

1 Like


…which has been available in all branches as of…

❯ pacman -Si tuxedo-drivers-dkms | grep 'Version\|Build Date'
Version         : 4.0.1-1
Build Date      : Fri 15 Dec 2023 09:55:34 AM MST



Pamac has still a heavy zoom in the update section:

well actually i just update it, should i switch to kernel 6.6 LTS?


YES - and: 6.5 is EOL now…

1 Like

I pushed some more updates:

:: Different overlay package(s) in repository core x86_64

                             PACKAGE           2023-12-17           2023-12-18
                          linux61-rt        6.1.66_rt19-2        6.1.67_rt20-1
                  linux61-rt-headers        6.1.66_rt19-2        6.1.67_rt20-1
                             linux65             6.5.13-4             6.5.13-6
                     linux65-headers             6.5.13-4             6.5.13-6
                             linux66              6.6.7-1              6.6.7-4
                     linux66-headers              6.6.7-1              6.6.7-4
                             linux67           6.7.0rc5-4           6.7.0rc6-1
                     linux67-headers           6.7.0rc5-4           6.7.0rc6-1

:: Different overlay package(s) in repository extra x86_64

                             PACKAGE           2023-12-17           2023-12-18
                linux61-rt-acpi_call             1.2.2-15             1.2.2-16
                 linux61-rt-bbswitch               0.8-15               0.8-16
             linux61-rt-nvidia-390xx           390.157-15           390.157-16
             linux61-rt-nvidia-470xx         470.223.02-6         470.223.02-7
                   linux61-rt-nvidia          545.29.06-5          545.29.06-6
                    linux61-rt-r8168           8.052.01-6           8.052.01-7
                linux61-rt-rtl8723bu          20220818-15          20220818-16
                 linux61-rt-tp_smapi               0.44-9              0.44-10
              linux61-rt-vhba-module          20211218-15          20211218-16
  linux61-rt-virtualbox-host-modules             7.0.12-6             7.0.12-7
                   linux65-acpi_call             1.2.2-33             1.2.2-35
                    linux65-bbswitch               0.8-33               0.8-35
                linux65-nvidia-390xx           390.157-26           390.157-28
                linux65-nvidia-470xx        470.223.02-14        470.223.02-16
                      linux65-nvidia         545.29.06-10         545.29.06-12
                       linux65-r8168          8.052.01-20          8.052.01-22
                linux65-rt-acpi_call              1.2.2-2              1.2.2-3
                 linux65-rt-bbswitch                0.8-2                0.8-3
             linux65-rt-nvidia-390xx            390.157-2            390.157-3
             linux65-rt-nvidia-470xx         470.223.02-2         470.223.02-3
                   linux65-rt-nvidia          545.29.06-1          545.29.06-2
                    linux65-rt-r8168           8.052.01-1           8.052.01-2
                linux65-rt-rtl8723bu           20220818-2           20220818-3
                 linux65-rt-tp_smapi               0.44-2               0.44-3
              linux65-rt-vhba-module           20211218-2           20211218-3
  linux65-rt-virtualbox-host-modules             7.0.12-1             7.0.12-2
                   linux65-rtl8723bu          20220818-33          20220818-35
                    linux65-tp_smapi              0.44-24              0.44-26
                 linux65-vhba-module          20211218-33          20211218-35
     linux65-virtualbox-host-modules            7.0.12-17            7.0.12-19
                         linux65-zfs              2.2.2-4              2.2.2-6
                   linux66-acpi_call             1.2.2-27             1.2.2-29
                    linux66-bbswitch               0.8-27               0.8-29
                linux66-nvidia-390xx           390.157-26           390.157-28
                linux66-nvidia-470xx        470.223.02-27        470.223.02-29
                      linux66-nvidia         545.29.06-22         545.29.06-24
                       linux66-r8168          8.052.01-27          8.052.01-29
                   linux66-rtl8723bu          20220818-27          20220818-29
                    linux66-tp_smapi              0.44-27              0.44-29
                 linux66-vhba-module          20211218-27          20211218-29
     linux66-virtualbox-host-modules            7.0.12-27            7.0.12-29
                         linux66-zfs             2.2.2-14             2.2.2-16
                   linux67-acpi_call           1.2.2-0.15           1.2.2-0.17
                    linux67-bbswitch             0.8-0.15             0.8-0.17
                linux67-nvidia-390xx         390.157-0.15         390.157-0.17
                linux67-nvidia-470xx      470.223.02-0.14      470.223.02-0.16
                      linux67-nvidia       545.29.06-0.14       545.29.06-0.16
                       linux67-r8168        8.052.01-0.15        8.052.01-0.17
                   linux67-rtl8723bu         20231204-0.9        20231204-0.11
                    linux67-tp_smapi            0.44-0.15            0.44-0.17
                 linux67-vhba-module        20211218-0.15        20211218-0.17
     linux67-virtualbox-host-modules          7.0.12-0.15          7.0.12-0.17
                         linux67-zfs                    -            2.2.2-0.2
1 Like

If you see it as an issue you can point it out here: Issues · Applications / pamac · GitLab


3 posts were split to a new topic: Wifi not working after updating kernels

Light locker currently doesn’t work properly. It locks once, upon unlocking you’re greeted with a black screen and only the mouse cursor, forcing you to change TTY and startx there. From there on, light locker doesn’t work at all until you reboot.

[Wed Dec 20 14:17:04 2023] traps: light-locker[2479] trap int3 ip:7fd1399af2a8 sp:7ffd2dd82870 error:0 in libglib-2.0.so.0.7800.3[7fd13996c000+9e000]

Edit: LightDM decided to start using 100% of the CPU for some reason

Edit 2: Lazy man’s solution is out with light-locker and now I’m just using xfce-screensaver’s lock

I’ve upgraded to the recommended kernel version 6.6.7-4, and I’ve started to notice some issues:

  • Watching YouTube videos for 10-20 minutes in Firefox causes the whole computer to irrecoverably freeze. In some cases I can still move the cursor, but cannot click on anything, and cannot even switch to another TTY session. In some cases not even the cursor moves.
  • I’ve noticed, Steam is starting so slow, it triggers the “Application not responding” window at least three times (always clicking on “Wait”), but eventually it starts.
  • Started to play a game, and it froze in the first 3 minutes (but I could force quit).

Reverting to kernel version 6.5.13-6 solved everything.


  • Manjaro x86_64 always up to date
  • Gnome 45.2
  • Wayland
  • Mesa for GPU driver


  • Ryzen 7 7700X
  • Radeon RX 7900 XT
  • 64 GB DDR5

As I’m currently not experiencing the issues running the older kernel, it’s not crazy urgent to resolve this, but I would like to test it a little bit to find out what’s wrong with the new kernel. Could someone tell me, which logs could be relevant to check out after such a freeze happens? Under /var/log I haven’t found anything that seemed to be relevant with a recent modification date.

Edit: well, it looks like the issue is bigger than just the kernel, as it keeps freezing under load. I would appreciate some ideas which logs to check in order to find out what’s going on.

Consider adjusting any power saving or hibernation settings. What you describe could easily be related, though other causes are possible.

Regarding Steam: :person_shrugging:

Kernel 6.5 is no longer supported. You might try reverting to kernel 6.1 (LTS), however from what you describe, I doubt the kernel is the problem.

Regarding logs. These links may help you find what you need. Unfortunately, I can’t (I must go).

I’m sure others will add their thoughts soon. However, it might be best to open a new thread to make it easier to focus on your issues.


1 Like

Thank you very much for the quick response!

Well, I’m afraid, it won’t be needed anymore, as I might have found the problem.

I’ve started a Memtest, and at the moment at 71% there are already 31 failures. Great. :frowning:

I’m just so shocked, because up until upgrading the kernel, the system was perfectly stable, it was impeccable. And I’m not even overclocking or anything; it’s running on base frequency.

Well, I guess I’ll have a round with Corsair’s warranty department.

Also check that the RAM modules are seated properly; and that they are in the recommended slots (check your mainboard documentation). Either of these not being the case could potentially allow incorrect test results.

Otherwise, Murphy’s Law strikes again.

I’ve tested each module individually in each slot. One module turned out to be faulty. At the moment I’m using the module that still works, and using kernel version 6.6.7-4 again.

So this case is unrelated to the kernel upgrade.


Sometimes it can also be hardware issues rather than software.