[Stable Update] 2023-12-01 - Kernels, NVIDIA, Thunderbird, Deepin, PipeWire 1.0, QEMU

After this update, during 2D rendering (window effects, text scrolling, etc.) the smoothness of rendering has greatly decreased, which leads to unpleasant “jitter”. In 3D, either this effect does not appear or is not noticeable. The disappearance of rendering smoothness is very noticeable when smoothly scrolling text in a browser window. In this case, after a few seconds of scrolling, the rendering of scrolling becomes smooth again, but after stopping, the effect appears again. Tell me, what could be the problem and how to fix it?

My system:

OS: Manjaro 23.1.0 Vulcan
Kernel: x86_64 Linux 6.6.3-1-MANJARO
Uptime: 7h 4m
Packages: 1253
Shell: zsh
Resolution: 2560x1440
DE: KDE 5.112.0 / Plasma 5.27.9
WM: KWin
GTK Theme: Breeze [GTK2/3]
Icon Theme: breeze
Disk: 1,1T / 4,9T (23%)
CPU: AMD FX-8350 Eight-Core @ 8x 4GHz
GPU: NVIDIA GeForce GTX 1060 6GB
RAM: 3689MiB / 32066MiB

If there are issues with nvidia drivers, always check lsmod and modprobe nvidia. when modules are not loaded, installing nvidia-dkms might help and report any issues with the precompiled modules, sonwe fix them.

I have the same problem. This is related to the kernel (>= 6.6.2 & >= 6.1.63). I downgraded mine to 6.1.62 and the problem was gone.

Probably this bug: https://bugzilla.kernel.org/show_bug.cgi?id=218142

Through experimentation I found out that this problem only occurs under X11. Under Wayland everything works very smoothly.

i also get this “error” after updating:
kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module 545.29.06
i looked around and it doesn’t seem to be an issue.

also following @philm comment;
i just checked and don’t have nvidia-dkms installed on my system,is it required?
or as i just read; it’s meant for persons using a custom kernel or switching between Kernels?
i recently changed from 6.1 to 6.6.

After the “upgrade”, the desktop background doesn’t load for about 25 seconds. Any XFCE related app I want to start takes also about the same time. Afterwards apps start kinda normal. Here the output of journalctl -b --user

Dec 02 12:20:41 woody systemd[2146]: Starting flatpak document portal service...
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Activating via systemd: service name='org.freedesktop.impl.portal.PermissionStore' unit='xdg-permission-store.service' requested by ':1.39' (uid=1000 pid=2409 comm="/usr/lib/xdg-document-portal")
Dec 02 12:20:41 woody systemd[2146]: Starting sandboxed app permission store...
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'org.freedesktop.impl.portal.PermissionStore'
Dec 02 12:20:41 woody systemd[2146]: Started sandboxed app permission store.
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'org.freedesktop.portal.Documents'
Dec 02 12:20:41 woody systemd[2146]: Started flatpak document portal service.
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Lockdown as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: The preferred method to match portal implementations to desktop environments is to use the portals.conf(5) configuration file
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Activating via systemd: service name='org.freedesktop.impl.portal.desktop.gtk' unit='xdg-desktop-portal-gtk.service' requested by ':1.38' (uid=1000 pid=2388 comm="/usr/lib/xdg-desktop-portal")
Dec 02 12:20:41 woody systemd[2146]: Starting Portal service (GTK/GNOME implementation)...
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Activating via systemd: service name='ca.desrt.dconf' unit='dconf.service' requested by ':1.37' (uid=1000 pid=2367 comm="light-locker")
Dec 02 12:20:41 woody systemd[2146]: Starting User preferences database...
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'ca.desrt.dconf'
Dec 02 12:20:41 woody systemd[2146]: Started User preferences database.
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'org.freedesktop.impl.portal.desktop.gtk'
Dec 02 12:20:41 woody systemd[2146]: Started Portal service (GTK/GNOME implementation).
Dec 02 12:20:41 woody xdg-desktop-por[2388]: No skeleton to export
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.FileChooser as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.AppChooser as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Print as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Notification as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Inhibit as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Access as a last-resort fallback
Dec 02 12:20:41 woody systemd[2146]: Started PipeWire Multimedia Service.
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Account as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.Email as a last-resort fallback
Dec 02 12:20:41 woody xdg-desktop-por[2388]: Choosing gtk.portal for org.freedesktop.impl.portal.DynamicLauncher as a last-resort fallback
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'org.freedesktop.portal.Desktop'
Dec 02 12:20:41 woody systemd[2146]: Started Portal service.
Dec 02 12:20:41 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Activating via systemd: service name='org.gtk.vfs.UDisks2VolumeMonitor' unit='gvfs-udisks2-volume-monitor.service' requested by ':1.31' (uid=1000 pid=2336 comm="/usr/lib/tumbler-1/tumblerd")
Dec 02 12:20:41 woody systemd[2146]: Starting Virtual filesystem service - disk device monitor...
Dec 02 12:20:42 woody systemd[2146]: Started Sound Service.
Dec 02 12:21:06 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Activating via systemd: service name='org.gtk.vfs.Metadata' unit='gvfs-metadata.service' requested by ':1.18' (uid=1000 pid=2274 comm="xfdesktop")
Dec 02 12:21:06 woody systemd[2146]: Starting Virtual filesystem metadata service...
Dec 02 12:21:06 woody dbus-daemon[2161]: [session uid=1000 pid=2161] Successfully activated service 'org.gtk.vfs.Metadata'
Dec 02 12:21:06 woody systemd[2146]: Started Virtual filesystem metadata service.
Dec 02 12:21:07 woody tumblerd[2336]: Error creating proxy: Error calling StartServiceByName for org.gtk.vfs.UDisks2VolumeMonitor: Timeout was reached (g-io-error-quark, 24)
...

It seems that XFCE doesn’t install the xfce-portals.conf file which is now required. See the bug report / discussion over at Debian: Bug#1050802: xfce4-session: please provide an xfce-portals.conf for xdg-desktop-portal.

For a detailed explanation as to why the -portals.conf is needed, see: MBF: adding portals.conf(5) to desktop environments. Here a quote from above email:

In Debian 12, if xdg-desktop-portal does not find a suitable backend
for the current desktop environment, it would fall back to trying any
backend. This meant that all backends needed to be prepared to run in an
environment where their functionality cannot actually work, which is
rarely tested, leading to undesired situations where a desktop
environment’s backend can cause bugs (such as crashes or slow application
startup) while running different desktop environments.

Further down it reads:

In a future version of xdg-desktop-portal, installing a portals.conf(5)
file is likely to become a requirement for desktop environments that
want to have working portal interfaces. For the moment, there is some
backwards-compatibility to keep existing desktop environments mostly
working (see below).

I’m intending to re-upload x-d-p 1.17.x to unstable soon.

From the portals.conf man page:

Desktop environments and OS vendors should provide a default configuration for their chosen portal backends in /usr/share/xdg-desktop-portal/DESKTOP-portals.conf, where DESKTOP is the desktop environment name as it would appear in the XDG_CURRENT_DESKTOP environment variable, after case-folding ASCII upper case to lower case.

My machine does not include a xfce-portals.conf file (searched everywhere, including /usr/share/xdg-desktop-portal/)

Here the inxi -G data:
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] driver: N/A
Device-2: NVIDIA GF106GL [Quadro 2000] driver: nvidia v: 390.157
Device-3: Logitech Webcam C930e driver: snd-usb-audio,uvcvideo type: USB
Display: x11 server: X.Org v: 21.1.9 driver: X: loaded: nvidia gpu: nvidia
resolution: 2560x1440~60Hz
API: OpenGL Message: Unable to show GL data. glxinfo is missing.

The host graphics card for Manjaro/XFCE is Device-2: NVIDIA GF106GL [Quadro 2000] driver: nvidia v: 390.157

Please advise as to what to write into the xfce-portals.conf for a XFCE desktop and add the xfce-portals.conf file to the XFCE package.

UPDATE:
In response to my own post above:

I copied the /usr/share/xdg-desktop-portal/gtk-portals.conf file into ~/.config and renamed it to xfce-portals.conf

Contents of ~/.config/xfce-portals.conf

[preferred]
default=gtk

This hack seems to have solved the issue with the delay after login.

Please let me know if this xfce-portals.conf file is correct and please fix the issue by including the xfce-portals.conf file as part of the xfce desktop environment, as described in my previous post.

Thanks for providing such a great distribution!

2 Likes

Looking at /var/log/pacman.log , I saw:

 [ALPM-SCRIPTLET] :: MariaDB was updated to a new feature release. To update the data run:
 [ALPM-SCRIPTLET]      # systemctl restart mariadb.service && mariadb-upgrade -u root -p

I tried to the suggested which however failed. (I don’t know what the new feature release is about yet)



╭─░▒▓    ~ ▓▒░                                                   ░▒▓ ✔  17:02:55  ▓▒░─╮
╰─ systemctl restart mariadb.service && mariadb-upgrade -u root -p                        ─╯
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xeu mariadb.service" for details.

╭─░▒▓    ~ ▓▒░                                         ░▒▓ 1 ✘  10s   17:03:10  ▓▒░─╮
╰─ sudo systemctl restart mariadb.service && mariadb-upgrade -u root -p                   ─╯
[sudo] password for 1:
Job for mariadb.service failed because the control process exited with error code.
See "systemctl status mariadb.service" and "journalctl -xeu mariadb.service" for details.

╭─░▒▓    ~ ▓▒░                                          ░▒▓ 1 ✘  6s   17:03:54  ▓▒░─╮
╰─ systemctl status mariadb.service                                                       ─╯
× mariadb.service - MariaDB 11.2.2 database server
     Loaded: loaded (/usr/lib/systemd/system/mariadb.service; disabled; preset: disabled)
     Active: failed (Result: exit-code) since Sat 2023-12-02 17:03:54 CET; 18s ago
       Docs: man:mariadbd(8)
             https://mariadb.com/kb/en/library/systemd/
    Process: 4217 ExecStartPre=/bin/sh -c systemctl unset-environment _WSREP_START_POSITION >
    Process: 4218 ExecStartPre=/bin/sh -c [ ! -e /usr/bin/galera_recovery ] && VAR= ||   VAR>
    Process: 4246 ExecStart=/usr/bin/mariadbd $MYSQLD_OPTS $_WSREP_NEW_CLUSTER $_WSREP_START>
   Main PID: 4246 (code=exited, status=1/FAILURE)
     Status: "MariaDB server is down"
        CPU: 286ms

Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [Note] InnoDB: Loading buffer pool>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [Note] InnoDB: Buffer pool(s) load>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [ERROR] Can't open and lock privil>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [Note] Server socket created on IP>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [Note] Server socket created on IP>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [ERROR] Fatal error: Can't open an>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [ERROR] Aborting
Dec 02 17:03:54 lapman systemd[1]: mariadb.service: Main process exited, code=exited, status=1/>
Dec 02 17:03:54 lapman systemd[1]: mariadb.service: Failed with result 'exit-code'.
Dec 02 17:03:54 lapman systemd[1]: Failed to start MariaDB 11.2.2 database server.

╭─░▒▓    ~ ▓▒░                                       ░▒▓ 3 ✘  1m 9s   17:05:21  ▓▒░─╮
╰─ journalctl -xeu mariadb.service                                                        ─╯
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [ERROR] Fatal error: Can't open an>
Dec 02 17:03:54 lapman mariadbd[4246]: 2023-12-02 17:03:54 0 [ERROR] Aborting
Dec 02 17:03:54 lapman systemd[1]: mariadb.service: Main process exited, code=exited, status=1/>
░░ Subject: Unit process exited
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░
░░ An ExecStart= process belonging to unit mariadb.service has exited.
░░
░░ The process' exit code is 'exited' and its exit status is 1.
Dec 02 17:03:54 lapman systemd[1]: mariadb.service: Failed with result 'exit-code'.
░░ Subject: Unit failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░
░░ The unit mariadb.service has entered the 'failed' state with result 'exit-code'.
Dec 02 17:03:54 lapman systemd[1]: Failed to start MariaDB 11.2.2 database server.
░░ Subject: A start job for unit mariadb.service has failed
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░
░░ A start job for unit mariadb.service has finished with a failure.
░░
░░ The job identifier is 2399 and the job result is failed.

Same error when I use sudo su before trying the suggested.

Think someone mentioned it already here or in Stable 11-28 but I can’t find it anymore.

I also did some research and including a temporary fix in this thread

I think this new feature branch Nvidia driver is causing me flickering (4000 series card). I tried turning off things like gsync, and flipping, but it didn’t help. As such I ran timeshift to a state before the update. Is there a way to downgrade the driver via the repo? After the update I don’t see a 535 driver in the repo.

1 Like

We other nvidia owners had this flickering for glorius 6 full month and it was finally fixed…

You as a new nvidia flagship owner can also archive the ultimate taste and how nvidia treat us nvidia customers :smile:

There are some workarounds to temporary get rid of it, that might help you till this issue is fixed for you, when you complain long enough in the nvidia Forum, like i did in the foretime.

If nvidia drm mode set not working after reboot, you can try this:

You can also change this stuff in the GUI btw.
And keep in mind, this changes require more Watt usage from your GPU, in idle mode my 2080Ti
used 50Watt instead 10Watt.

As a third and the last option that i know, there you can also quickly use Sleepmode and no more flickering (temporary) till you restart your PC.

1 Like

Thanks for the information.

First of all, my problem is a little different. My flickering isn’t black, it’s more like the graphics for thumbnails and context menus quickly become corrupt and correct themselves. It happens frequently, especially if I open steam and allow shaders to cache. Sometimes it seems random.

I also have drm modesetting enabled already, because I installed the plasma wayland session a while back.

I also tried googling it and came across the bug of flickering during changes of the power mode, so I set it to prefer maximum and that didn’t work.

I should have mentioned these things in my first post, but I figured this would be more common. I guess it’s something else.

This doesn’t happen under wayland, but there’s too many programs I am accustomed to using on x11 that don’t provide a great experience on wayland.

If I run my updates, and simply

pacman -S linux66-nvidia 535.129.03-4

Will that install?

I am still running my restored un-updated system.

1 Like

I had the same problem with my dualshock 4 controller, apparently bluez 5.69 was broken a few months back… … not even the update to 5.70 fixed the problem for me even tho some people said it fixed it for them… my solution that worked for me was I downgraded bluez, bluez-libs, bluez-utils to 5.68 using the downgrade command thru the terminal. hope this helps

https://www.reddit.com/r/ManjaroLinux/comments/16r31sd/ps4_controller_suddenly_doesnt_connectpair_thru/
https://bbs.archlinux.org/viewtopic.php?pid=2118917#p2118917

Of course not. If it had been that easy NVIDIA owners wouldn’t have suffered from flickering for half a year.

But an option to downgrade drivers is not provided for Manjaro users. linux66-nvidia now includes 545 branch, 535 is not in the official repositories anymore.

2 Likes

I don’t recommend it. You should restore system from backup. If you have older packages in your pacman cache, you may try to downgrade it, but it involved downgrading all kernels, all kernel modules, all graphical drivers, which may go wrong very, very wrong, assuming that system will let you do it (which I doubt it, you will get some errors and process won’t go further).

2 Likes

Thanks for your reply - yep, your explanation and suggestion looks spot-on.

I hope the maintainers include a proper xfce-portals.conf file. In that case it would be better to not have the local xfce-portals.conf file under ~/.config…, but one under /usr/share/xdg-desktop-portal/xfce-portals.conf, together with possibly other DESKTOP-portals.conf files.

A local ~/.config… file would override the config provided by the maintainers.

Create a Topic (or check if someone else openend one and upvote it for moderator attention) on the nvidia forum, report the issue and also get maybe help from others who maybe know a workaround for your issue.

Did you try the sleepmode, workaround?

I remember the flickering was also more visible while using steam, maybe it has to do something with Powerstates, but when you switched to max performance already and try’d the sleepmode im pretty lost.

I also would recommend to keep the last working stable update before december but maybe also update again and create another snapshot and when the next stable update comes out, you won’t run into issue when you rollback then before you update again.

Keep in mind about the files that are overwritten from your restore… i feel the pain for you but atleast you can evade this bug for some time, so get sure nvidia will pay attention.

I heared there was a legacy driver (it was mainly for nvidia 7xx Gen after they run out of support), that should work… but i never archived any experience with rolling back, to this legacy driver.

You better collect more infos in Manjaro Forum about this legacy driver and if its support your GPU.

Even if that works, im still unsure if this legacy driver actually works with the newest Gen… i wouldn’t count on it… because this driver only gets updated for security issues.

A rollback to 535 is not possible, there are to many incompatibilitys.

Edit: Additional i would also try change Hz if you own a high refreshrate Monitor or disable compositor under system settings>display monitor but thats only my last straw.

1 Like

Yeah, that’s true. My fix is based on what’s already on XFCE’s gitlab tho (see the links in EDIT4) so worst case: it would overwrite with exactly the same settings :wink:

no it won’t. we ship pre-compiled drivers which only match one certain kernel version. So if we update also the kernel that module won’t load. You can get the utils from here: Files · e1ac0a3c4c955a7d032230ced15aedf205a1bbd4 · Packages / Extra / nvidia-utils · GitLab and for lib32 here: Files · 714f1413be1a12b42d7b8f33debc13baa6acec63 · Packages / Multilib / lib32-nvidia-utils · GitLab. You have to compile it with makepkg, put them to the ignore list and use the nvidia-dkms package to compile the module for your kernel.

2 Likes

Same problem here. I downgraded nvidia drivers to 470x as a workaround.

1 Like

No KDE or other new issues (old: Plasma System Monitor core dumps on laptop, Powerdevil/Ddcutil on desktop) here. For the latter, manjaro-downgrade showed no dependency issue while downgrading the 2 packages.
Nvidia 545 seems to work fine here.

Wait, Dolphin can’t open folders with “?” in their name anymore (or could it ever?), but can create/trash/delete them.