[Stable Update] 2023-11-21 - Systemd, Gamescope-Plus, KDE Frameworks, Wine, Pipewire, Thunderbird

Yes, but for good measure, you should then also replace keymap and consolefont by sd-vconsole.

Just for illustration purposes, these are my hooks below. But do note that I’ve got Intel graphics and that I’m using btrfs, which may differ for your use case. :point_down:

HOOKS=(systemd autodetect modconf kms block keyboard sd-vconsole filesystems)

So, nobody else gets a core dump trying to login (kde)?
I get a core dump in startplasma-x11/wayland every time.
Installed cinnamon and it “runs” in fallback mode.
It is a laptop, i7-10850H with a Nvidia Quadro T1000.
I’ve had some issues in the past, mainly because of the graphics card, but nothing like this.
Any ideas?

1 Like

Welcome to the forum! :vulcan_salute:

It is obviously a graphics driver issue. Wayland doesn’t like Nvidia, and I don’t know what display server Cinnamon uses — i.e. I don’t know whether it even supports Wayland at al — but the fallback thing also points in the direction of Nvidia.

If you cannot figure it out, please open a separate thread. This thread here is specifically for reporting issues and perhaps small questions that can easily be answered. Troubleshooting graphics driver issues is a whole other matter. :wink:

HOOKS="base udev autodetect modconf block keyboard keymap encrypt filesystems"

should I use what you posted instead of this then? What is the case if i dont use intel graphics?

That is a dangerous example for newbies lol. Both the wiki page and the comments in mkinitcpio.conf itself have dire warnings about fsck hook being strongly recommended and required for seperate /usr partition, and using systemd fsck instead requires additional configuration.

1 Like

No, I only showed you what I am using on my system. Obviously, you must adapt this to your own configuration. In your case, it would then be… :point_down:

HOOKS=(systemd autodetect modconf block keyboard sd-vconsole sd-encrypt filesystems)

But I notice that you have not been merging your .pacnew files. The double-quote “HOOKS="..."” syntax was deprecated in favor of the “HOOKS=(...)” syntax ages ago already.

Your current HOOKS line does not have any mention of the Nvidia-specific hooks for modesetting with the proprietary driver, so you should be good to go.

I only mentioned that I’ve got Intel graphics in case people were wondering about the Nvidia-specific stuff — which will still be needed whether you use the systemd hooks or not.

It was not intended as how it should be done, but merely as an illustration of how it is on my system.

I did also mention that I use btrfs, and with btrfs, you don’t need an fsck hook in the initramfs because btrfs always checks the filesystem at mount time — it will even replay the journal on a filesystem that is to be mounted read-only if it detects filesystem damage. :wink:

With ext4 and other traditional (read/write-mounted) filesystems, you do indeed need the fsck hook.

1 Like

Thanks for the reply - I was assuming an issue with this update, because there were no nvidia updates since before my previous reboot.

1 Like

Thank you for the hint, i did the change over to systemd hooks and it significantly shortened boot time. Seems like the console printing was slowing down the process previously and now it’s much faster, i have no time to even read the text as it scrolls so fast.

1 Like

Before the update I replaced my previous:

HOOKS=(base udev autodetect modconf kms keyboard keymap consolefont block filesystems fsck shutdown)

… with:

HOOKS=(systemd autodetect modconf kms keyboard sd-vconsole block filesystems fsck shutdown)


sudo mkinitcpio -P
sudo update-grub

Then switched to kernel 6.1, since I previously used 5.15, rebooted, then used the usual update script and everything went good, although, I’ve seen some error messages during the update, like cuda was not downloaded entirely and similar.

should i run sudo mkinitcpio -P after the update,or after restarting the PC? or does Pamac takes care of it?

Before. But you should not do anything. Above are just examples. Leave the defaults and it will work too.

i wasn’t intending on changing/adding HOOKS
i’m asking because of the update.

Just cat /etc/mkinitcpio.conf and take a look. In most of the systems base is the first hook by default (i actually think it is the default by everybody, if not deliberately changed by user). If it is there you do not need to do anything.

1 Like

i already looked and have it,
but I’m assuming the update changes things in this file and i was told i should run this command after changes has been made,thus my question.

It doesn’t change anything. It requires that you have base in the mkinitcpio.conf file.

I don’t see you were told anything (at least in this thread).

I think it’s a good idea to separate the questioning about good and actual settings of HOOKS to a own thread, isn’t it.
@Aragorn can hopefully start with some good tips.


Well, it’s all properly explained on the Arch Wiki page, if only people were to actually look at it. :stuck_out_tongue:


Just ran the update using sudo pacman -Syu. Everything went well, but I noticed this new warning when pacman runs the build hooks (this message appears for each kernal - 5.15 and 6.1.

==> WARNING: consolefont: no font found in configuration

Should I be concerned?

1 Like
1 Like

See also Don't show warning if /etc/vconsole.conf is not found in consolefont hook (#139) · Issues · Arch Linux / Mkinitcpio / mkinitcpio · GitLab

Will ignore.

1 Like