[Stable Update] 2023-10-09 - Mesa, Grub, GlibC, Thunderbird, KDE Frameworks Renaming

pacman likes to get your permission for each package
If you prefer not to have to respond to each package prompt, you can use pamac instead of pacman

sudo pamac update

pamac will take care of it for you

But refresh your mirrors beforehand

sudo pacman-mirrors --country all --api --protocols all --set-branch stable

assuming you are on stable branch as you are posting in this thread.

Together in sequence:

sudo pacman-mirrors --country all --api --protocols all --set-branch stable && sudo pamac update


3 posts were merged into an existing topic: Update fails due to depencies are in confilict _Manjaro Gnome

The update shuffled application grid in KDE Application Launcher->Favourites. Not an issue but a weird behaviour. Except that everything looks fine.

Yes I also saw that behaviour. Not a big deal and preferable to it forgetting window size/position preferences as has happened in the past. :upside_down_face:

I needed sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\* so thanks @philm for that heads up. Now taking bets on how many people won’t read that. :stuck_out_tongue_closed_eyes:


Why does that require renames? Doesn’t hat imply that I will not get the version 6 update?

3 posts were split to a new topic: Are concerns about GRUB breaking no longer an issue?

3 posts were split to a new topic: How to upgrade to KDE 6

I have a problem with update from today:
e.g.: glibc locales: /usr/lib/locale/zu_ZA_utf.8/LC Time exists in filesystem.

1 Like



During boot i noticed a warning

BFPT parsing failed please consider SPI_NO

journalctl -b -t kernel -p3

spi-nor spi0.0: BFPT parsing failed. Please consider using SPI_NOR_SKIP_SFDP when declaring the flash

The solution for me is create a file spi_nor.conf in /etc/modprobe.d

sudo vim /etc/modprobe.d/spi_nor.conf
blacklist spi_nor

more information in the archwiki

A post was split to a new topic: LUKS device not recognized

Update failed using pacman-mirrors -f && sudo pacman -Syyu but updating via GUI/pamac worked.

One minor thing that caught my eye is that favorites in the application overview are no longer in the order I set.

The update also solved a problem I had been having for some time where icons on the desktop would no longer show as highlighted after they were selected. :+1:

1 Like

Thank you for getting the security fix for glibc out!

I’m also getting a renamed GTK package, before updating:
libgedit-amtk and amtk are in conflict
and Pacman wants me to remove the latter [y/N]

Says the package amtk was renamed here:
“The project has been renamed to libgedit-amtk and is now hosted on…” Gedit Technology.

So it’s probably reinstalled under the new name during the process.

8 posts were split to a new topic: Kvantum is causing problems

Never use sudo with pamac. It will mess up the permissions on your package databases.

pamac is intended to be run with the user’s own privileges and will prompt you for a password when needed.

It simply implies that there will be a choice when Plasma 6 hits the repos, so that no packages from Plasma 6 will be overwriting packages needed in Plasma 5.


A post was merged into an existing topic: Kvantum is causing problems

7 posts were split to a new topic:

:trophy: :trophy:


Somehow — only the universe knows why — my Plasma desktop was once again completely screwed up after updating. The symptoms were the same as the last time.

I had to restore a full system backup — and a separate (and even earlier) copy of my $HOME, because the copy in the last backup was corrupt again as well — and then run the update process all over again. And then it all worked out fine again. :man_shrugging:

After reading this update announcement as I always do the update went fine
(I did sudo pacman -Syu glibc-locales --overwrite /usr/lib/locale/\*/\* and said Yes to replace some packages), the only thing I noticed is that pamac in now full white (it had a dark theme like the rest of my system) but not bothering me at all since everything is working as it should.
Manjaro XFCE for more than 3 years here.