[Stable Update] 2023-09-10 - Kernels, Systemd, Firefox, Thunderbird, LLVM

No, definitely not the minority. Quite the opposite: it’s what almost everyone does. But if you’re updating the system from within the GUI, then a whole busload of shared libraries will be in use that are going to be overwritten, and this could cause serious problems.

Secondly, pamac is a work in progress, and it has serious issues — especially the GUI versions, although even the command-line version has its problems.

pacman on the other hand is the mature command-line-only package manager for Arch-based distributions, and you can use yay — which is equally mature — for installing AUR packages. But of course, yay does not handle Snaps or FlatPaks, so you may need to resort to (the command-line version of) pamac for those.

Same issue, same results - un/re-installing keepass corrected the issue.

For flatpaks, there’s

flatpak update

I use KDE’s Discover to handle Flatpaks.

1 Like

I’m using KDE Plasma, running on X11 and have tearing after the update. There is also a Plasma-Render warning. I have tried both, software renderer and OpenGL, but for both there is tearing when scrolling in firefox or watching videos.

Furthermore I cannot adjust under system settings/compositor the sync option. It has disappeared?

What should I do?

inxi -Fza
  Kernel: 6.5.1-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
  inxi: 3.3.29

Though this is not working, as in installing just the libva-mesa-driver doesnt work , installing all the packges are also not working

How exactly should we log out? Is there a command in tty that we need to use?

Um, every desktop environment has a logout function/button, no?

In KDE Plasma, you can also log out by pressing Ctrl+Alt+Del, or if you want it without the confirmation screen, Ctrl+Alt+Shift+Del.

You either way have to be looking at the login screen — note: the login screen, not the lock screen; they are different things.

1 Like

Oh crap, Keepass is broken on KDE, and it doesn’t launch!
You get the following error:
I reinstalled, and the program, and it launches, but you can’t open it. You get the password key error. How ever, you can launch keepass through Konsole only.
Here’s the original error message:

 Assertion at aot-runtime.c:2638, condition `is_ok (error)' not met, function:decode_cached_class_info, Image out of date

        Native Crash Reporting
Got a SIGABRT while executing native code. This usually indicates
a fatal error in the mono runtime or one of the native libraries 
used by your application.

        Native stacktrace:
        0x5627a45dcf19 - mono : 
        0x5627a4586437 - mono : 
        0x5627a45d4d6c - mono : 
        0x7f8bf6a3e710 - /usr/lib/libc.so.6 : 
        0x7f8bf6a8e83c - /usr/lib/libc.so.6 : 
        0x7f8bf6a3e668 - /usr/lib/libc.so.6 : raise
        0x7f8bf6a264b8 - /usr/lib/libc.so.6 : abort
        0x5627a4538f61 - mono : 
        0x5627a4860de8 - mono : 
        0x5627a4861759 - mono : monoeg_assertion_message
        0x5627a4577ef8 - mono : 
        0x5627a4577f6c - mono : 
        0x5627a46d6e07 - mono : 
        0x5627a461090c - mono : 
        0x5627a45e4156 - mono : 
        0x5627a453f339 - mono : 
        0x5627a4588cf5 - mono : 
        0x5627a458a592 - mono : 
        0x40d44393 - Unknown

        Telemetry Dumper:
Pkilling 0x140239072917184x from 0x140239118114880x
Entering thread summarizer pause from 0x140239118114880x
Finished thread summarizer pause from 0x140239118114880x.
Failed to create breadcrumb file (null)/crash_hash_0x6903e1f5

Waiting for dumping threads to resume

        External Debugger Dump:
mono_gdb_render_native_backtraces not supported on this platform, unable to find gdb or lldb

        Basic Fault Address Reporting
Memory around native instruction pointer (0x7f8bf6a8e83c):0x7f8bf6a8e82c  05 00 44 89 ea 89 de 89 c7 b8 ea 00 00 00 0f 05  ..D.............
0x7f8bf6a8e83c  89 c3 f7 db 3d 00 f0 ff ff b8 00 00 00 00 0f 47  ....=..........G
0x7f8bf6a8e84c  c3 e9 78 ff ff ff 66 0f 1f 44 00 00 4c 89 e7 e8  ..x...f..D..L...
0x7f8bf6a8e85c  d0 ae ff ff e9 4c ff ff ff 0f 1f 00 4c 89 e7 e8  .....L......L...

        Managed Stacktrace:
          at <unknown> <0xffffffff>
          at KeePass.Program:Main <0x0003a>
          at <Module>:runtime_invoke_void_object <0x00091>
zsh: IOT instruction (core dumped)  keepass
    ~                       
1 Like

In my case: a boring update. As smooth as butter. Thanks!

Did you try to reinstall mono?

You probably are using the nonfree repo. You should be able to fix it by installing llvm15-libs.

1 Like

I am new here so I don’t know where to say this, but I’ll just post here about an issue I resolved myself about this update.

I think my kernel did not update with this update, which caused grub to say that some linuz file was not found. I was running 6.1, and I have 4.19 installed in the background. I had too boot into a live USB and use manjaro-chroot -a to reinstall the 4.19 kernel, which allowed me to boot into the main OS using the 4.19 kernel. Next, I reinstalled the 6.1 kernel and booted into that.

This was annoying and concerning, but it seems everything is fine now. If wanted I can post more details.

1 Like

Compiz stopped working, but rebuilding it and rebooting fixed it.

The update appears to have gone well for me (I am running KDE) with one exception.
It overwrote my customized Grub config file.
It was not a big issue for me as I keep a backup copy of my Grub config file just in case.
I would recommend to anyone who has customized their Grub menu to make a backup copy of their config file prior to applying the update.

1 Like

There shouldn’t be any need to log out the GUI session. As long as the update’s on a TTY, a crashing desktop can’t cause any problems.

Fixed with procps-ng 4.0.4-1.1 coming along shortly.

After update, right-click on cairo-dock items and select “Edit” does nothing. No way to edit the settings for a given dock item. Reposition of the dock seems to fix it.

2 posts were split to a new topic: Audio stopped working with systemd v253.10

While this will fix most of the issues, steam will refuse to work, as there is no lib32-llvm15-libs available.

I’ve downgraded both llvm libs to previous version (15.0.7-3). Maybe it is not supported but at least it works. I hope nonfree repo will get updated soon.

1 Like