[Stable Update] 2023-07-27 - Kernels, Nvidia, Virtualbox, Thunderbird, LibreOffice, Pipewire

Well, Microsoft reduced disk space on their VMs … However there are hacks available.

1 Like

Apparently kernel 6.1.41-1 is still affected by this issue below… :arrow_down:

I don’t think it would be an actual CPU load of 100% on that particular core, though, because if that were the case, then the temperature readout for that particular core would be a lot higher than can be seen in the second screenshot here-above.

On my system, that particular core always runs just a tad hotter than the other cores anyway, but its current temperature readout of 36°C is not consistent with a core that’s genuinely stuck at 100% — in that case, the temperature readout would probably be somewhere in the 40-50°C range.

So whatever’s causing this apparent 100% load is most likely a bug in the kernel code reporting the core temperatures, and according to the 2023-07-25 Testing update thread, the issue was apparently fixed in 6.4.6. I guess no one thought of backporting it to 6.1 as well. :frowning_face:

Oh, and on account of mariadb being the cause — which I doubt, although it may be the trigger — replacing it by postgresql is not an option here because I’m running Plasma, and akonadi requires mariadb. I don’t know whether it would be possible to replace mariadb by mysql proper — I’ll have to investigate that — but mysql is an AUR package, and I would rather not replace an essential component for my desktop environment by an AUR package.


pacnew (and pacsave, etc) are a product of ALPM (pacman, pamac, etc) … you wont have them on Ubuntu. But then you cant roll the same Ubuntu install for years and years. Frozen vs Rolling.
(and a care to preserve user configurations)
So a bit of consolation maybe :slight_smile:

Its triggered by akonadi (used by Kalendar) … but mariadb is the culprit.

The kernel is doing what it should … reporting had changed slightly.
That said a proposed kernel patch circumvents the issue by narrowing the reports and squashing another unrelated bug.

1 Like

It is not fixed in 6.4.6. The Arch Linux Bug Report mentions a LKML thread (without a link) that suggests it is not a Kernel error. However, there is a patch that fixes the problem inside the kernel. The patch comment suggest the high iowait is just a cosmetic issue.

The patch is at the moment not merged, so it is also not backported to any version.

1 Like

If there is a patch that fixes it inside the kernel — and I already knew about this :wink: — then it is a kernel issue. :stuck_out_tongue:

Yes, that much is true, as I said in my previous post. If it were a genuine 100% load, then the temperature readout for that particular CPU core would be a lot higher, as would the total temperature be for the entire processor chip. :wink:

Still, cosmetic or not, it’s annoying. :stuck_out_tongue_closed_eyes:

Nvidia Flickering issue also still exist with the newest nvidia driver version on Turing and Pascal GPU’s, related to high refresh TFT’s.

1 Like

Will the CPU peaks affect the 6.1.38-1 kernel?

We’ve skipped 6.1.38 in Stable, but yes, that was was where the problem was introduced in Unstable and Testing.

The NVIDIA update solved some issues for me.

The one thing that didn’t work after the update was my xbox controller. It still connected to bluetooth but it no longer rumbled on connect, and it was no longer recognized by any Steam games.

I simply rebuilt xpadneo-dkms, restarted, and its working again.

Yeah, it is just cosmetic but as Linus once said (very loudly and with a lot of swearing)

If a change results in user programs breaking, it’s a bug in the kernel. We never EVER blame the user programs.

1 Like

I have a strange bug with hanging keystokes after a few hours uptime. I think it started with the 10.7.23 or 17.7.23 update.

All applications seem to open the search bar searching for tabs in a loop and meta key is not working anymore. Nothing special to see in journalctl. The only thing that helps is a reboot.

I see a new error in journal after this update:

kernel: ucsi_ccg 0-0008: failed to get FW build information

The LTS Kernel 5.15 shows 1 CPU core at 100% as well.
(I I know already, it is just a cosmetic issue).

It seems that darktable is broken.

   ~  darktable                                                                                                                           IOT ✘ 
PHI node has multiple entries for the same basic block with different incoming values!
  %967 = phi float [ %largephi.extractslice0, %sw.default ], [ %largephi.extractslice055, %sw.bb667 ], [ %largephi.extractslice059, %sw.bb663 ], [ %largephi.extractslice063, %sw.bb659 ], [ %largephi.extractslice067, %sw.bb655 ], [ %largephi.extractslice071, %sw.bb646 ], [ %largephi.extractslice075, %_Z4fmodff.exit16 ], [ %largephi.extractslice079, %_Z4fmodff.exit13 ], [ %largephi.extractslice083, %_Z4fmodff.exit ], [ %largephi.extractslice087, %sw.bb562 ], [ %largephi.extractslice091, %sw.bb555 ], [ %largephi.extractslice095, %sw.bb533 ], [ %largephi.extractslice099, %if.then502 ], [ %largephi.extractslice0103, %if.else517 ], [ %largephi.extractslice0107, %if.then456 ], [ %largephi.extractslice0111, %if.else471 ], [ %largephi.extractslice0115, %if.then393 ], [ %largephi.extractslice0119, %if.else408 ], [ %largephi.extractslice0123, %if.then338 ], [ %largephi.extractslice0127, %if.else353 ], [ %largephi.extractslice0131, %if.then283 ], [ %largephi.extractslice0135, %if.else298 ], [ %largephi.extractslice0139, %if.then224 ], [ %largephi.extractslice0143, %if.else241 ], [ %largephi.extractslice0147, %sw.bb193 ], [ %largephi.extractslice0151, %sw.bb180 ], [ %largephi.extractslice0155, %sw.bb168 ], [ %largephi.extractslice0159, %sw.bb158 ], [ %largephi.extractslice0163, %sw.bb147 ], [ %largephi.extractslice0167, %if.then116 ], [ %largephi.extractslice0171, %if.else131 ], [ %largephi.extractslice0175, %sw.bb71 ], [ %largephi.extractslice0179, %sw.bb ], [ %largephi.extractslice0183, %if.end ], [ %largephi.extractslice0187, %if.end ], [ %largephi.extractslice0191, %if.end ], [ %largephi.extractslice0195, %if.end ], [ %largephi.extractslice0199, %if.end ]
label %if.end
  %largephi.extractslice0187 = extractelement <4 x float> %div, i64 0
  %largephi.extractslice0199 = extractelement <4 x float> %div, i64 0
in function blendop_Lab
LLVM ERROR: Broken function found, compilation aborted!
[1]    11325 IOT instruction (core dumped)  darktable

It works if I start it with darktable --disable-opencl, but it worked before (the 4.4.1) with openCL… (It need rocm-opencl-runtime)

If I remove all the rocm-opencl-runtime packages (and dependencies), it works again.

There was no issue with the update except that the new Thunderbird version refused to display some of my mail accounts in the unified mailboxes view. After some unsuccessful attempts to fix this I eventually decided to set up a fresh user profile. Well, the old profile was 12 years old, originallly created on OS X and then migrated to Linux, and also full of clutter of old mail accounts long gone. So I consider this to be an opportunity for a spring cleaning rather than troubleshooting. :wink:


I think your idea is good.
But just in case other users run into the same issue and have less of a reason for cleaning …

Now with a one-liner.


Had issues with using HTTPS mirrors (“TLS error decoding” error messages). Temporarily switched to HTTP mirrors (by manually editing /etc/pacman.d/mirrorlist). This allowed me to complete the update.

Also had issues with missing or expired keys. Doing:

sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

Resolved the issues with the expired / missing keys.

Finally, RTL88x2BU out-of-kernel driver failed to install using the current 6.1 kernel (seems related to https://github.com/morrownr/88x2bu-20210702/issues/165?). So, went back to 5.15 and rebuilt the RTL88x2BU out-of-kernel driver. Strangely, now the rebuilt driver works well on 6.1 kernel, too…

Sorry I don’t get your answer, maybe I want to make sure.
I am running that kernel.
(1) Am I affected of that bug already (I have not updated yet)?
(2) Will I be affected AFTER this update?

Open up a system monitor and see for yourself whether you’ve got one CPU core appearing stuck at 100% — I don’t know what desktop environment you’re using, nor whether you might be using mariadb in another context. :man_shrugging:

The users of KDE Plasma will all be affected — unless they’re still running 5.15 or an earlier kernel — because several components of Plasma rely on mariadb, i.e. kmail, korganizer, and anything else that uses akonadi.

As above. It depends on your desktop environment and/or whether you use mariadb.

1 Like