[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

Была такая же проблема, совет @angel2035 помог, большое ему спасибо)))

I had the same problem, @angel2035’s advice helped, thank you very much)))

Moderator edit: Added English translation via Google Translate

I wanted to bring only a few packages up to date.
As I do it more often.
Unfortunately, the command seems to do nothing more?

$ sudo pamac install --no-upgrade languagetool chromium discord 
Resolving dependencies...
Checking inter-conflicts...

To upgrade (3):
  discord       0.0.27-2          (0.0.27-1)          extra  
  languagetool  6.2-1             (6.1-3)             extra  
  chromium      114.0.5735.198-2  (114.0.5735.198-1)  extra  

Total installed size: 5.5 MB

Apply transaction ? [y/N] y
Transaction successfully finished.

Unfortunately, it does not install anything at all now.
Does anyone have an idea how to do this now?

I’m not sure if this is the proper place, but I’ve found after upgrade a small problem with new pamac GTK4
With the cache cleaner, more precisely. I’ve got it configured to keep 2 versions of packages, and not set the “delete only uninstalled packages”, or whatever the english text is (I’m using Spanish).
So, after upgrading (all was smooth with that), I went to config to delete the coreesponding old packages retained by now. It was OK, showing the XXX packages XXX Gb, etc. Click, and turned into 0, as it should. But now, if I change into keep 1 or 0 versions to keep, it still says there are 0 packages to delete, and that can’t be true, the shoud be several hundreds at least, and more than 8 Gb.
I checked through octopy cache cleaner that there were in place, as should be. And yes, the older than 2 versions were properly deleted, and the rest were kept in place.
So, I’m not sure if it’s working now, and just showing wrongly 0 files to delete when it¡s no true, or if it’s just not working and not deleting. Till new upgrade, I can’t check it.
But at least the counter is not working.

I seem to get an error when attempting to upgrade:

Error: Failed to prepare transaction: target not found: haskell-crypton-connection

Running the solution above didn’t help: (pacman-mirrors || sudo pacman-mirrors --continent; pamac update)

1 Like

Things done:

Saw pamac update notification.
Gone on Manjaro forum announcements, read about this update.
Opened pamac, opened preferences, deleted cache of auto downloaded packages if any and closed pamac.
opened terminal and typed:

 sudo pacman-mirrors --fasttrack 

Opened pamac again and deleted packages cache again if any.
Gone to pamac update and done the update.
Update gone flowless with Manjaro KDE and kernel 6.1 LTS

Sorry for my english.

1 Like

same/similar issue here: ignored message and updated system → stuck at boot “stopping bootsplash after system start up” or something like this. linux62 was installed | bootsplash-systemd | bootsplash-theme-manjaro was installed.
Solved issue:
removed bootsplash* | updated /etc/default/grub | update /etc/mkinitcpio.conf (reverse of: [HowTo] Enable Bootsplash Provided by the kernel)
removed linux62 | removed linux62-nvidia
reboot | installed linux61-nvidia
system up and running again with GUI :slight_smile:

They can go back to the gtk3 version of pamac.
Installing an ugly libadwaita for one application is unacceptable.
pacman -S pamac-gtk3


This is not the worst update ever, because it doesn’t update and therefore destroy anyting. (funny? not really)

But it also does nothing, it even won’t update the firefox+language packages.

The update won’t run, because “some files are missing”. :frowning:

I tried sudo pacman -Syyu but no updates were found whatsoever. And I’m still on systemd 253.4 so I know I haven’t gotten the updates yet…

Edit: resolved itself

After installing gtk3, and removing pamac, the glitches stopped. Thank you!


pacman -S pamac-gtk3
The glitches have stopped

Something of a nasty affecting my Plasma autostarts. Everything that tries to open a window (or otherwise interact with X, such as setxkbmap commands) is failing with the same messages:

Invalid MIT-MAGIC-COOKIE-1 key
Cannot open display ":0.0"

The solution I posted here turns out to be invalid, so I’ve create a support post

Im updated the mirrors and even try to refresh database in the pacman UI and still get also this error :frowning:

Edit: Even in Terminal with pamac update -a i get this error:

==== AUTHENTICATING FOR org.manjaro.pamac.commit ====
Authentication is required to install, update, or remove packages
Authenticating as: Koboldx (koboldx)
https://mirror.alpix.eu/manjaro/stable/community/x86_64/python-filelock-3.12.0-2-any.pkg.tar.zst: Error 404
https://mirror.alpix.eu/manjaro/stable/community/x86_64/i2c-tools-4.3-4-x86_64.pkg.tar.zst: Error 404
https://mirror.alpix.eu/manjaro/stable/extra/x86_64/libadwaita-1:1.3.2-1-x86_64.pkg.tar.zst: Error 404
https://mirror.alpix.eu/manjaro/stable/extra/x86_64/gtk4-1:4.10.3-2-x86_64.pkg.tar.zst: Error 404
https://mirror.alpix.eu/manjaro/stable/community/x86_64/python-filelock-3.12.0-2-any.pkg.tar.zst: Error 404
Error: Failed to commit transaction: failed to retrieve some files

There is no way for me to update.

1 Like

I’ve had similar issue and it’s not the repo that is out of date (I specifically used global repo) and update using pacman (not pamac) worked correctly, while pamac correctly detected the update, but when prompted it went through all the confirmation steps to finally not do anything. It is worth to mention that the packages meant to be updated were 2 libpamac related packages themselves.

I suggest cleaning up before attempting the upgrade.
In my case, I took a few hints from the forum and condensed them into a little script:

if [[ $EUID -ne 0 ]]; then
   echo "This script must be run as root" 
   exit 1
die() {
    local message=$1

    echo "$message" >&2
    exit 1

pacman -Scc || die 'Clearing the cache failed'
pacman-mirrors -c Germany || die 'Updating mirror list for Germany failed'
pacman -Syyu || die 'Update packages from repos failed'
pamac update -a || die 'Updating AUR packages failed'
pacman -Qtdq | pacman -Rns -  || die 'removing unused packages failed'
flatpak uninstall --unused || die 'Cleaning up unused flatpaks failed'
echo "**********"
echo "All updates successfully retrieved"

At least for me it worked flawlessly and after rebooting I just had the notification of a newer kernal and a few flatpak updates…

1 Like

I had this same problem.

Its known that a number of settings in newer pamac have no effect.
Why was it still released as is and without warning?
I dont know … but maybe use pamac-gtk3 for now.


There is a security vulnerability we had to mitigate. A proper fix will come in Mid-August. The issue with updatting is now fixed.

1 Like

i noticed one mirror is gone from the Global ones(can’t remember it’s name ;fosshost?)
also i used to be able to choose between HTTP and HTTPS.

There is only one global host: https://mirrors.manjaro.org/repo/ (from https://repo.manjaro.org/)