[Stable Update] 2023-07-10 - Kernels, Plasma, Gnome, LibreOffice, Pipewire, Mozilla, Wine

Thanks @Kobold for the help, what steps to install lib32-libudev0-shim

You may or may not have disabled the adwaita part.
Such as the Note here:

No steps needed, just install the package with pacman GUI, it was running instantly for me.

Install “lib32-libudev0-shim” version 1-6 which also install “libudev0-shim” version 1-4 btw.

Maybe restart your system and try again, if you have still problems.

The same way you install any package.

Manjaro Wiki - Software Management

Already installed - reinstalled it - no change.

The client still doesn’t work - steam appears to be running - the fossilised background processes are running. Steamhelper process is zombied. The system tray icon is there, and the games run from the start menu.

Then its a different issue. Open a thread if you cant find one matching your problem.

FYI - heres what kobold was initially referring to:

Hm, I did not touch anything in this area. (I installed my host system via architect)
But if you can teach me, how to do this I would apply it the same on my test vm.
So I do not have to use gtk3.


I only could temporary fixed Steam with that install from lib32-libudev0-shim. After i did a system restart, Steam wont no longer start again :worried:

systemd-coredump[3393]: [🡕] Process 3290 (steam) of user 1000 dumped core.
                                                     Stack trace of thread 3344:
                                                     #0  0x00000000f7a3a222 getenv (libc.so.6 + 0x3a222)
                                                     #1  0x00000000f7efca98 XkbUseExtension (libX11.so.6 + 0x98a98)
                                                     #2  0x00000000f7e8c87e XOpenDisplay (libX11.so.6 + 0x2887e)
                                                     #3  0x00000000e489e4be n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamclient.so + 0xa9e4be)
                                                     #4  0x00000000e46c76e5 n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamclient.so + 0x8c76e5)
                                                     #5  0x00000000e46e0b82 n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamclient.so + 0x8e0b82)
                                                     #6  0x00000000e489616e n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamclient.so + 0xa9616e)
                                                     #7  0x00000000e4896ad1 n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamclient.so + 0xa96ad1)
                                                     #8  0x00000000efa1c63e n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/libtier0_s.so + 0x1b63e)
                                                     #9  0x00000000efa1a7a0 n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/libtier0_s.so + 0x197a0)
                                                     #10 0x00000000f7a8721c n/a (libc.so.6 + 0x8721c)
                                                     #11 0x00000000f7b24a9c n/a (libc.so.6 + 0x124a9c)
                                                     Stack trace of thread 3295:
                                                     #0  0x00000000f7fc6549 __kernel_vsyscall (linux-gate.so.1 + 0x549)
                                                     #1  0x00000000f7b25263 epoll_wait (libc.so.6 + 0x125263)
                                                     #2  0x00000000eec838c6 n/a (/home/koboldx/.local/share/Steam/ubuntu12_32/steamui.so + 0x10838c6)
                                                     ELF object binary architecture: Intel 80386
░░ Subject: Process 3290 (steam) dumped core
░░ Defined-By: systemd
░░ Support: https://forum.manjaro.org/c/support
░░ Documentation: man:core(5)
░░ Process 3290 (steam) crashed and dumped core.
░░ This usually indicates a programming error in the crashing program and
░░ should be reported to its vendor as a bug.

Any idea?

Core dump is maybe different from the linked issue.
But did you read that link? How does lib32-libnm fare ?

I just deleted and reinstalled lib32-libudev0-shim and steam works now (temporary again, till next system start).

Do you mean the other solutions?

I didnt try them out yet… Do you mean install lib32-libnm from official repo?

Thats the short and long of it, yes…
(minimum characters achieved)

I have now added an entry to the known issues wiki post above.

1 Like

Здравствуйте, обновился через консоль после команды sudo pacman Syu всё прошло вроде успешно,но после перезагрузки появились ещё обновления,просит править файлы,я ничего не меняю, они не обновляются выдаёт ошибку , не находит чего то там. Пожалуйста помогите. Вот эти–1)ckbcomp 2)pamac-tray-icon-plasma 3)timeshift 4)v86d
Всё это AUR.

Hello, I updated via the console after the sudo pacman Syu command, everything seemed to be successful, but after the reboot, more updates appeared, it asks me to edit the files, I don’t change anything, they don’t update, it gives an error, it doesn’t find something there. Please, help. These are – 1)ckbcomp 2)pamac-tray-icon-plasma 3)timeshift 4)v86d These are all AUR.

Moderator edit: Added English translation via Google Translate


Found the cause, thanks to MrQuest: I had one line in .profile that resulted in non-zero exit code (and that was source ~/.cargo/env).

The logfile was empty for me actually, for whatever reason, and still is… :person_shrugging:

Edit: There’s a bug or two about it, as I guessed there would already be.

“Failed to synchronize databases” constantly, can’t update at all no matter what. Using Konsole, I get 404 error on all packages. What the hell is going on?

I could update my PC but with my Laptop i have exactly the same issue… the only difference on both systems, that i didnt update pamac 2 or 3 days ago where this 3 little pamac updates shows up… did you downloaded this few updates maybe?

Edit: i just did sudo pacman -Syu and it updates now on my Laptop.

Something strange is happening with pamac… All repositories are empty, Most of installed packages has no repository at all. Some packages moved to AUR… I am totally confused.

For anyone having issues with the “failed to synchonize databases” update while trying to using the GUI, i know you want to avoid the terminal like the plague but updating thru the terminal solved my issues… (( sudo pacman -Syu )) I tried everything from switching kernels, to hunting down/deleting problematic pkgs, switching mirros etc but honestly what solved it was updating thru the term. It will give you the same error saying X package is conflicting with X but the terminal will give you a Y/N prompt to force it thru…

I have successfully updated my computer without any issues. I only have a preference issue with Firefox on my hard drive #2
I have two identical hard drives on the same computer.
Hard drive #2 installation date is January 2021.
Hard Drive #2
Firefox 115.0.1 has been installed on both hard drives.
I prefer the way Firefox appears on this hard drive #2

When you open a tab the rest of them fades-out. Therefore you take less chance of making a mistake when you’re working with multiple tabs. It’s easier to see which tab is open.

This hard drive #2 looks like the same as before the update, even though it’s the Firefox 115.0.1. How can I make Firefox to display like my hard drive 2?
Hard drive #1 installation date was in September 2021.


Any idea as how to make Firefox to display similar to my hard drive #2?

Kernel: 6.1.38-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
Desktop: KDE Plasma v: 5.27.6 Distro: Manjaro Linux base: Arch Linux

pamac didn’t recognize many packages, I ran: pamac update --force-refresh and it returns:

Synchronizing package databases...
Synchronizing package databases...
Refreshing core.db...                                                                                                       
Refreshing extra.db...                                                                                                      
Refreshing multilib.db...                                                                                                   
Database file for core does not exist.                                                                                      
Database file for extra does not exist.
Database file for multilib does not exist.
Refreshing core.files...                                                                                                    
Refreshing extra.files...                                                                                                   
Refreshing multilib.files...                                                                                                
Nothing to do.                                                                                                              
Transaction successfully finished.

I can not update or install any AUR Packages via Pamac GUI, I have had to switch to yay to do the updating and rebuilding of packages. I have Cleared Cache, Rebooted, and Used commands to confirm and rebuild mirrors. still no luck. Doesnt matter if I remove a problem AUR from the error it just goes down the line and says this for every package eventually. I when though 1 by 1 to confirm this. (Error: Failed to prepare transaction: Failed to generate ceph-libs-bin information) Replace ceph-libs-bin with any of my other 71 AUR packages that need updating.

1 Like