[Stable Update] 2023-06-04 - Kernels, Gnome 44.1, Plasma 5.27.5, Python 3.11, Toolchain, Firefox

I found myself in the same position.
Disabling gpu acceleration worked as a quick workaround.
But i found another post about the same issue in the arch forum: https://bbs.archlinux.org/viewtopic.php?pid=2098015#p2098015
Doing an:

# rm -rf ~/.config/google-chrome/Default/GPUCache

fixed the problem for me. Now chrome start as usual without any graphics glitches

3 Likes

i’m using plasma and i noticed that the last stable update affected mouse cursor movement speed - this update restored it to what it should be, but i first had to adjust the speed in system settings (no need to enable adaptive speed)

After the update VLC and Smplayer stutter with fullscreen videos.

Same here for Xfce, Monospace Font Selection got reset to “empty”

Why didn’t the new Lutris version make it into this update? I know it landed on testing a few weeks ago.

Its kind of important because of this issue.

Although python311 has not been in the AUR for a few weeks (since Arch upgraded to python 3.11) you can still uninstall it, using you AUR helper or pacman.
You need to uninstall it before starting this system update.

Always read the wiki post at the start of these announcements, before upgrading.
AUR python311 is mentioned in [HowTo] Re-install packages after a Python upgrade (short version)

Thank you very much, this fixed too my issue with Brave. :clap: :clap: :clap:

Best regards!! :grinning: :grinning:

What is the current situation with KiCad?
According to the mirrors, kicad will be updated to 7.0.3-1 but according to the manjaro packages, there is currently no such version for the stable release kicad manjaro package

KiCad 7.0.3 and 7.0.4 have also never been officially launched because they had critical bugs, which were fixed with KiCad 7.0.5.

Like most of our packages, we inherit kicad from Arch. They updated to 7.0.3 > 7.0.4 > 7.0.5. There should be a testing update before the next stable update, so both testing and stable should receive 7.0.5 next.

Got a problem with Evolution after applying this update - Evbolution doesn’t display mail content or header. Neither in preview, nor when opening a mail. Just a blank window.

Packages shows that stable has an older version of evolution. Commits · main · Arch Linux / Packaging / Packages / evolution · GitLab. so maybe that version has known bugs like yours @leftbit

Does starting evolution from the command line print out any info?

There are some folders that can be cleaned / renamed to check if there is an issue with settings or cache.

The user’s data files

$HOME/.local/share/evolution

Various configuration and state files

$HOME/.config/evolution

Account settings

$HOME/.config/evolution/sources

Disposable data caches

$HOME/.cache/evolution

I did the update few minutes ago, everything is OK, no issue at all with dkms modules nor with firefox or with AUR python based app.
Thank you! :kissing_heart:

A post was split to a new topic: Curl 8.1.0-1 is not working with github

A post was split to a new topic: My gnome not work Oh no something wrong!

Same here… Brave is acting weird, it won’t show most buttons online or images associated with buttons.
I’ve tried switching different themes (light / dark, gtk / classic )

Here the fix:

Regards.

So I tried again to update today and it worked fine. Turns out last time I ran pamac remove --orphans and it removed GDM! No wonder graphical login was no longer working! I was more careful to the command output this time:

$ pamac remove --orphans
Preparing...
Checking dependencies...

To remove (31):
  gnome-common           3.18.0-4                                            extra
  gtk-doc                1.33.2-1        (Orphan Of: gnome-common)           extra
  python-anytree         2.8.0-6         (Orphan Of: gnome-common)           extra
  glib2-docs             2.76.2-1        (Orphan Of: gnome-common)           core
  intltool               0.51.0-6        (Orphan Of: gnome-common)           extra
  autoconf-archive       1:2023.02.20-1  (Orphan Of: gnome-common)           community
  autoconf               2.71-4          (Orphan Of: gnome-common)           core
  yelp-tools             42.1-1          (Orphan Of: gnome-common)           extra
  mallard-ducktype       1.0.2-9         (Orphan Of: gnome-common)           extra
  itstool                1:2.0.7-1       (Orphan Of: gnome-common)           extra
  docbook-xsl            1.79.2-7        (Orphan Of: gnome-common)           extra
  docbook-xml            4.5-9           (Orphan Of: gnome-common)           extra
  gdm                    44.1-1                                              extra
  python-html2text       2020.1.16-9                                         community
  debugedit              5.0-5                                               core
  cython                 0.29.34-3                                           community
  libx86                 1.1-8                                               community
  ttf-noto-nerd          3.0.1-1                                             community
  webkit2gtk-5.0         2.38.6-1                                            extra
  gobject-introspection  1.76.1-3                                            extra
  python-mako            1.2.4-3         (Orphan Of: gobject-introspection)  extra
  electron               22.3.3-1                                            community
  uchardet               0.0.8-1                                             extra
  bison                  3.8.2-5                                             core
  pastebinit             1.5.1-1                                             community
  flex                   2.6.4-5                                             core
  m4                     1.4.19-3        (Orphan Of: gnome-common)           core
  asar                   3.2.3-1                                             community
  go                     2:1.20.4-1                                          community
  pkgconf                1.8.1-1                                             core
  make                   4.4.1-2                                             core

Total removed size: 1.5 GB

Apply transaction ? [y/N] 

Transaction cancelled.

For those on GNOME, can you reproduce that ?

No, I have gdm set as explicitly installed. Set gdm to be explicitly installed so you will not have to deal with this again. Pamac (gui) has an option to set it to explicitly installed or pamac install --as-explicit gdm

That’s probably my fault, because I was fiddling with GDM before the update and I may have done a wrong move. FYI the only thing that I remember modifying is the following (yes I saved what I did in a script):

# configure GDM using current user desktop settings
function configure-gdm {
	# copy monitor config (e.g. scaling)
	sudo cp "${HOME}/.config/monitors.xml" /var/lib/gdm/.config/monitors.xml
	# relaunch the command after boot so the modifications survive system updates
	sudo mkdir -p /etc/systemd/system/gdm.service.d/
	echo "[Service]
ExecStartPre=/bin/cp ${HOME}/.config/monitors.xml /var/lib/gdm/.config/monitors.xml" \
	| sudo tee /etc/systemd/system/gdm.service.d/override.conf > /dev/null

	# enable fractional scaling
	sudo -u gdm dbus-launch gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

	# set mouse speed
	SPEED="$(dbus-launch gsettings get org.gnome.desktop.peripherals.mouse speed)"
	sudo -u gdm dbus-launch gsettings set org.gnome.desktop.peripherals.mouse speed "$SPEED"

	# set touchpad speed
	SPEED="$(dbus-launch gsettings get org.gnome.desktop.peripherals.touchpad speed)"
	sudo -u gdm dbus-launch gsettings set org.gnome.desktop.peripherals.touchpad speed "$SPEED"
}
1 Like