[Stable Update] 2023-05-07 - Kernels, KDE Gear 23.04.0, KDE Frameworks 5.105.0, Qt5, Firefox, Thunderbird

Note for those that need PCI passthrough via OVMF with qemu and kernel 6.2 or higher and were following the Arch guide, are now getting errors while running mkinitcpio -P :

==> ERROR: module not found: ‘vfio_virqfd’

==> WARNING: errors were encountered during the build. The image may not be complete.

The guide was updated with the following note:

As of kernel 6.2, the vfio_virqfd functionality has been folded into the base vfio module.

That means, the module ‘vfio_virqfd’ should be removed from /etc/mkinitcpio.conf and mkinitcpio -P rerun.

as another update, just had another crash - more or less same error, but this time with the latest bios (3002) and latest amd-ucode (20230404.2e92a49f-1), but this time it reset and showed the “Hardware Error” log on boot, but today it didnt progress beyond showing “Hardware Error” (so i cannot post the full error after the reset), but the following was the last line in journalctl before the reset happened:

May 11 10:50:12 Meicoo-Manjaro kernel: igc 0000:06:00.0 enp6s0: PCIe link lost, device now detached

enp6s0 is for the build-in ethernet port (not a extra PCI device)

also note that this time it reset just right after boot (before i could even login)

for now i am just gonna revert back to 20230210.bf4115c-1 and ignore updates for amd-ucode

EDIT: the amd-ucode update (20230404.2e92a49f-1) definitely runs more stably on bios version 3002 than 2803 did, but still not fully stable

1 Like

A post was split to a new topic: Libplist-2.0.so.3: cannot open shared object file

It seems I voted “No issues…” to early, because I just noticed that Audacity is broken with this update!
It opens and you can still import then play an audio file, but there is no visible waveform anymore, so there’s no way to edit anything!
Starting it from the terminal, I only see the same 3 error messages about GDK as in this thread Cannot Open Audacity.
As stated there, I deleted the legacy configuration folder ~/.audacity-data/ and Audacity created a new configuration folder ~/.config/audacity/, but that didn’t change a thing.
Didn’t want to mess more with AUR package as what I have to, so I uninstalled it and downloaded the Appimage from Audacity’s website, which works flawlessly…

Audacity v1:3.3.0-1 has a bug in the selection toolbar that causes it to expand and hide the waveform display
What happen to audacity in the new version of 1:3.3.1-1?

A new, working version v1:3.3.2-1 was released in testing branch yesterday (2023-05-11) and should be released to stable branch soon

1 Like

13 posts were split to a new topic: Skanpage: Failed to open selected device

I do not even have zfs installed… do I have to worry about the update or I have to install it before update?

Shotwell crashes after update. Seems to be an issue with settings. I’ve seen statements that shotwell is deprecated but it works well enough for me and I don’t want to lose all my photo metadata.

$ shotwell &
[1] 4763
** Message: 20:19:29.805: main.vala:440: Starting session with system profile

(shotwell:4763): GLib-GIO-ERROR **: 20:19:30.110: Settings schema ‘org.gnome.shotwell.plugins.enable-state’ does not contain a key named ‘publishing-facebook’

[1]+ Trace/breakpoint trap (core dumped) shotwell

Shotwell works for me and is under active development.

1 Like

I have random (rare) blackscreen (monitor lost signal) issue when im on the KDE Desktop and when im afk from my PC.

Mai 11 02:25:15 koboldx-z170 kernel: [drm:drm_new_set_master] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership
Mai 11 02:26:26 koboldx-z170 kernel: [drm:drm_new_set_master] *ERROR* [nvidia-drm] [GPU ID 0x00000100] Failed to grab modeset ownership

This issue still only fixed with the workaround, that possible gives me today the blackscreen issue.

Please help me out in my Topic:

After the upgrade a login on the console would produce a coredump of login:

systemd-coredump[6476]: Process 6473 (login) of user *redacted* dumped core.

I use ecryptfs and had modified my /etc/pam.d/system-auth accordingly, I noticed a system-auth.pacnew dating back to 2022, so i guess the file wasn’t updates as intended during the update due to my changes.

After restoring system-auth to system-auth.pacnew (without my patches) and updating pambase and systemd I re-applied my patches and everything worked fine. I diffed the old and the new file:

auth       [success=2 default=ignore]  pam_unix.so          try_first_pass nullok
-auth      [success=1 default=ignore]  pam_systemd_home.so


-auth      [success=2 default=ignore]  pam_systemd_home.so
auth       [success=1 default=bad]     pam_unix.so          try_first_pass nullok

and the line

-session   optional                    pam_systemd_home.so

got added.

Thanks. It does seem to be something specific to my user profile: shotwell works fine if I log in under a different user. I’ve no idea how to track down the issue from here. Maybe I can try resetting all the shotwell preferences to defaults.

I updated the BIOS on my two latest PC’s, both AMD Ryzen-based and then did the Stable 2023-05-07 update, including the amd-ucode update. Both PCs are running without problems on kernel 6.1.26 LTS.

Thanks for bringing this amd-ucode issue up. I had originally planned to ignore BIOS updates because one of the PCs can only be updated from within Windows (Lenovo offers ONLY Windows-based BIOS updates) and I refuse to install Windows. But reading past posts by @bogdancovaciu and @straycat tipped me off to using Hiren’s BootCD PE to do the BIOS update. Easy peasy!!

You made a mistake. You mentioned at the start that Firefox is at version 112.0.2. But in the middle, you said that it is at version 112.0.1

5 posts were split to a new topic: NVIDIA high refresh issues

Had the same issue with cryptsetup version 2.6.1-3.2. I can confirm downgrading to 2.6.1-1 solves the problem and unlocking works again!

I pushed some kernels.


2 posts were split to a new topic: The USB-C ports on my Dell monitor aren’t working anymore

I guess that they solved the “zfs” issue…

What zfs issue?