[Stable Update] 2023-05-07 - Kernels, KDE Gear 23.04.0, KDE Frameworks 5.105.0, Qt5, Firefox, Thunderbird

I don’t have any specific posts, quotes or anything like that. Maybe I’m just more careful since I’ve used Ubuntu in the past, so I know it’s not Windows. And I prefer the CLI for stuff like this, so I might just be more careful, I don’t know. :man_shrugging:

Indeed. But that won’t stop me from making a recommendation. And I’ve had this conversation before, that’s why I put that disclaimer along with my recommendation.

You’ll notice I don’t answer to support requests regarding anything to do with sound, since I can’t use sound, so don’t have experience with it. I don’t wish to make people scared about pacman, or Linux, I just make my recommendations based on personal experience and conviction.

And I gave my reasons already.

1 Like

I’m confused now.

Does pacman also check the AUR for updates of packages that i installed from it ? Or does only Pacmac do that?

pamac does both. It also has both a cli commands and a GUI.
pacman is for the repos and local packages and does not have a GUI… to use the AUR along with pacman you can do so by hand or add an aur helper like yay or paru.

Ok, so i should start using pacmac from CLI then instead of pacman. I only have 2 apps from the AUR, but keeping those up to date is important, so i should at least know the CLI commands for pacmac.

Is there an equivalent of

sudo pacman-mirrors -f && sudo pacman -Syyu

For pacmac?

I’m using the Manjaro GUI app for updates in general and never had problems. Just wanna know the command in case sth breaks or i need to fix stuff via terminal.


Taking into consideration pacmans design to not bundle AUR updates or handle them directly, the translation is:

sudo pacman-mirrors -f && pamac upgrade --force-refresh --no-aur

(the pacman-mirrors command doesnt change because its its own script, written when pacman was still the default, and given its proper status as defacto end-all package manager [and because shiny-mirrors didnt go anywhere])

Maybe this is a good place to mention that flipside of the ‘normal’ syntax … its definitely longer. :wink:

The problem seems to be caused by an incompatible version of the Qt libraries:

$ /usr/lib/kscreenlocker_greet --testing
Fontconfig error: "/etc/fonts/local.conf", line 1: not well-formed (invalid token)
kf.kirigami: Failed to find a Kirigami platform plugin
Cannot mix incompatible Qt library (5.15.8) with this library (5.15.9)
fish: Job 1, '/usr/lib/kscreenlocker_greet --…' terminated by signal SIGABRT (Abort)

And if i want to update everything including the stuff from AUR, i just remove the --no-aur ?

Also pamac update is shorter then pamac upgrade and does the same :stuck_out_tongue:

Ah true.
But whether 28 or 29 digits … still more than 17.
And yes, of course drop the no aur and you can add a -a flag to have it combined as usual.
Or keep it split like the pacmyn do and follow the above with

pamac update -a

That way its forced to follow the normal procedure of update repo packages first, then update aur.
(which currently is one of the quirks not working out well on some systems)

1 Like

That is very good to know. Thanks for taking the time to explain that!

So the “correct” way would be :

sudo pacman-mirrors -f

Followed by

pamac update -a

Without the --force-refresh?

the force-refresh is the same as the 2 y’s in the pacman command.
It was normally required after switching mirrors.
I have found in recent times pacman usually doesnt require it (Syu works fine and will update changes) … but I would not know about pamac in the case of this specific function … so going by the old rules you should always include ‘force-refresh’ after touching mirrors.

So to update both repo and aur packages at the same time and be sure about the mirrors;

sudo pacman-mirrors -f && pamac update --force-refresh -a

( I guess the order matters for some reason so force-refresh goes before the -a :person_shrugging: )

PS sorry mods … it should probably be split at this point but I cant do it :wink:


sudo pacman-mirrors --fasttrack

Followed by

pamac update --force-refresh --aur

Got it.

And yeah sorry mods … i derailed this topic a bit, but i was very curious. Sorry.

1 Like

xscreensaver doesn’t work. I uninstalled it, intending to reinstall, but the reinstall wanted a whole list of gnome-related dependencies, so I cancelled. I am running KDE Plasma. Also, I am now running the 6.1 kernel, where before I was running 5.15. I did not make that change.

I just pushed python-astroid 2.15.4-1.0, please test.

1 Like

super. thank you very much :hugs:

Note for those that need PCI passthrough via OVMF with qemu and kernel 6.2 or higher and were following the Arch guide, are now getting errors while running mkinitcpio -P :

==> ERROR: module not found: ‘vfio_virqfd’

==> WARNING: errors were encountered during the build. The image may not be complete.

The guide was updated with the following note:

As of kernel 6.2, the vfio_virqfd functionality has been folded into the base vfio module.

That means, the module ‘vfio_virqfd’ should be removed from /etc/mkinitcpio.conf and mkinitcpio -P rerun.

as another update, just had another crash - more or less same error, but this time with the latest bios (3002) and latest amd-ucode (20230404.2e92a49f-1), but this time it reset and showed the “Hardware Error” log on boot, but today it didnt progress beyond showing “Hardware Error” (so i cannot post the full error after the reset), but the following was the last line in journalctl before the reset happened:

May 11 10:50:12 Meicoo-Manjaro kernel: igc 0000:06:00.0 enp6s0: PCIe link lost, device now detached

enp6s0 is for the build-in ethernet port (not a extra PCI device)

also note that this time it reset just right after boot (before i could even login)

for now i am just gonna revert back to 20230210.bf4115c-1 and ignore updates for amd-ucode

EDIT: the amd-ucode update (20230404.2e92a49f-1) definitely runs more stably on bios version 3002 than 2803 did, but still not fully stable

1 Like

A post was split to a new topic: Libplist-2.0.so.3: cannot open shared object file

It seems I voted “No issues…” to early, because I just noticed that Audacity is broken with this update!
It opens and you can still import then play an audio file, but there is no visible waveform anymore, so there’s no way to edit anything!
Starting it from the terminal, I only see the same 3 error messages about GDK as in this thread Cannot Open Audacity.
As stated there, I deleted the legacy configuration folder ~/.audacity-data/ and Audacity created a new configuration folder ~/.config/audacity/, but that didn’t change a thing.
Didn’t want to mess more with AUR package as what I have to, so I uninstalled it and downloaded the Appimage from Audacity’s website, which works flawlessly…

Audacity v1:3.3.0-1 has a bug in the selection toolbar that causes it to expand and hide the waveform display
What happen to audacity in the new version of 1:3.3.1-1?

A new, working version v1:3.3.2-1 was released in testing branch yesterday (2023-05-11) and should be released to stable branch soon

1 Like

13 posts were split to a new topic: Skanpage: Failed to open selected device