[Stable Update] 2023-04-06 - Kernels, Systemd, Nextcloud 26, Linux-Firmware, LibreOffice 7.5.2

Just plain lucky then…

1 Like

there has been few developments since of late, requiring manual intervention in some cases.


No task bar after each reboot and the desktop short cut are upside down.
It happened in the past, those bugs are back.

[nls@lap ~]$ neofetch
██████████████████  ████████   nls@lap 
██████████████████  ████████   ------- 
██████████████████  ████████   OS: Manjaro Linux x86_64 
██████████████████  ████████   Host: NJ50_70CU 
████████            ████████   Kernel: 6.1.22-1-MANJARO 
████████  ████████  ████████   Uptime: 3 mins 
████████  ████████  ████████   Packages: 1763 (pacman) 
████████  ████████  ████████   Shell: bash 5.1.16 
████████  ████████  ████████   Resolution: 1920x1080 
████████  ████████  ████████   DE: Plasma 5.27.3 
████████  ████████  ████████   WM: KWin 
████████  ████████  ████████   WM Theme: plastik 
████████  ████████  ████████   Theme: Breath Light [Plasma], Breeze [GTK2/3] 
████████  ████████  ████████   Icons: oxygen [Plasma], oxygen [GTK2/3] 
                               Terminal: konsole 
                               CPU: Intel i7-10510U (8) @ 4.900GHz 
                               GPU: Intel CometLake-U GT2 [UHD Graphics] 
                               Memory: 3328MiB / 7638MiB 


[nls@lap ~]$ 

edit : I did a fresh install, it solve some issues :slight_smile:

I’m also getting this not such cryptodisk found line (but booting with no problem for now). In my case is most probably triggered for I’m keeping the systemd 251 till 252 is out (I don’t want to loose the timed suspend-then-hibernate option that was removed with 252, and is planned again for 253). So, I guess that 252 is coming not much later, and I can live with that for now.

Just, I saw the information about not using dashes for the UUID for LUKS devices in grub… Should then everyone change that line yet, wait if it’s working (with just the line showed), or what is the recommended procedure? Perhaps just try to modify the line directly in grub when booting, to check if it makes any difference, before changing anything permanently?


EDIT: after trying changing manually from grub menu to confirm it works properly, just taking out (manually) the dashes from the cryptomount -u lines in /boot/grub/grub.config , as suggested, avoids the (no so) annoying prompt. So, by now it’s an easy solution, to be applied whenever grub is updated; and probably future upgrades will solve it completely. Thanks again!

ASRock X670E Steel Legend
AMD 7900X3D
Using iGPU with Open Source Drivers
Kernel linux62 6.2.9
2 Monitors

When I login to my desktop I have a white screen
linux61 6.1.22 works fine

After this update, it might have even been the 23.03.31 one, Gwenview hangs when playing an .mp4 file and after it finishes, you go to the next item, be that a pic or vid. You see the little wheel spinning in the center and can not but force the application quit.
There is no such bug when the video is still playing or when you move backwards. Also, changing to the Browse overview in Gwenview once the video has finished playing hangs the application.
There was a similar bug some years ago, fixed without confirmation, which might have been Qt related: show_bug.cgi?id=344809
The bug didn’t exist before the 2 most recent update cycles.
Reinstalling Gwenview, rebooting, to no avail.

I applied the update, but the nag screen persists unfortunately. I’ll post an update on the main thread.

Thanks for the explanations!

UPDATE: @brn is reporting here that removing the dash separators in grub.cfg has removed the nag screen issue: applying this fix solved the issue in my case too!

1 Like

I am running a Ivy Bridge CPU and KDE Wayland. I saw the comment about adding LIBVA_DRI3_DISABLE=1 to /etc/environment, actually added it with a “#” in front so it would be inactive but I wouldn’t have to re-research when I forgot about it.

Are there any other ill effects to the overall system by adding that variable? To me, it sounded like a drastic change to make to re-enable HW acceleration for Chromium where maybe just a bit of patience would make it work again. I mostly use Firefox anyhow. :slight_smile:

AFAIK this fix is intended for X11 and not wayland. from the little i do know this is due to libva-intel-driver not supporting DRI3 for pre-haswell iGPUs, and thus breaking functionality since libva 2.17. on X11 it is not as much of drastic change to get things going because it is afterall due to un-supported functionality of the intel driver. i’m afraid waiting will do no good, libva-intel-driver dev team is supposedly very inactive and since we are talking legacy HW here chances of them supporting DRI3 is very slim.

1 Like

After locking pc and unlocking it after a couple of hours, either secondary or both screens are black. KDE plasma seems like its dead. No taskbar, background, right click does nothing. Reboot fixes it, but this is annoying. Any ideas what I could do? Before the 30.3.2023 update it never occurred. Now it occurs daily.
Found an old issue, similar to this found here. Mine is the same, but occurs sometimes when I lock and unlock pc. Never on restart. At least not yet.

1 Like

Nvidia high refresh being unable to be set and the monitor generally feeling like it’s burning my eyes is still an instant issue (like it was last update) after applying previous update and then this update over it.

Rolling the system back again, not even trying another update till there’s a really good reason to believe that I can update without experiencing eye pain pretty much instantly.

Yubico Authenticator doesn’t show the codes, again . The same problem was in November 2022.
Downgrade yubikey-manager to 14.09.-3 and is works fine.
Obviously update of yubikey-manager took place in previous system update.

1 Like

Raybans…? :wink:

Why is my hostname changed to “manjaro” after upgrading to this release?

This update breaks the inclusion of .eps pictures when using xelatex in TeXLive (texlive-core 2023.66587-1), which is a pretty critical bug as it completely prevents compilation of affected TeX documents. The problem seems to be inherited from Arch (see Arch bug FS#78098 - [texlive-core] /usr/bin/rungs links to a non-existing file). In the Arch repos, it is already fixed in texlive-core 2023.66587-2, so hopefully this package version can be included in Manjaro soon.

A temporary solution is to fix the link manually:

sudo ln -sf /usr/share/texmf-dist/scripts/texlive/rungs.lua /usr/bin/rungs
1 Like

I sort of figured out the gfx_0.0.0 ring timeout error I was getting. It seems to be due to something that was introduced from Mesa 22.3 to Mesa 23.0. Downgrading the package fixed the issue for now. Might be this: Dirt Rally amdgpu ring gfx_0.0.0 timeout with mesa-23 (#8432) · Issues · Mesa / mesa · GitLab, although I get it with Blender.

My old question about Bluetooth device not obeying volume control was weird; my Sony WH-1000XM5 worked fine the whole time, Harman Kardon Onyx Studio 7 didn’t, with or without EasyEffects…

Well, either this or the previous stable release fixed it again :slight_smile: Thanks for tips anyway!

A post was split to a new topic: Screen flickering and system crash playing Doom Eternal