[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

search this topic for xsettingsd


Changing screen scale (on Wayland session) and restarting after that, causes KDE to freeze (immediately after entering the password).

Thanks, that was it!

II don’t think it’s actually about the 144hz at all… I knew I didn’t remember 144 being so bad, and I just realised the photo editing profile I did on this monitor IS 144hz (almost perfect gamma accuracy at 144), because I just used it and I felt like it’s choppy and horrible, but it wasn’t painful, and I didn’t get a headache of any sort in a couple of hours editing.

Then I was removing some stuff from the system and accidentally did full update again… And again it felt literally painful just in the time it took to roll the system back.

There is something really wrong with those 530 Nvidia drivers, or at least something I’m super sensitive to. I’m didn’t seeing any clear issue like black flickering etc, but it just feels like the screen is cutting into my eyes straight after update and I feel headaches stuff coming on.

No idea what is going on there, it’s not the refesh rate per-se that’s causing my issue. It feels kinda like how I feel almost instantly with backlight strobing or pwm in the 120-360hz range, I did check, none of that motion clarity etc stuff was on.

After I downloaded the update and rebooted, I was stuck on a Black Screen with Manjaro logo. Pressed on ESC gave me some messages of stopped processes. The latest was “[OK] Stopped pamac daemon”.
Wait 15 minutes and nothing, so I rebooted pressing the reboot button.
After start, everything was Ok.

Even though you haven’t experienced the top-third black flicker, it might be worth a shot setting nvidia_drm.modeset=1 as per the solution here:

Since it seems like the new driver doesn’t play that well without it set, could very well be a related issue.

I got the information from nvidias website.

The ‘Supported Products’ tab only shows the 4090 GPU from the 4000-series as supported. It is of course possible that they have the wrong info on their webpage.

Looking at the exact link you sent under the “Supported Products” tab I currently see everything from the 4000 series down to the 700 series…

Maybe you have an old cached version of the page or looked before they fixed it, but looks fine to me.

This is the link to the ‘Production’ driver…

This is the link to the ‘New Feature’ driver…

Do you see the same supported products for the 4000-series cards?

Ah, I misinterpreted what you meant. I understand now. Yes, looks like the 4080 and 4070 Ti cards are missing from the list along with all the 4000 series laptop GPUs.

I was using video-hybrid-amd-nvidia-470xx-prime instead of video-hybrid-amd-nvidia-prime ever since it came out simply because I get better FPS on my games. But the latest update borked vulkan somehow and couldn’t run the games. So I tried installing video-hybrid-amd-nvidia-prime and the games worked fine again, but I was still getting almost half the FPS I got from 470xx. So I removed it and tried to reinstall 470xx and I get this error:

> Installing video-hybrid-amd-nvidia-470xx-prime...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/db/pci/graphic_drivers/hybrid-amd-nvidia-470xx-prime/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
:: Synchronizing package databases...
 core downloading...
 extra downloading...
 community downloading...
 multilib downloading...
error: target not found: linux63-nvidia-470xx
Error: pacman failed!
Error: script failed!

After installing this update, having a problem accessing Display related options in the Systems Setting app. When clicking on Systems Setting / Display and Monitor, the Display Configuration window briefly appears for a few seconds, then that window closes. Same window closing issue if I select Appearance / Plasma Style or Colors or Fonts.

Per some of the other posts here, I installed Xsettingsd, but that did not fix this issue.

Here is the output of my inxi -F:

  Host: go-manjaro-kde Kernel: 6.1.21-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.3 Distro: Manjaro Linux
  Type: Laptop System: Dell product: XPS 15 9560 v: N/A
    serial: <superuser required>
  Mobo: Dell model: 05FFDN v: A00 serial: <superuser required> UEFI: Dell
    v: 1.24.0 date: 08/10/2021
  ID-1: BAT0 charge: 88.1 Wh (100.0%) condition: 88.1/97.0 Wh (90.8%)
  Info: quad core model: Intel Core i7-7700HQ bits: 64 type: MT MCP cache:
    L2: 1024 KiB
  Speed (MHz): avg: 2087 min/max: 800/3800 cores: 1: 2800 2: 2800 3: 900
    4: 2800 5: 900 6: 900 7: 2800 8: 2800
  Device-1: Intel HD Graphics 630 driver: i915 v: kernel
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] driver: N/A
  Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.0 driver: X:
    loaded: modesetting dri: iris gpu: i915 resolution: 1: 3840x2160~60Hz
    2: 2880x1620~60Hz
  API: OpenGL v: 4.6 Mesa 23.0.1 renderer: Mesa Intel HD Graphics 630 (KBL
  Device-1: Intel CM238 HD Audio driver: snd_hda_intel
  API: ALSA v: k6.1.21-1-MANJARO status: kernel-api
  Server-1: PulseAudio v: 16.1 status: active
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    driver: ath10k_pci
  IF: wlp2s0 state: up mac: 9c:b6:d0:d8:4c:d7
  IF-ID-1: ipv6leakintrf0 state: unknown speed: N/A duplex: N/A
    mac: 16:4d:5b:64:0c:b5
  IF-ID-2: proton0 state: unknown speed: 10 Mbps duplex: full mac: N/A
  Device-1: Qualcomm Atheros type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 413.24 GiB (43.3%)
  ID-1: /dev/nvme0n1 vendor: Samsung model: PM961 NVMe 1024GB
    size: 953.87 GiB
  ID-1: / size: 58.19 GiB used: 32.35 GiB (55.6%) fs: ext4 dev: /dev/nvme0n1p7
  ID-2: /boot/efi size: 511.9 MiB used: 9.2 MiB (1.8%) fs: vfat
    dev: /dev/nvme0n1p5
  ID-3: /home size: 224.52 GiB used: 89.05 GiB (39.7%) fs: ext4
    dev: /dev/nvme0n1p8
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p6
  System Temperatures: cpu: 52.0 C pch: 65.5 C mobo: 51.0 C
  Fan Speeds (RPM): cpu: 2512 fan-2: 2517
  Processes: 269 Uptime: 13m Memory: 31.08 GiB used: 5.61 GiB (18.1%)
  Shell: Zsh inxi: 3.3.26

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

3 posts were split to a new topic: Ttf-noto-nerd: failed to commit transaction (conflicting files)

A post was merged into an existing topic: Ttf-noto-nerd: failed to commit transaction (conflicting files)

My GNOME Settings > About panel shows the current Gnome version as 43.4. Meanwhile, Packages shows the current version of the gnome-desktop package in stable as 1:43.2-1. So which is it? I’m trying to troubleshoot an issue on another forum and I want to be able to tell them which versions of stuff I’m running with a bit of confidence.

Hi there.

I’m wondering if it might be worth offering a choice of full disk vs root disk encryption in the installer. I’m running Arch (I used “archinstall” script" on an old laptop with Xfce, Grub & partial encryption & am not having any issues. Given that a significant number of people will want a level of encryption on their notebook, I think it’s worth considering.

Thanks team & everyone that tests it for the rest of us. More power to you all. Ruziel :slight_smile:

1 Like

And I think I found a bug with the new KDE Plasma, related to multi-monitor support. The Move Window KWin script broke. Can someone please point me to where I should report it to KDE? (Bug description here.)

It is fairly simple to do already

Updated and the desktop and all icons vanished and no app icon runs. Looking at it right now.
I cannot use the command prompt but I have Yakuake. Through this I looked at the command “xfdesktop” which had an error returned on gtk-appmenu-module. I use packman to install this module but it just chained into another error so I reversed change.

Through Yakquake I can launch programs just I have an un-usable desktop/workspace.

Note:- All icons even Manjaro icons do not work I seem to only have the one app Yakuake that works.

Any ideas would be appreciated.

[edit] I installed the gtk-appmenu-module and proceeded on but it leads to another error.
command xfdesktop - Failed to connect to session manager: Failed to connect to the session manager: SESSION_MANAGER environment variable not defined.

A post was split to a new topic: Input delay with external monitor connected via DisplayPort