[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

Three updated pacnews: grub.pacnew, pamac.conf.pacnew, pamac.conf.pacnew. Be careful if/when you deal with them. I know from personal experience in another update. :wink:

I have one problem with this new update: I cannot log into Google from Gnome Online Accounts any more. The login-screen simply freezes. Evolution - trying to achieve the same - complains, that the Oauth2 identification does not work. Does anybody here have a fix for that? This is a problem for my business life…

Since update im experience a very short black flickering, even open kate or starting terminal, it shows a strange behavior.

After installing nvidia-settings (i have a 2080Ti) and after a restart it got it reduced a little.

But i just see it flickers again when i openend Steam or right now in Firefox, while i write this message.

I also created a Topic in this Forum and in the nvidia Forum:

EDIT2: Problem is solved, you can find the original answer from dbrhks in the nvidia Forum but @belyash created a little instruction that explains it better, in our Forum:


This has confused me with other updates as well. When I attempt to apply the update listed today (by clicking the icon and it launches Pamac), some 600 of them, when one fails to find dependencies it just stops.

How do you tell it to go to the next and continue?

Cargo update failed

── 21:39:03 - Cargo ───────────────────────────────────────────────────────────
    Polling registry 'https://index.crates.io/'.
Failed to update index repository crates-io: package FileSorterX doesn't exist: HTTP 404.
cargo failed: 
   0: Command failed: `/usr/bin/cargo-install-update install-update --git --all`
   1: `/usr/bin/cargo-install-update` failed: exit status: 2


Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.

During Topgrade. I tried Topgrade because Discover is borked - it takes 20 seconds before painting a window, and complains no metadata URIs for vendor-directory

After updating, I’m unable to boot because it cannot find the specified cryptdisk. I verified on a live USB from last week that the cryptdisk didn’t change UUID and is mountable. Luckily I was able to revert to an earlier BTRFS snapshot. I did attempt the update again and had the same problem the second time as well (with the same solution). Bummer, cuz I wanted that Plasma 5.27 hotness. I may take a backup and reinstall and go straight to updates before restoring anything to see what happens.

Anybody else having this issue?

tuxedo infinitybook pro 16 - gen 7
3050 Ti

ETA: Can confirm solution described here ([Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #50 by Skunkie) addressed this for me.

1 Like

Here’s what I would try:

set pamac to ignore the problem package and restart the updates:

sudo pamac update --ignore package-name

It should then update the remaining packages.
After completion, try updating the ignored package separately.

Fixed with libxnvctrl 470xx-470.182.03-3.

1 Like

That’s a royal PITA, there appear to be hundreds to ignore…

When rebooting the computer, instead of ending up in grub/manjaro, I ended up in refind. However, no options were offered there (white background with the refind logo, no operating elements)

I had to reboot again into UEFI to change the boot order back. After that grub/manjaro started again.

Background: I once tried to install refind, but was unsuccessful at the time. The refind.efi -corpse- is still in the EFI partition and seems to got bumped to 1. place in boot-order.

After this update I got error encoding video with hevc_nvenc codec on Nvidia GTX1080Ti card (Pascal architecture). The error was: “hevc_nvenc @ 0x55629e85a9c0] B frames as references are not supported”. Workaround for me is to encode with ffmpeg parameter “-b_ref_mode 0” (b_ref_mode=0 for kdenlive). Befor the update there was no errors. Any suggestions about the issue?

1 Like

I got used to call WIN + pamac + Enter to get into the software center. This no longer works after the update, as pamac-manager seems to be removed from the listed programs.

Workaround: call pamac-manager directly from the terminal.

Almost everything went smoothly, but somehow the inferiors panel height reset to 50 and got tiny icons in some title-bars alike the system updater.

1 Like

I had the disc encryption issue described here [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #50 by Skunkie and the solution worked for me.

The same with 1660S.
Xorg, gnome.

Well, that was totally unrewarding.

I started applying the updates one by one because there were so many unresolved deps.

Now I can’t launch pamac or firefox, or the app launcher.

Guess it’s time for a fresh install. :roll_eyes:

1 Like

After the restart I felt like my eyes want to bleed the moment I moved my mouse, quickly realised I’m stuck in 144hz mode.

I’ve installed nvidia-settings, I’ve tried setting the resolution to 1920x1080 manually, and trying to set the refresh rate manually, but I see no 280hz option (or 240).

I didn’t have to configure it previously, it just automatically detected the 280hz settings. I have tried turning the OC on and off on my monitor and changing profiles etc.

The monitor is an Asus 259QM.

I’ve tried the 6.1 kernel which I was using previously and the 6.2

Please help, this actually hurts my head, it’s like every change is burning and movement is burning my eyes. (I had headaches constantly from fairly light computer use before this monitor, but this feels even worse than I remember). Yes I’ve checked and strobing/pwm is not on, that’s not what’s causing the pain, plus I’d have a migrane in the time it took me to type this if it was on.

Update: tried a long shot of starting up Overwatch 2 and seeing if it somehow tricked everything into 280hz. It didn’t. I’m going to take a break now, starting to feel a headache coming on already, using NON-FREE nvidia drivers.

99% of world’s population does not even have 144hz and you get migraines unless you have 280hz? jeez.

Anyhow, what DE are you using? Try setting the refresh rate from the system settings, not nvidia control panel.

Solved it for me too

Quick question concerning ZFS compatibility and linux 6.2.8.
Apparently backported bug fixes to linux 6.2.8 introduced incompatibility with zfs 2.1.9 as detailed in:

It appears a patch was generated correcting the issue

This has been applied to linux modules extra as of approximately 8 hours ago on gitlab
zfs 2.1.9-10

Checking the package versions for linux6.2-zfs from extra lists 2.1.9-9 as the latestversion on all manjaro variants, stable, testing and unstable

Is there any reason the latest extra module zfs version is not included in any manjaro variant?

Given that I’m depending on zfs and am currently using linux6.2, should I avoid this particular stable update as I’m not interested in reverting to linux6.1?
Or should I manually determine the means to checkout, build and apply the 2.1.9-10 zfs module myself?