[Stable Update] 2023-03-31 - Kernels, Plasma 5.27 LTS, Pamac, Phosh, Mesa, LibreOffice

This helped in resolving the issue.

1 Like

2 posts were split to a new topic: Intiramfs unpacking failed: invalid magic as start of compressed


I have the same problem kernel 5.4

Some Qt apps got lost after the update (no such file or directory), PlayStation 2 Emulator fully unusable now from the manager (cannot install any AUR of it and Flatpak version cannot detect any other disks or games)… Well, reinstalling the apps and using official AppImage of PCSX2 solved these problems, but one I couldn’t fix:

Cannot start any OBS version (for the previous versions is 'no such file or directory' and impossible to run directly, and 'core dumped' for the latest one):

details from terminal

It also says “libDeckLinkAPI.so: no such file or directory” at one line down.

debug: Found portal inhibitor
debug: Attempted path: share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/en-US.ini
debug: Attempted path: share/obs/obs-studio/locale.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale.ini
debug: Attempted path: share/obs/obs-studio/locale/ru-RU.ini
debug: Attempted path: /usr/share/obs/obs-studio/locale/ru-RU.ini
info: Using preferred locale 'ru-RU'
debug: Attempted path: share/obs/obs-studio/themes/Dark.qss
debug: Attempted path: /usr/share/obs/obs-studio/themes/Dark.qss
info: Using EGL/X11
info: CPU Name: Intel(R) Core(TM) i5-3470 CPU @ 3.20GHz
info: CPU Speed: 1600.000MHz
info: Physical Cores: 4, Logical Cores: 4
info: Physical Memory: 7885MB Total, 630MB Free
info: Kernel Version: Linux 5.15.104-2-MANJARO
info: Distribution: "Manjaro Linux" Unknown
info: Session Type: x11
info: Window System: X11.0, Vendor: The X.Org Foundation, Version: 1.21.1
info: Qt Version: 6.4.3 (runtime), 6.4.2 (compiled)
info: Portable mode: false
qt.core.qmetaobject.connectslotsbyname: QMetaObject::connectSlotsByName: No matching signal for on_tbar_position_valueChanged(int)
info: OBS 29.0.2-2 (linux)
info: ---------------------------------
info: ---------------------------------
info: audio settings reset:
        samples per sec: 48000
        speakers:        2
        max buffering:   960 milliseconds
        buffering type:  dynamically increasing
info: ---------------------------------
info: Initializing OpenGL...
info: Loading up OpenGL on adapter NVIDIA Corporation NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
info: OpenGL loaded successfully, version 3.3.0 NVIDIA 530.41.03, shading language 3.30 NVIDIA via Cg compiler
info: ---------------------------------
info: video settings reset:
        base resolution:   1920x1080
        output resolution: 1920x1080
        downscale filter:  Bicubic
        fps:               48/1
        format:            NV12
        YUV mode:          Rec. 709/Partial
info: NV12 texture support not available
info: P010 texture support not available
info: Audio monitoring device:
        name: По умолчанию
        id: default
info: ---------------------------------
warning: Failed to load 'en-US' text for module: 'decklink-captions.so'
warning: Failed to load 'en-US' text for module: 'decklink-output-ui.so'
libDeckLinkAPI.so: невозможно открыть разделяемый объектный файл: Нет такого файла или каталога
warning: A DeckLink iterator could not be created.  The DeckLink drivers may not be installed
warning: Failed to initialize module 'decklink.so'
info: [pipewire] Available captures:
info: [pipewire]     - Desktop capture
info: [pipewire]     - Window capture
info: NVENC supported
zsh: segmentation fault (core dumped)  obs

Phew I had a little adventure after upgrading: I started the upgrade (on Manjaro Gnome) and went to have breakfast. When I came back, my computer had gone into auto-suspend due to inactivity. I woke it, but the lock screen did not work properly: I could not type anything into the password field. Whenever I typed anything, it immediately disappeared and greyed out the input field. So I went to another TTY and checked the pacman-log. It said “transaction failed” in the end. So I decided to do a reboot. That was a bad Idea :sweat_smile:
I ended up in partial upgraded state without any working kernel and without working pacman and pamac. My Manjaro boot stick came to the rescue and with pacstrap I managed to reinstall pacman. Then I chrooted into the system and did the full upgrade again, this time without errors. I rebooted and tadaaa the kernel worked again, but only brought me to the text input prompt. Somehow gdm got uninstalled in the process. Reinstalled GDM, rebooted and here I am typing this report. I definitely learned a few new Linux-rescue-skills today :smiley:


Another KDE update, another few minutes of my life wasted because migrating window size and position settings for their own built-in apps is harder than rocket science apparently.

This is on a single monitor system using the default Breath theme so it’s not like there’s any weird customization or multi-monitor edge cases here. And it’s only the built-in KDE apps (Dolphin, Konsole, Kate, KSystemLog, etc) that are affected - Firefox, Thunderbird, Code OSS, Gimp, and everything else remembered their window layout just fine.


1 Like

This is the known issue. Auto-suspend broke your system during kernel upgrade. I recommend disabling auto-suspend during upgrade.

Members can read the thread:

1 Like

Yes I’ll definitely do that from now on. It would be a nice feature if pamac could disable autosuspend automatically while transactions are running.


Same here - I had to resize, reposition many windows - feasible, but definitely quite annoying.


I just tried to change the profile account picture but it simply doesn’t seem to work. I tried in ‘Settings’ as well ‘Manjaro-Settings’ but both just don’t take the picture (no error messages popping up).

1 Like

Three updated pacnews: grub.pacnew, pamac.conf.pacnew, pamac.conf.pacnew. Be careful if/when you deal with them. I know from personal experience in another update. :wink:

I have one problem with this new update: I cannot log into Google from Gnome Online Accounts any more. The login-screen simply freezes. Evolution - trying to achieve the same - complains, that the Oauth2 identification does not work. Does anybody here have a fix for that? This is a problem for my business life…

Since update im experience a very short black flickering, even open kate or starting terminal, it shows a strange behavior.

After installing nvidia-settings (i have a 2080Ti) and after a restart it got it reduced a little.

But i just see it flickers again when i openend Steam or right now in Firefox, while i write this message.

I also created a Topic in this Forum and in the nvidia Forum:

EDIT2: Problem is solved, you can find the original answer from dbrhks in the nvidia Forum but @belyash created a little instruction that explains it better, in our Forum:


This has confused me with other updates as well. When I attempt to apply the update listed today (by clicking the icon and it launches Pamac), some 600 of them, when one fails to find dependencies it just stops.

How do you tell it to go to the next and continue?

Cargo update failed

── 21:39:03 - Cargo ───────────────────────────────────────────────────────────
    Polling registry 'https://index.crates.io/'.
Failed to update index repository crates-io: package FileSorterX doesn't exist: HTTP 404.
cargo failed: 
   0: Command failed: `/usr/bin/cargo-install-update install-update --git --all`
   1: `/usr/bin/cargo-install-update` failed: exit status: 2


Backtrace omitted. Run with RUST_BACKTRACE=1 environment variable to display it.
Run with RUST_BACKTRACE=full to include source snippets.

During Topgrade. I tried Topgrade because Discover is borked - it takes 20 seconds before painting a window, and complains no metadata URIs for vendor-directory

After updating, I’m unable to boot because it cannot find the specified cryptdisk. I verified on a live USB from last week that the cryptdisk didn’t change UUID and is mountable. Luckily I was able to revert to an earlier BTRFS snapshot. I did attempt the update again and had the same problem the second time as well (with the same solution). Bummer, cuz I wanted that Plasma 5.27 hotness. I may take a backup and reinstall and go straight to updates before restoring anything to see what happens.

Anybody else having this issue?

tuxedo infinitybook pro 16 - gen 7
3050 Ti

ETA: Can confirm solution described here ([Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #50 by Skunkie) addressed this for me.

1 Like

Here’s what I would try:

set pamac to ignore the problem package and restart the updates:

sudo pamac update --ignore package-name

It should then update the remaining packages.
After completion, try updating the ignored package separately.

Fixed with libxnvctrl 470xx-470.182.03-3.

1 Like

That’s a royal PITA, there appear to be hundreds to ignore…