[Stable Update] 2023-02-12 - Kernels, OpenSSL, Nvidia, Mesa, LibreOffice 7.5, Pamac, Thunderbird

Some software package, is what I think.

or some lib32 libraries haven’t been adjusted (updated) yet… apart from the other system I use jack2 and also some lib32 packages (audio stuff) but that would be very unlikely unless a lib32 GPU library is affected

As previously stated:


Answering my own question about constantly re-enabling powersave power profile – this has now been fixes with either this update, or the one before (I managed to skip that one on my affected computer). Setting Performance, Balanced or Powersave now work as expected.

1 Like

A post was merged into an existing topic: Still no fix to OBS

Desktop system locks up when suspending with kernel 6.1.7 (& 6.1.11)

A post was merged into an existing topic: Still no fix to OBS

Strange that two computers with KDE gets updates, one is fine, the other has the can’t launch and no icons problem.

Very minor regression that I noticed and I’m not even sure what caused it (probably kernel 6.1, I jumped to it with this update): after the PC unlocks or wakes up from sleep, the num lock light on the keyboard stays off. But it’s still on, it’s just the light.

I’m running an Nvidia GPU with the proprietary driver, connected via DisplayPort to a “GSync-compatible” monitor. My desktop is KDE Plasma, under Wayland.

After this update, my monitor was constantly dropping out to a black screen for a few seconds, in what seemed to be a soft reboot of some kind. When the picture reappeared, it would work for a couple of seconds before blacking out again. It stopped when I went into Plasma settings and changed the monitor’s refresh rate to its highest supported rate.

Possibly related is the fact that this update is when the “Adaptive sync: Never/Always/Automatic” drop-down menu appeared for the first time on that same page of Plasma settings. It defaulted to “always,” and changing it to other values does not prevent the constant blackouts when changing the refresh rate.

Not sure if this was said explicitly or not. I added PAMAC_CLI_AUTH=1 to /etc/environment, logged out and logged back in again and now running pamac upgrade in a cli allows authorization natively, no more intrusive pop-up from the GUI asking for a password.

I’m not sure if this is an issue:

(261/410) upgrading manjaro-sway-settings                                                                                                        [########################################################################################] 100%
## updating manjaro-sway-mirrors
## removed classic repo configuration from pacman.conf
## now referencing manjaro-sway.repo.conf from pacman.conf
## manjaro repo configured:
SigLevel = PackageRequired
Server = https://pkg.manjaro-sway.download/stable/$arch
00:00:00.016 [ERROR] [swaymsg/main.c:491] Unable to retrieve socket path
## in order to update your user configuration, run: skel

Jings, I requested this!
Yep, works a treat. My thanks to everyone involved!

1 Like

I’m using KDE, X11 and NVidia. After installing the update, I wasn’t able to launch any application from the application starter or task bar. The icon would briefly show the usual animation, then nothing happend. Luckily, launching applications via krunner still worked!

The log showed errors like this:
kernel: __vm_enough_memory: pid: 1952, comm: plasmashell, no enough memory for the allocation

After some investigation, I found out that this configuration file was corrupted:

The [ScreenMapping] section of the file contained a line with approx. 6 million characters that looked like a comma-separated list of files in my Thunderbird profile. :astonished:

I moved the file to a different place and then rebooted. plasmashell created a fresh config file, and the issue was gone. :+1:

Browing through old backups revealed that the file has been corrupted since nearly half a year, without any observable malfunctions in the Plasma shell. It seems that the latest update brought some changes in the shell that made it less robust against corrupted configurations.


With the newest Vivaldi version — right click doesn’t work anymore!!

Upon further inspection: it works correctly when right clicking fort the first time, and after that it shows the right-click menu for probably couple of milliseconds and then disappears again.

EDIT: After I wrote this, it started working correctly!? Very strange, I have no idea what’s going on.

Wow, great find!!
This also solved the problem form me, I was able to update glibc.

For me removing the [ScreenMapping] section from the ~/.config/plasma-org.kde.plasma.desktop-appletsrc file was sufficient.
Before the section was filled with thousands of entries of files that I temporarily had on my desktop but now no longer existed.

New NVIDIA driver 525.89.02 did not change the issue that I am having with my external DisplayPort monitor described in DisplayPort issues . Behavior is exactly the same as before.

Hello I am just recently updated to the new stable manjaro Plasma release,
After a reboot I am unable to launch & use any application from the start menu, Desktop or the task bar.
When I click on the Program icon, the spinning wheel is visible for some seconds and then it disappears.

The only way I could start programs at moment is via the search bar (ALT-F2, this is unfortunate and I would like to have some help.

Thank you in advance.

Edit: moving ~/.config/plasma-org.kde.plasma.desktop-appletsrc to *.bak and a restart helped for me too. What a strange cause for an error.


I’ve had strange problems in the past where removing that file provided a fix. In that case it was because of one of the widgets I was using (I think WebCut) being out of date vis-a-vis the Plasma API, so it was crashing the whole desktop.
As I keep a bootable partition at the last version for rescue purposes, at least this allowed me to swap between them and test which widget’s removal solved the problem - not so easy without my setup.

After this update, I noticed that my KDE system freezes in the beginning… So when I boot my system > login > it runs first for ~15/~20 seconds great and then it seems to freeze for ~15/~20 seconds and it then works fine after that, for the whole day(s). In the time it freezes I can’t start any application, only move my mouse. So I’m not that worried, but it’s irritating. Anyone else had this problem?

I tried this with kernel 5.15 and 6.1, both gave me the same issue. I also tried to clean the KDE cache, but it didn’t work.

System information
  Host: desktop-pc Kernel: 6.1.11-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.5 Distro: Manjaro Linux
  Type: Desktop Mobo: ASUSTeK model: ROG STRIX X570-E GAMING v: Rev X.0x
    serial: 210383132400210 UEFI: American Megatrends v: 4021 date: 08/09/2021
  Info: 12-core AMD Ryzen 9 5900X [MT MCP] speed (MHz): avg: 2262
    min/max: 2200/4950
  Device-1: AMD Navi 21 [Radeon RX 6800/6800 XT / 6900 XT] driver: amdgpu
    v: kernel
  Device-2: Logitech C922 Pro Stream Webcam type: USB
    driver: snd-usb-audio,uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: amdgpu
    dri: radeonsi gpu: amdgpu resolution: 1: 2560x1440 2: 2560x1440
  API: OpenGL v: 4.6 Mesa 22.3.5 renderer: AMD Radeon RX 6800 XT (navi21
    LLVM 15.0.7 DRM 3.49 6.1.11-1-MANJARO)
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi
  Device-2: Realtek RTL8125 2.5GbE driver: r8169
  Device-3: Intel I211 Gigabit Network driver: igb
  Local Storage: total: 931.51 GiB used: 544.95 GiB (58.5%)
  Processes: 519 Uptime: 2h 48m Memory: 62.71 GiB used: 7.26 GiB (11.6%)
  Shell: Zsh inxi: 3.3.25

sudo journalctl -p 3 -xb

feb 18 11:45:18 desktop-pc kernel: usb 1-4: 1:1: cannot set freq 48000 to ep 0x3
feb 18 13:23:11 desktop-pc konsole[17882]: kf.xmlgui: Shortcut for action  "" "Show Quick Commands" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
feb 18 13:23:11 desktop-pc konsole[17882]: kf.xmlgui: Shortcut for action  "" "Show SSH Manager" set with QAction::setShortcut()! Use KActionCollection::setDefaultShortcut(s) instead.
1 Like