[Stable Update] 2023-01-24 - Kernels, Plasma, Frameworks, Gear, Libreoffice, Mesa, Nvidia, Deepin

more likely a wayland issue…

When running DBeaver I needed to set default java version to 19 in order to Dbeaver to start. Default version was set to java-8-openjdk/jre.

This solved the issue:
sudo archlinux-java set java-19-openjdk

1 Like


1 Like

Hey, first time posting here, and first month using Linux outside of experiments with VMs! So forgive me if anything sounds a bit noob-ish.

There’s an issue with Krita, specifically when opening the G’MIC-qt plugin to apply filters. I get an error message saying “Krita cannot launch the gmic-qt plugin. No bundled library found.” and I simply cannot use those filters.

So far this seems to be the only issue, we’ll see if that remains the case.

1 Like

I’m using a Lenovo ThinkPad T14gen2 AMD and a Lenovo USB-C DockingStation 40AS0090EU.
With kernel 6.0 I have no problems, but with all kernels 6.1 the connected displays will not wake up after a suspend of the notebook. Even a reboot with kernel 6.1 will not switch the external displays on. I have to boot with kernel 6.0 and everything is fine again.

When the problem shows up, and I switch of the displays with the hardware buttons, it’s detected by the os and the main task bar is moved to the notebook display. When I then switch the displays again on, they stay in power safe mode.

Is this behaviour known?
Can I do something myself to convince the kernel 6.1 to switch the displays on?

OBS does not start anymore (flatpack version runs without problems) obsdebug: Found portal inhibitordebug: Attempted path: share/obs/obs-studio/ - Pastebin.com
VLC crash if a video is loaded (can fix this if I set output to vdpau) vlcVLC media player 3.0.18 Vetinari (revision 3.0.13-8-g41878ff4f2)[0000559a - Pastebin.com


A post was split to a new topic: Installing libplacebo (5.229.1-2) breaks dependency ‘libplacebo.so=208-64’ required by jellyfin-ffmpeg5

I am experiencing the following:

sudo pamac update                                                                              ✔  21s  
Synchronizing package databases...
https://packages.manjaro-sway.download/x86_64/manjaro-sway.db: Error 404
Failed to synchronize databases

I tried refreshing mirrors with both:

sudo pacman-mirrors --continent
sudo pacman-mirrors --geoip

Both mirror refreshes work but still give me the error when running sudo pamac update. :man_shrugging:

And this update breaks… OBS, nice one.

 error: VAAPI: Failed to initialize display in vaapi_device_h264_supported
 Segmentation fault (core dumped)

I could fix it. I installed libva-nvidia-driver from aur.
that fixed my vlc problem, too

1 Like

If it works for you it’s ok, but THAT’S NOT A SOLUTION, AUR is not supported by Manjaro, as stated here. They need to fix this so we can use the official repos with no more issues.

yes. but if you need obs, like me, then it could be a fix for until they fixed it officially

Let’s hope you don’t have any other problem in your OS before a fix arrives and you get a “oh but you are using an AUR package, that’s not supported, we won’t help you” when you try to look for help in this forum. :crossed_fingers:

1 Like

I had the problem with crashing VLC, too. I’m running Plasma with X11 on an Nvidia card. Here’s the message from the vlc.log:

gl: Initialized libplacebo v5.229.0 (API v229)
glconv_vaapi_x11 error: vaInitialize: unknown libva error

I found a thread in the Archlinux BBS regarding this topic:

They suggested downgrading libva from version 2.17.0 to 2.16.0. That solved the issue for me. :slightly_smiling_face:


that might be something to do with Libva 2.17.0 update

Kernel 6.1.7 appears to be still broken for users of Mediatek wifi (mt76). Stay with 6.0 (eol) or 5.15 if you have mediatek wifi and you experience full system freeze.

This is strange, because the patch appears to be accepted in arch kernel 6.1.7.arch1-1.

I discovered warning messages in /var/log/pacman.log
How do I fix these? (terminal commands please)

warning: directory permissions differ on /var/log/swtpm/libvirt/qemu/

Hmm, forgot that was there.

I just added an environment variable. See Hardware video acceleration - ArchWiki


AMDVLK now instantly crashing upon trying to launch anything, was working ok on the previous version…

1 Like

Why are you using AMDVLK instead of the built-in AMDGPU kernel driver? Please create a new #support:graphic-cards topic for troubleshooting and further discussion.

1 Like