[Stable Update] 2022-12-24 - Kernels, XFCE, Systemd, Thunderbird, KDE-Git

for me it’s not,
i went back to 6.0

1 Like

Linux trickeries no doubt…

Merry Christmas :santa::christmas_tree:
Switched to 6.1 Kernel
And keep as fallback 5.15
I know we shouldn’t post working things but no issues so far with 6.1 :vulcan_salute:


How do I fix this error?

[manjaro@manjaro tmp]$ sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
 sublime-text is up to date
:: Starting full system upgrade...
warning: scrot: ignoring package upgrade (1.6-2 => 1.7-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing db (6.2.32-1) breaks dependency 'db=5.3.28' required by lib32-db

thanks, removing lib32-db was the solution


Switching open tabs in Kate has become terribly slow.
edit: fixed after another reboot.

Blessed Christmas everyone. :christmas_tree:

Just minor insignificant little issue during upgrade.

If you already have "The North" wallpaper (I manually added it before) you have to remove it … or upgrade won’t move through that part.

sudo rm --recursive --dir /usr/share/wallpapers/North/

:: Starting full system upgrade…
:: Replace manjaro-mirrors with core/pacman-mirrors? [Y/n] y
resolving dependencies…
looking for conflicting packages…

How come manjaro-mirrors replace pacman-mirrors but the pacman mirrorlist generator application is still using pacman-mirrors command ?

# manjaro-mirrors --help
zsh: command not found: manjaro-mirrors
pacman-mirrors --help                                                                             127 ✘ 
Version 4.23.2
 pacman-mirrors [-h] [-f [NUMBER]] [-i [-d]] [-m METHOD] [--status]
		[-c COUNTRY [COUNTRY...] | [--geoip] | [--continent]]
		[-l] [-lc] [-q] [-t SECONDS] [-v] [-n]
		[--api] [-S/-B BRANCH] [-p PREFIX]
			[-P PROTO [PROTO...]] [-R] [-U URL]

It’s like you installed neofetch package but the command to actually run neofetch is clearfetch. :joy:
I think it would be better to re write the program manjaro-mirrors which uses manjaro-mirror as it’s command rather than something else. It would also be better to update the Manjaro website as well.
Just saying :slight_smile:

1 Like
  1. Please read more carefuly: your quoted output states pacman-mirrors replacing manjaro-mirrors.
  2. Binaries provided via a package do not need to have the same name.
  3. That renaming already was covered enough in this forum, please search (more) before posting.

Merry X-mas everyone :christmas_tree:

What was that one command again which shows which package requires non-installed dependency XYZ?

An unknown package want to install an non-existant package called “clap-host”, but because it isn’t available, the alternatives are complete music studio software DAWs qtracktor and reaper. I do not want that.

sudo pactree -r clap-host
sudo pacman -Qi clap-host
sudo pacman -Si clap-host

All tell “package ‘clap-host’ not found”.

And I do not have any of the required packages at AUR (en) - clap-host installed.

Nevermind, I figured out myself by digging through the requirements of Arch Linux - qtractor 0.9.29-3 (x86_64)

Turns out Arch Linux - easyeffects 7.0.0-2 (x86_64) is the culprit.

Apparently it optionally required the complete Arch Linux - zam-plugins 4.1-2 (x86_64) in the past. That package got split up, and easyeffects only optionally requires zam-plugins-lv2 now. upgpkg: easyeffects 7.0.0-2: Optdepend on split package for maximizer · archlinux/svntogit-community@763a397 · GitHub

However, since zam-plugins was already installed, pamac does not figure out that zam-plugins need to be removed, and only zam-plugins-lv2 needs to be installed.

pacman -Rns zam-plugins
pacman -S zam-plugins-lv2
pacman -D --asdeps zam-plugins-lv2

BTW there is a pacnew again for /usr/share/icons/default/index.theme which belongs to extra/libxcursor

With the following diff:

< [Icon Theme]
< Inherits=Adwaita
> [icon theme]
> Inherits=xcursor-breeze

The file was created (also with a pacnew, thus it didn’t exist beforehand) during one of the other upgrades in December.
However, the file seems to be completely removed again in the new version: 1.2.1-3: use default-cursors · archlinux/svntogit-packages@baf6851 · GitHub
(The package extra/libxcursor is not in Manjaro’s package repositories: Packages · GitLab).

What is going on? Just upstream noobing around?

Here on my end it seems all is fine. But I couldn’t find a way to make it work with AMD cpu/gpu without downgrading MESA to 22.2. Tried following other topics, installed mesa-git but then had to install many other packages and even then couldn’t make it work properly. So, for now, I can only stay with this version of MESA.

I can only assume zam-plugins and the various dependencies are for some sort of specialised audio processing, as I’ve removed them all and can still play all the audio I need without them.


I’m having issues with Firefox and VLC. If I lock the screen Firefox tends to crash and VLC doesn’t always resuming play the video I was playing.

4 posts were split to a new topic: Manjaro-cinnamon-settings and manjaro-gnome-settings are in conflict

A post was merged into an existing topic: Manjaro-cinnamon-settings and manjaro-gnome-settings are in conflict

After the command sudo pamac update, I get the following output:

Checking inter-conflicts...
Error: unresolvable package conflicts detected
Error: Failed to prepare transaction:
conflicting dependencies:
pipewire-jack and jack2 are in conflict

Because I’m using pipewire with no issues (yet) I tried to remove jack2.
That gives the following output:

Error: target not found: jack2

What can I do?

Any pipewire-jack conflict with bonafide JACK packages should have been resolved when pipewire-jack was installed

To find what JACK packages are installed on system

pamac search -i jack

Blockquote signature from “Manjaro Build Server <build_at_manjaro_dot_org>” is unknown trust

again? thought signatures were fixed for good

The latest update to the 6.1 kernel locks the computer when opening Steam. It first flashes and doesn’t let me do anything, sometimes it just lockups, other times it drops to the login screen.

I was able to change to another console and run dmesg, there were a lot of errors about GPU resetting. When booting kernel 5.15 the problem is not present.

  Host: ProBook445G8-1 Kernel: 5.15.85-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5 Distro: Manjaro Linux
  Type: Laptop System: HP product: HP ProBook 445 G8 Notebook PC v: N/A
    serial: <superuser required>
  Mobo: HP model: 8861 v: KBC Version 41.27.00 serial: <superuser required>
    UEFI: HP v: T78 Ver. 01.10.00 date: 07/13/2022
  ID-1: BAT0 charge: 32.0 Wh (96.4%) condition: 33.2/45.0 Wh (73.7%)
  Info: 6-core AMD Ryzen 5 5600U with Radeon Graphics [MT MCP] speed (MHz):
    avg: 1878 min/max: 1600/4288
  Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-2: Quanta HP HD Camera type: USB driver: uvcvideo
  Display: x11 server: X.org v: driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1920x1080
  API: OpenGL Message: No GL data found on this system.
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi
  Local Storage: total: 238.47 GiB used: 127.55 GiB (53.5%)
  Processes: 299 Uptime: 16m Memory: 14.95 GiB used: 2.9 GiB (19.4%)
  Shell: Zsh inxi: 3.3.24