[Stable Update] 2022-12-20 - Kernels, XFCE 4.18, KDE Frameworks, Kde Gear, Mesa, Plasma-Mobile, Thunderbird, Firefox

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2022-12-20

pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


python-cairo 1.23.0-2 update requires manual intervention

The python-cairo package prior to version 1.23.0-2 was missing the compiled python module. This has been fixed in 1.23.0-2, so the upgrade will need to overwrite the untracked pyc file that was created. If you receive this error

python-cairo: /usr/lib/python3.10/site-packages/cairo/__pycache__/__init__.cpython-310.pyc exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/python3.10/site-packages/cairo/__pycache__/\*

to perform the upgrade.


We recommend to install openssl-1.1

Due to the update to openssl 3.0 some things still look for the older LTS version 1.1. You may install openssl-1.1 and maybe lib32-openssl-1.1 packages. However report such issues to us.

Known issues:

  • some SDDM themes might not work
  • dkms might not sign modules properly as header files may still depend on 1.1 version of openssl

Issues reported to Archlinux so far:

FS#76567 : [plasma-framework] 5.99.0 needs a rebuild against openssl 3.0

libx11 1.8.2 causes firefox to freeze

libx11 1.8.2 causes Firefox to freeze, mainly when highlighting text and copying things to the clipboard (e.g. password manager).

Issues reported:

Workaround (UNTESTED - at your own risk!):
Install the AUR Package libx11-firefox-fix

Kernel 6.0: AMDGPU - Screen freezes when waking from hibernation or suspend

Screen doesn't turn on when waking from suspend: Failed to pin framebuffer with error -19 (#2213) · Issues · drm / amd · GitLab

Mesa 22.2.x renders Calamares black on Gnome Development ISOs

For some yet unknown reason Calamares is rendered black on Gnome when Mesa 22.2.x is used. Current workaround is to install 22.1.x series and relogin to the live-session.


Kernel 6.1-rc# might break backlight control on old/weird laptops, please test



signature from "Manjaro Build Server <build_at_manjaro_dot_org>" is unknown trust

Seems our signing key for our Build Server had the 2022-10-28 as expire date set when generated. This is now fixed for chroot builds and fresh as also current existing installs via manjaro-keyring 20221028-4 Simply update your system to get that package, which got pushed to all our branches.

NVIDIA 520.56.06 - 525.60.11 Color banding and animation issues

Current (not so good) Workaround:

  • Open nvidia-settings
  • Select the problematic monitor under the GPU Tab (e.g. DP-0 - (LG ...))
  • Under Controls, change Depth to 6 bpc and set dither mode to temporal (or play with the Dithering Controls)

NVIDIA already replied to the Bug-Report, so there is a good chance that this issue will be fixed with the next NVIDIA driver release.


Best distro ever & Best founder


Hi, when it will be available as sudo pacman -Syyu says there is nothing to upgrade?
Edit: Ok mirror is not synced yet :wink:


Indeed, it can take minutes to several hours before the mirrors catch up with the updates, depending on the mirror.

1 Like

As Philm wrote, problem importing keys with dbus, I followed his instructions and no more problem.

How to continue?

error: failed to prepare transaction (could not satisfy dependencies)
:: installing db (6.2.32-1) breaks dependency ‘db=5.3.28’ required by lib32-db


After package upgrade and after switched to 6.1 kernel, audio HDMI output stopped working using Dock.
Connection scheme is like this: Notebook <-(USB-C)-> Lenovo ThinkPad USB-C Dock <-(DP-HDMI)-> Dell S2721DGFA Monitor

Edit: Using direct connection trough HDMI, the sound is not working neither.

Before upgrade and on Kernel 6.0x it was working.

inxi -F
  Host: petr-t14 Kernel: 6.1.0-1-MANJARO arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.26.4 Distro: Manjaro Linux
  Type: Laptop System: LENOVO product: 21CGS1ES00 v: ThinkPad T14 Gen 3
    serial: <superuser required>
  Mobo: LENOVO model: 21CGS1ES00 v: ThinkPad serial: <superuser required>
    UEFI: LENOVO v: R23ET60W (1.30 ) date: 09/14/2022
  ID-1: BAT0 charge: 46.8 Wh (89.1%) condition: 52.5/52.5 Wh (100.0%)
  Info: 8-core model: AMD Ryzen 7 PRO 6850U with Radeon Graphics bits: 64
    type: MT MCP cache: L2: 4 MiB
  Speed (MHz): avg: 1709 min/max: 1600/4767 cores: 1: 2700 2: 1382 3: 1600
    4: 1600 5: 1397 6: 1600 7: 1600 8: 1600 9: 1600 10: 2700 11: 1600 12: 1600
    13: 1600 14: 1600 15: 1600 16: 1577
  Device-1: AMD Rembrandt [Radeon 680M] driver: amdgpu v: kernel
  Device-2: Luxvisions Innotech Integrated RGB Camera type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.6 driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution:
    1: 2560x1440~60Hz 2: 1920x1200~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.1 renderer: AMD Radeon Graphics (rembrandt
    LLVM 14.0.6 DRM 3.49 6.1.0-1-MANJARO)
  Device-1: AMD Rembrandt Radeon High Definition Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp6x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Device-4: SteelSeries ApS Arctis 5 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-5: Lenovo ThinkPad Dock Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.0-1-MANJARO running: yes
  Sound Server-1: PulseAudio v: 16.1 running: yes
  Sound Server-2: PipeWire v: 0.3.63 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: enp1s0f0 state: down mac: 9c:2d:cd:7c:f0:1d
  Device-2: Qualcomm QCNFA765 Wireless Network Adapter driver: ath11k_pci
  IF: wlp2s0 state: up mac: 04:7b:cb:b4:4a:a6
  Device-3: Lenovo ThinkPad Dock Ethernet [Realtek RTL8153B] type: USB
    driver: r8152
  IF: enp5s0f3u1u1 state: down mac: 3c:e1:a1:4b:60:05
  IF-ID-1: br-5f96bcf192b6 state: down mac: 02:42:ec:22:3a:9d
  IF-ID-2: docker0 state: down mac: 02:42:f0:0c:62:34
  IF-ID-3: wwp4s0f3u4i1 state: unknown mac: a6:7d:e7:5f:bc:ed
  Device-1: USI type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Local Storage: total: 953.87 GiB used: 426.2 GiB (44.7%)
  ID-1: /dev/nvme0n1 vendor: SanDisk model: SKHynix HFS001TEJ9X102N
    size: 953.87 GiB
  ID-1: / size: 904.9 GiB used: 426.17 GiB (47.1%) fs: ext4 dev: /dev/dm-0
  ID-2: /boot/efi size: 299.4 MiB used: 33.8 MiB (11.3%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-1: swap-1 type: partition size: 33.14 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-1
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: amdgpu temp: 45.0 C
  Fan Speeds (RPM): fan-1: 2262
  Processes: 413 Uptime: 2m Memory: 30.13 GiB used: 4.48 GiB (14.9%)
  Shell: Zsh inxi: 3.3.24

Ideas? Thanks


Shotwell / photo program does not start, in the terminal it reports:

❯ shotwell
shotwell: error while loading shared libraries: libraw.so.20: cannot open shared object file: No such file or directory

libraw is installed, pamac shows:


Would an alias or something else solve this, and if yes, what would that be??

edit: copied /usr/lib/libraw.so.23 to /usr/lib/libraw.so.20 and now shotwell runs, but that is only a workaround for now, I guess.

To all the strong souls still using KDE Plasma 5.24.7 LTS, I will see you on the other side. :cry:

1 Like

On KDE Plasma…

  • all my documents on the desktop got rearranged and moved to the top of the screen
  • the desktop background image was replaced with another image
  • there was a new panel added at the bottom of the desktop

I had the same error. I simply removed the lib32-db package and then everything worked just fine.

The only thing I’ve really noticed so far is that the Kate widget is now gone, for those of you who’ve added it to a panel or had it visible in the system tray. The icon can be put back, but it is no longer a widget now — it is now merely a launcher for Kate.

Everything else still appears to look fine in Plasma 5.24.7 LTS. :man_shrugging:

There was however a problem when using pamac to try and update the AUR packages, while yay had no problem doing so. See the following thread. :arrow_down:


HDMI is not detecting external display after the update. Anyone facing similar issue?

1 Like

Yes, sometimes it works (after reboot) but I was facing similar issues with HDMI output and the Dock. (Lenovo T14 G3 AMD). HDMI audio was broken completely. I reverted to 6.0 kernel and it’s working again.

1 Like

So… I want to ask if those 6.1 is stable enough to use on host system. But I see it’s not, so I will stay on 5.15. Until 6.1 get some patches.
I think it’s time to make my grub visible again :joy:

After my update today, remmina was not working anymore.

After ** Message: 16:25:46.796: [X2GO] X2Go plugin loaded. it would simply coredump.
Turns out the problem is /usr/lib/remmina/plugins/remmina-plugin-www.so.
I removed the library from the plugins-directory, and now everything is fine - seems I do not need the plugin.

For some reason, remmina forgot mv VNC password - I guess this was due to moving plugin libraries in and out of the plugin directory to see which one was responsible for the core dumps.

What is the correct way to proceed with this? File a bug report for remmina, or for manjaro?

I’ve got an issue on one machine with keyring. do you know a safe way to solve that ?
Thanks for your work :+1:

Procéder à l’installation ? [O/n] o
(163/163) vérification des clés dans le trousseau  [######################] 100%
téléchargement des clés requises…
:: Importer la clé PGP 139B09DA5BF0D338, « David Runge <dvzrv@archlinux.org> » ? [O/n] O
erreur : la clé « 139B09DA5BF0D338 » n’a pas pu être importée

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

could someone please report if the audio issue was fixed in the Kernel 5.15.
I’m currently on 6.0 which was the solution,but want to revert back to the LTS one.

What was the the default font for clock app (XFCE)?

It was Sans Regular. It got changed to Sans Regular 8. I changed mine to Sans Bold 10. (XFCE)

Can’t boot into

  • linux60 6.0.14
  • linux61 6.1.0

anymore. 5.15 LTS still works. I have a nvidia 2080 and I did an pamac upgrade before the issues